aboutsummaryrefslogtreecommitdiff
path: root/www/linux-flashplugin7/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-01 08:19:34 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-01 08:19:34 +0000
commit6891a6b82959a909848944fc2691de8cd199c09a (patch)
tree8b526991da19ff7fc0352508be1010f514e36143 /www/linux-flashplugin7/Makefile
parentbfd1d7d25e520d5c07bf73aba083ae7a8ccf584e (diff)
downloadports-6891a6b82959a909848944fc2691de8cd199c09a.tar.gz
ports-6891a6b82959a909848944fc2691de8cd199c09a.zip
- Add support for NPAPI infrastructure
- Reflect Macromedia->Adobe change - Move plist to Makefile - Update pkg-descr Approved by: Jamie Jones <jamie@bishopston.net> (maintainer)
Notes
Notes: svn path=/head/; revision=169315
Diffstat (limited to 'www/linux-flashplugin7/Makefile')
-rw-r--r--www/linux-flashplugin7/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/www/linux-flashplugin7/Makefile b/www/linux-flashplugin7/Makefile
index bd4e6a33140e..1a1707e515bd 100644
--- a/www/linux-flashplugin7/Makefile
+++ b/www/linux-flashplugin7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= flashplugin
PORTVERSION= 7.0r63
+PORTREVISION= 1
CATEGORIES= www multimedia linux
MASTER_SITES= http://fpdownload.macromedia.com/get/flashplayer/current/
PKGNAMEPREFIX= linux-
@@ -14,31 +15,26 @@ DISTNAME= install_flash_player_7_linux
DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= jamie@bishopston.net
-COMMENT= The official Macromedia Flash Player for Linux Mozilla and Netscape 6+
+COMMENT= Adobe Flash Player NPAPI Plugin
ONLY_FOR_ARCHS= amd64 i386
USE_LINUX= yes
-USE_X_PREFIX= yes
RESTRICTED= Redistribution not allowed
NO_BUILD= yes
WRKSRC= ${WRKDIR}/install_flash_player_7_linux
LATEST_LINK= flash7
+PORTDOCS= Readme.txt Readme.htm
-LIBFILES= libflashplayer.so flashplayer.xpt
+USE_NPAPI= linux-*
+NPAPI_FILES= libflashplayer.so flashplayer.xpt
-DOCSDIR?= ${PREFIX}/share/doc/${UNIQUENAME}
-
-do-install:
- @${MKDIR} ${PREFIX}/lib/linux-flashplugin7
-.for f in ${LIBFILES}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/lib/linux-flashplugin7
-.endfor
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/Readme.txt ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/Readme.htm ${DOCSDIR}
+post-install:
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
+.include "${.CURDIR}/../linux-mplayer-plugin/Makefile.npapi"
.include <bsd.port.mk>