aboutsummaryrefslogtreecommitdiff
path: root/www/linux-mozilla
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2004-01-22 09:02:09 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2004-01-22 09:02:09 +0000
commit0761b45da216f3eb45210b13ce1aa9ecf745b926 (patch)
tree0d39500438617e9c26a4daf53c5c6ec9cb2b6f7c /www/linux-mozilla
parent4032f42aeee2753067c6e391f34fd57f6a67d068 (diff)
downloadports-0761b45da216f3eb45210b13ce1aa9ecf745b926.tar.gz
ports-0761b45da216f3eb45210b13ce1aa9ecf745b926.zip
Remove checksum target, which is no longer needed and causes "make
index" to generate a warning message (requested by kris).
Notes
Notes: svn path=/head/; revision=98765
Diffstat (limited to 'www/linux-mozilla')
-rw-r--r--www/linux-mozilla/Makefile31
1 files changed, 0 insertions, 31 deletions
diff --git a/www/linux-mozilla/Makefile b/www/linux-mozilla/Makefile
index 3969190367c2..88071cbc350a 100644
--- a/www/linux-mozilla/Makefile
+++ b/www/linux-mozilla/Makefile
@@ -63,37 +63,6 @@ DISTFILES= browser.xpi \
DISTFILES!= ${CAT} ${WRKDIRPREFIX}${.CURDIR}/work/xpi/components.conf
.endif
-checksum:
-.if !defined(REAL_EXTRACT)
- @cd ${.CURDIR} && ${MAKE} ${__softMAKEFLAGS} fetch
-.endif
- @if [ ! -f ${MD5_FILE} ]; then \
- ${ECHO_MSG} ">> No MD5 checksum file."; \
- else \
- (cd ${DISTDIR}; OK="true"; \
- for file in ${_CKSUMFILES}; do \
- if [ -r $$file ]; then \
- CKSUM=`${MD5} < $$file`; \
- CKSUM2=`${GREP} "^MD5 ($$file)" ${MD5_FILE} | ${AWK} '{print $$4}'`; \
- if [ "$$CKSUM2" = "" ]; then \
- ${ECHO_MSG} ">> No checksum recorded for $$file."; \
- OK="false"; \
- elif ${EXPR} "$$CKSUM2" : ".*$$CKSUM" > /dev/null; then \
- ${ECHO_MSG} ">> Checksum OK for $$file."; \
- else \
- ${ECHO_MSG} ">> Checksum mismatch for $$file."; \
- OK="false"; \
- fi; \
- fi; \
- done; \
- if [ "$$OK" != "true" ]; then \
- ${ECHO_MSG} "Make sure the Makefile and distinfo file (${MD5_FILE})"; \
- ${ECHO_MSG} "are up to date. If you are absolutely sure you want to override this"; \
- ${ECHO_MSG} "check, type \"make NO_CHECKSUM=yes [other args]\"."; \
- exit 1; \
- fi) ; \
- fi
-
do-extract:
${MKDIR} ${WRKSRC}
.for i in ${DISTFILES}