aboutsummaryrefslogtreecommitdiff
path: root/www/linux-opera/Makefile
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2000-12-13 14:28:53 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2000-12-13 14:28:53 +0000
commit5b5a4764de085ddf3283cd12a0ab55d9234dedf1 (patch)
tree596c11a3cdce3cb5e401082848986abefc8dbb65 /www/linux-opera/Makefile
parent347fe2f8a84be3c920732ff2c32cee085ba5518b (diff)
downloadports-5b5a4764de085ddf3283cd12a0ab55d9234dedf1.tar.gz
ports-5b5a4764de085ddf3283cd12a0ab55d9234dedf1.zip
Upgrade to 4.0b4.
Submitted by: jedgar
Notes
Notes: svn path=/head/; revision=35954
Diffstat (limited to 'www/linux-opera/Makefile')
-rw-r--r--www/linux-opera/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/www/linux-opera/Makefile b/www/linux-opera/Makefile
index 4415b429c0e8..a7497d114697 100644
--- a/www/linux-opera/Makefile
+++ b/www/linux-opera/Makefile
@@ -6,25 +6,26 @@
#
PORTNAME= linux-opera
-PORTVERSION= 4.0b3
+PORTVERSION= 4.0b4
CATEGORIES= www linux
MASTER_SITES= http://opera.online.no/linux/tgz/
-DISTNAME= opera-4.0-b3-static.i386
+DISTNAME= opera-4.0-b4-20001211.012-static.i386
MAINTAINER= des@FreeBSD.org
-RUN_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_base \
- /compat/linux/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg
+RUN_DEPENDS= ${LINUXBASE}/lib/ld.so:${PORTSDIR}/emulators/linux_base \
+ ${LINUXBASE}/usr/lib/libpng.so.2:${PORTSDIR}/graphics/linux-png \
+ ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg
NO_BUILD= yes
do-configure:
- ${SED} 's|%%PREFIX%%|${PREFIX}|; s|%%DISTNAME%%|${DISTNAME}|' \
- <${FILESDIR}/opera.sh >${WRKDIR}/opera.sh
+ ${SED} 's|%%PREFIX%%|${PREFIX}|' <${FILESDIR}/opera.sh >${WRKDIR}/opera
do-install:
- (cd ${WRKDIR} && \
- tar cf - ${DISTNAME} | tar --unlink -xpf - -C ${PREFIX})
- ${INSTALL_SCRIPT} ${WRKDIR}/opera.sh ${PREFIX}/bin/opera
+ ${MKDIR} ${PREFIX}/opera-4.0
+ (cd ${WRKSRC} && \
+ tar cf - . | tar --unlink -xpf - -C ${PREFIX}/opera-4.0)
+ ${INSTALL_SCRIPT} ${WRKDIR}/opera ${PREFIX}/bin/opera
.include <bsd.port.mk>