aboutsummaryrefslogtreecommitdiff
path: root/www/mapedit
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-03-17 22:45:48 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-03-17 22:45:48 +0000
commitd9808168fd671f0cda5d64ed1b94535c4358291e (patch)
tree3eaec1da10953fc4b1835cc90852dfc84ce9d947 /www/mapedit
parentfc94a9d79622b69da048a2d3170b9dcffe629322 (diff)
downloadports-d9808168fd671f0cda5d64ed1b94535c4358291e.tar.gz
ports-d9808168fd671f0cda5d64ed1b94535c4358291e.zip
A WWW authoring tool to create clickable maps.
Submitted by: Andreas Klemm <andreas@knobel.gun.de>
Notes
Notes: svn path=/head/; revision=2847
Diffstat (limited to 'www/mapedit')
-rw-r--r--www/mapedit/Makefile33
-rw-r--r--www/mapedit/distinfo1
-rw-r--r--www/mapedit/files/COPYRIGHT10
-rw-r--r--www/mapedit/files/patch-aa13
-rw-r--r--www/mapedit/pkg-comment1
-rw-r--r--www/mapedit/pkg-descr45
-rw-r--r--www/mapedit/pkg-plist4
7 files changed, 107 insertions, 0 deletions
diff --git a/www/mapedit/Makefile b/www/mapedit/Makefile
new file mode 100644
index 000000000000..c18e7a97bc0d
--- /dev/null
+++ b/www/mapedit/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mapedit
+# Version required: 1.5
+# Date created: Sun Mar 17 17:59:48 MET 1996
+# Whom: Andreas Klemm <andreas@knobel.gun.de>
+#
+# $Id$
+#
+
+DISTNAME= mapedit1.5
+PKGNAME= mapedit-1.5
+CATEGORIES+= www
+MASTER_SITES= ftp://ftp.boutell.com/pub/boutell/mapedit/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= andreas@knobel.gun.de
+
+USE_IMAKE= yes
+NO_INSTALL_MANPAGES= yes
+DOCDIR= ${PREFIX}/lib/X11/mapedit
+
+pre-install:
+ @cat ${FILESDIR}/COPYRIGHT
+ @echo ""
+ @cat ${WRKSRC}/README
+ @echo ""
+
+post-install:
+ mkdir -p ${DOCDIR}
+ cp ${WRKSRC}/LICENSE ${DOCDIR}
+ cp ${WRKSRC}/README ${DOCDIR}
+ cp ${WRKSRC}/mapedit.html ${DOCDIR}
+
+.include <bsd.port.mk>
diff --git a/www/mapedit/distinfo b/www/mapedit/distinfo
new file mode 100644
index 000000000000..7ce2bf879ea2
--- /dev/null
+++ b/www/mapedit/distinfo
@@ -0,0 +1 @@
+MD5 (mapedit1.5.tar.Z) = 7ad4bd45951dc2e07bad032379e96ed2
diff --git a/www/mapedit/files/COPYRIGHT b/www/mapedit/files/COPYRIGHT
new file mode 100644
index 000000000000..79e08d4cadfc
--- /dev/null
+++ b/www/mapedit/files/COPYRIGHT
@@ -0,0 +1,10 @@
+Copyright 1994 by Thomas Boutell. THIS IS NOT PUBLIC DOMAIN SOFTWARE.
+Commercial users must pay for it to continue using it after 30
+days. You need not register again when new versions are released.
+Please remit $25 to:
+
+Thomas Boutell
+426 Bellevue Ave. E Apt. 1
+Seattle, WA 98102 USA
+
+Nonprofit and educational users are required to send me a postcard!
diff --git a/www/mapedit/files/patch-aa b/www/mapedit/files/patch-aa
new file mode 100644
index 000000000000..e9165ace2434
--- /dev/null
+++ b/www/mapedit/files/patch-aa
@@ -0,0 +1,13 @@
+*** gd.c.orig Sun Mar 17 19:28:12 1996
+--- gd.c Sun Mar 17 19:29:10 1996
+***************
+*** 1,4 ****
+--- 1,8 ----
++ #ifdef __FreeBSD__
++ #include <stdlib.h>
++ #else
+ #include <malloc.h>
++ #endif
+ #include <stdio.h>
+ #include <math.h>
+ #include <string.h>
diff --git a/www/mapedit/pkg-comment b/www/mapedit/pkg-comment
new file mode 100644
index 000000000000..6a3eaa4030e7
--- /dev/null
+++ b/www/mapedit/pkg-comment
@@ -0,0 +1 @@
+A WWW authoring tool to create clickable maps
diff --git a/www/mapedit/pkg-descr b/www/mapedit/pkg-descr
new file mode 100644
index 000000000000..87d80283a6cd
--- /dev/null
+++ b/www/mapedit/pkg-descr
@@ -0,0 +1,45 @@
+An important note from the port maintainer
+ (Andreas Klemm <andreas@knobel.gun.de>)
+
+Please note: mapedit is NOT public domain software
+==================================================
+
+Credits and license terms
+=========================
+
+Copyright 1994 by Thomas Boutell. THIS IS NOT PUBLIC DOMAIN SOFTWARE.
+Commercial users must pay for it to continue using it after 30
+days. You need not register again when new versions are released.
+Please remit $25 to:
+
+Thomas Boutell
+426 Bellevue Ave. E Apt. 1
+Seattle, WA 98102 USA
+
+Nonprofit and educational users are required to send me a postcard!
+
+What is mapedit?
+================
+
+mapedit is a WYSIWYG (What You See Is What You Get) editor for
+imagemap files.
+
+Imagemap files are a feature of both NCSA and CERN httpd servers;
+they allow you to turn a GIF into a clickable map by designating
+polygons, circles and rectangles within the GIF and specifying a
+URL for each to link to.
+
+Unfortunately, creating good image maps by hand is a lot of work,
+because the points must be located using an editor not explicitly
+designed for the purpose.
+
+mapedit allows you to load your GIF image into a scrollable,
+resizable window and then draw polygons, circles and rectangles on
+top of it, specifying a URL for each. It also allows you to go back
+and delete these "hot spots", set a default URL for clicks outside
+of the "hot" areas, and so on. In addition, it allows you to
+associate comments of arbitrary length with each object if you have
+a server that accepts the NCSA imagemap format.
+
+Please take a look at the file /usr/X11R6/lib/X11/mapedit/mapedit.html
+for full usage documentation.
diff --git a/www/mapedit/pkg-plist b/www/mapedit/pkg-plist
new file mode 100644
index 000000000000..c40adf20a3df
--- /dev/null
+++ b/www/mapedit/pkg-plist
@@ -0,0 +1,4 @@
+bin/mapedit
+lib/X11/mapedit/LICENSE
+lib/X11/mapedit/README
+lib/X11/mapedit/mapedit.html