aboutsummaryrefslogtreecommitdiff
path: root/www/midori
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2012-05-08 20:02:17 +0000
committerRene Ladan <rene@FreeBSD.org>2012-05-08 20:02:17 +0000
commitab28b4a77003f231fe2f252e32b25fb1b24bb81d (patch)
tree979dc0a7c6945bbcf79e105a98bc3bccf52f1f0d /www/midori
parente0675a36f9f70c432e494fc290b6745d9e674e4c (diff)
downloadports-ab28b4a77003f231fe2f252e32b25fb1b24bb81d.tar.gz
ports-ab28b4a77003f231fe2f252e32b25fb1b24bb81d.zip
Update to 0.4.5
Changelog: http://mail.xfce.org/pipermail/xfce/2012-April/030296.html PR: ports/167536 Submitted by: Olivier Duchateau
Notes
Notes: svn path=/head/; revision=296245
Diffstat (limited to 'www/midori')
-rw-r--r--www/midori/Makefile7
-rw-r--r--www/midori/distinfo4
-rw-r--r--www/midori/files/patch-extensions__wscript_build12
-rw-r--r--www/midori/files/patch-midori_midori-websettings.c50
-rw-r--r--www/midori/files/patch-wscript13
-rw-r--r--www/midori/pkg-plist2
6 files changed, 30 insertions, 58 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index e255491bcca4..88df6b84ca38 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= midori
-PORTVERSION= 0.4.4
-PORTREVISION= 1
+PORTVERSION= 0.4.5
CATEGORIES= www xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/${PORTVERSION:R}
@@ -87,8 +86,8 @@ post-install:
.if defined(WITH_APIDOCS)
${MKDIR} ${DOCSDIR}/api/katze/html
${MKDIR} ${DOCSDIR}/api/midori/html
- (cd ${WRKSRC}/_build_/docs/api/katze/html && ${COPYTREE_SHARE} \* ${DOCSDIR}/api/katze/html)
- (cd ${WRKSRC}/_build_/docs/api/midori/html && ${COPYTREE_SHARE} \* ${DOCSDIR}/api/midori/html)
+ (cd ${WRKSRC}/_build/docs/api/katze/html && ${COPYTREE_SHARE} \* ${DOCSDIR}/api/katze/html)
+ (cd ${WRKSRC}/_build/docs/api/midori/html && ${COPYTREE_SHARE} \* ${DOCSDIR}/api/midori/html)
.endif
.include <bsd.port.post.mk>
diff --git a/www/midori/distinfo b/www/midori/distinfo
index fef374c8e1c9..86e5af46f6df 100644
--- a/www/midori/distinfo
+++ b/www/midori/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/midori-0.4.4.tar.bz2) = fadd43f76c1c9f6a16483e60a804e58fb6817c6a595b1acdd59bcbdd7b35bca2
-SIZE (xfce4/midori-0.4.4.tar.bz2) = 939294
+SHA256 (xfce4/midori-0.4.5.tar.bz2) = 7b57cf3ebb56eef586351f2ae9f71ec9683aedff0b79a071b70b811d9876ff84
+SIZE (xfce4/midori-0.4.5.tar.bz2) = 950950
diff --git a/www/midori/files/patch-extensions__wscript_build b/www/midori/files/patch-extensions__wscript_build
new file mode 100644
index 000000000000..2b28214b82de
--- /dev/null
+++ b/www/midori/files/patch-extensions__wscript_build
@@ -0,0 +1,12 @@
+--- extensions/wscript_build.orig 2012-04-14 21:17:35.000000000 +0200
++++ extensions/wscript_build 2012-05-02 22:02:34.000000000 +0200
+@@ -4,7 +4,8 @@
+
+ import os
+
+-extensions = os.listdir ('extensions')
++exclude_files = ['external-download-manager.vala']
++extensions = [i for i in os.listdir ('extensions') if i not in exclude_files]
+ for extension in extensions:
+ folder = 'extensions' + os.sep + extension
+ if os.path.isdir (folder):
diff --git a/www/midori/files/patch-midori_midori-websettings.c b/www/midori/files/patch-midori_midori-websettings.c
deleted file mode 100644
index 929ef643251a..000000000000
--- a/www/midori/files/patch-midori_midori-websettings.c
+++ /dev/null
@@ -1,50 +0,0 @@
---- midori/midori-websettings.c.orig 2012-03-08 23:34:45.000000000 +0100
-+++ midori/midori-websettings.c 2012-03-23 15:48:54.000000000 +0100
-@@ -27,6 +27,11 @@
- #include <sys/utsname.h>
- #endif
-
-+#if defined(__FreeBSD__)
-+#include <sys/types.h>
-+#include <sys/sysctl.h>
-+#endif
-+
- struct _MidoriWebSettings
- {
- WebKitWebSettings parent_instance;
-@@ -347,16 +352,26 @@
- static gboolean
- midori_web_settings_low_memory_profile ()
- {
-- gchar* contents;
-- const gchar* total;
-- if (!g_file_get_contents ("/proc/meminfo", &contents, NULL, NULL))
-- return FALSE;
-- if (contents && (total = strstr (contents, "MemTotal:")) && *total)
-- {
-- const gchar* value = katze_skip_whitespace (total + 9);
-- gdouble mem_total = g_ascii_strtoll (value, NULL, 0);
-- return mem_total / 1024.0 < 352 + 1;
-- }
-+ #ifdef __FreeBSD__
-+ size_t size;
-+ int mem_total;
-+ size = sizeof mem_total;
-+
-+ sysctlbyname("hw.realmem", &mem_total, &size, NULL, 0);
-+
-+ return mem_total / 1048576 < 352;
-+ #else
-+ gchar* contents;
-+ const gchar* total;
-+ if (!g_file_get_contents ("/proc/meminfo", &contents, NULL, NULL))
-+ return FALSE;
-+ if (contents && (total = strstr (contents, "MemTotal:")) && *total)
-+ {
-+ const gchar* value = katze_skip_whitespace (total + 9);
-+ gdouble mem_total = g_ascii_strtoll (value, NULL, 0);
-+ return mem_total / 1024.0 < 352 + 1;
-+ }
-+ #endif
- return FALSE;
- }
diff --git a/www/midori/files/patch-wscript b/www/midori/files/patch-wscript
new file mode 100644
index 000000000000..6165d02ac6e8
--- /dev/null
+++ b/www/midori/files/patch-wscript
@@ -0,0 +1,13 @@
+--- wscript.orig 2012-04-14 21:17:35.000000000 +0200
++++ wscript 2012-05-02 19:15:37.000000000 +0200
+@@ -104,8 +104,8 @@
+ conf.check_tool ('compiler_cc')
+ conf.check_tool ('vala')
+ conf.check_tool ('glib2')
+- if not check_version (conf.env['VALAC_VERSION'], 0, 14, 0):
+- Utils.pprint ('RED', 'Vala 0.14.0 or later is required.')
++ if not check_version (conf.env['VALAC_VERSION'], 0, 12, 0):
++ Utils.pprint ('RED', 'Vala 0.12.0 or later is required.')
+ sys.exit (1)
+
+ if option_enabled ('nls'):
diff --git a/www/midori/pkg-plist b/www/midori/pkg-plist
index 060c3fe92410..6127a43f6151 100644
--- a/www/midori/pkg-plist
+++ b/www/midori/pkg-plist
@@ -44,7 +44,6 @@ share/applications/midori-private.desktop
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-separatoraction.html
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-throbber.html
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-utils.html
-%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze.devhelp
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze.devhelp2
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/left.png
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/right.png
@@ -75,7 +74,6 @@ share/applications/midori-private.desktop
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-socket.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-sokoke.html
-%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori.devhelp
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori.devhelp2
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/right.png
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/style.css