aboutsummaryrefslogtreecommitdiff
path: root/www/mimetex
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-30 20:10:00 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-30 20:10:00 +0000
commit0da57b1eba593a5f5655922031c324c4a590e607 (patch)
treecc369802fe529fb78db75fd975926349109c6c65 /www/mimetex
parent4136ed975a0e8b21a4d464e03468cf056dd5e053 (diff)
downloadports-0da57b1eba593a5f5655922031c324c4a590e607.tar.gz
ports-0da57b1eba593a5f5655922031c324c4a590e607.zip
- Add WITH_STATIC knob
PR: ports/97952 Submitted by: Nicola Vitale Reviewed by: aaron Approved by: tobez
Notes
Notes: svn path=/head/; revision=164001
Diffstat (limited to 'www/mimetex')
-rw-r--r--www/mimetex/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/www/mimetex/Makefile b/www/mimetex/Makefile
index e561f94821ae..0df71baaaa91 100644
--- a/www/mimetex/Makefile
+++ b/www/mimetex/Makefile
@@ -28,9 +28,14 @@ CGI_BIN= ${PREFIX}/www/cgi-bin/
CGI_PRG= ${PORTNAME}.cgi
WWW_DIR= ${PREFIX}/www/data/mimetex/
+# usefull if you run mimetex on another machine
+.if defined(WITH_STATIC)
+STATIC_MIMETEX= -static
+.endif
+
do-build:
cd ${WRKDIR};\
- ${CC} ${CFLAGS} -DAA mimetex.c gifsave.c -lm -o ${CGI_PRG}
+ ${CC} ${CFLAGS} ${STATIC_MIMETEX} -DAA mimetex.c gifsave.c -lm -o ${CGI_PRG}
do-install:
${MKDIR} ${CGI_BIN}