aboutsummaryrefslogtreecommitdiff
path: root/www/mod_access_identd
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-10 23:17:32 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-10 23:17:32 +0000
commitca0808a56ec910f0dfbdc45466977ac518234367 (patch)
tree986883620ccce119a9673a47e1ea84d7f159b621 /www/mod_access_identd
parent6702077846838060cd213aedb522069bdeb5b80f (diff)
downloadports-ca0808a56ec910f0dfbdc45466977ac518234367.tar.gz
ports-ca0808a56ec910f0dfbdc45466977ac518234367.zip
Add mod_access_identd 1.2.0, an Apache module to supply access control
based on ident reply.
Notes
Notes: svn path=/head/; revision=41253
Diffstat (limited to 'www/mod_access_identd')
-rw-r--r--www/mod_access_identd/Makefile27
-rw-r--r--www/mod_access_identd/distinfo1
-rw-r--r--www/mod_access_identd/pkg-comment1
-rw-r--r--www/mod_access_identd/pkg-descr9
-rw-r--r--www/mod_access_identd/pkg-plist3
5 files changed, 41 insertions, 0 deletions
diff --git a/www/mod_access_identd/Makefile b/www/mod_access_identd/Makefile
new file mode 100644
index 000000000000..47fec0a8d0b0
--- /dev/null
+++ b/www/mod_access_identd/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: mod_access_identd
+# Date created: 10 April 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_access_identd
+PORTVERSION= 1.2.0
+CATEGORIES= www
+MASTER_SITES= http://MeepZor.Com/packages/mod_access_identd/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+
+WRKSRC= ${WRKDIR}/mod_access_identd
+APXS?= ${LOCALBASE}/sbin/apxs
+
+do-build:
+ @cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
+
+do-install:
+ ${APXS} -i -A -n ${PORTNAME:S/_//g} ${WRKSRC}/${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/www/mod_access_identd/distinfo b/www/mod_access_identd/distinfo
new file mode 100644
index 000000000000..eb94d8de72e5
--- /dev/null
+++ b/www/mod_access_identd/distinfo
@@ -0,0 +1 @@
+MD5 (mod_access_identd-1.2.0.tar.gz) = 67a5a1b9d5862eeaf2ba812f6dca98d9
diff --git a/www/mod_access_identd/pkg-comment b/www/mod_access_identd/pkg-comment
new file mode 100644
index 000000000000..28a603e995a7
--- /dev/null
+++ b/www/mod_access_identd/pkg-comment
@@ -0,0 +1 @@
+Apache module to supply access control based on ident reply
diff --git a/www/mod_access_identd/pkg-descr b/www/mod_access_identd/pkg-descr
new file mode 100644
index 000000000000..f0936c24a61a
--- /dev/null
+++ b/www/mod_access_identd/pkg-descr
@@ -0,0 +1,9 @@
+A security module for the Apache Web server, supplying
+mandatory access control based upon the client username
+and host. The credentials are obtained using the identd
+(RFC1413) mechanism, so this is of limited usefulness
+if document access is through a proxy or by clients not
+running an RFC1413 server daemon. As a result, this module
+is best suited for intranets.
+
+WWW: http://MeepZor.Com/packages/
diff --git a/www/mod_access_identd/pkg-plist b/www/mod_access_identd/pkg-plist
new file mode 100644
index 000000000000..40fd54c83cd6
--- /dev/null
+++ b/www/mod_access_identd/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache/mod_access_identd.so
+@exec %D/sbin/apxs -e -A -n access_identd %D/%F
+@unexec %D/sbin/apxs -e -A -n access_identd %D/%F