aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_mysql41_ap2
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-01-09 23:15:20 +0000
committerClement Laforet <clement@FreeBSD.org>2004-01-09 23:15:20 +0000
commit643168d988060f4450dec0c1d9f7ca2f7ec9e128 (patch)
treedcd48d98cb374f232b954e0c1eb8cd05f7f93da4 /www/mod_auth_mysql41_ap2
parent7433b9218c52d69fddba3c202381c87670046206 (diff)
downloadports-643168d988060f4450dec0c1d9f7ca2f7ec9e128.tar.gz
ports-643168d988060f4450dec0c1d9f7ca2f7ec9e128.zip
Add mod_auth_mysql41_ap2 1.00, mySQL 4.1 and Apache 2 port of
mod_auth_mysql. PR: 57503 Submitted by: Douglas A. Maske <maske@maske.org> Approved by: erwin (mentor) (implicity)
Notes
Notes: svn path=/head/; revision=97817
Diffstat (limited to 'www/mod_auth_mysql41_ap2')
-rw-r--r--www/mod_auth_mysql41_ap2/Makefile39
-rw-r--r--www/mod_auth_mysql41_ap2/distinfo1
-rw-r--r--www/mod_auth_mysql41_ap2/files/patch-mod_auth_mysql.c11
-rw-r--r--www/mod_auth_mysql41_ap2/pkg-descr5
-rw-r--r--www/mod_auth_mysql41_ap2/pkg-message27
-rw-r--r--www/mod_auth_mysql41_ap2/pkg-plist3
6 files changed, 86 insertions, 0 deletions
diff --git a/www/mod_auth_mysql41_ap2/Makefile b/www/mod_auth_mysql41_ap2/Makefile
new file mode 100644
index 000000000000..ec54cfc9e8c5
--- /dev/null
+++ b/www/mod_auth_mysql41_ap2/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mod_auth_mysql41_ap2
+# Date Created: Thu Oct 2 10:33:50 CDT 2003
+# Whom: Douglas A. Maske <maske@maske.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_auth_mysql41_ap2
+PORTVERSION= 1.00
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.maske.org/pub/FreeBSD/distfiles/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+DISTFILES= ${DISTNAME}.tar.gz
+
+MAINTAINER= maske@maske.org
+COMMENT= MySQL 4.1 and Apache 2 port of mod_auth_mysql
+
+USE_APACHE= YES
+WITH_APACHE2= YES
+
+USE_MYSQL= YES
+WANT_MYSQL_VER= 41
+MYSQL_INC?= ${LOCALBASE}/include/mysql
+MYSQL_LIB?= ${LOCALBASE}/lib/mysql -lmysqlclient
+
+MODULE_NAME= mod_auth_mysql
+PORTDOCS= README
+
+do-build:
+ @(cd ${WRKSRC} && ${APXS} -D APACHE2 -I ${MYSQL_INC} -L ${MYSQL_LIB} -c ${MODULE_NAME}.c)
+
+do-install:
+ @(cd ${WRKSRC} && ${APXS} -i -A -n ${MODULE_NAME:S/mod_//} ${MODULE_NAME}.la)
+.if !defined(NORPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_auth_mysql41_ap2/distinfo b/www/mod_auth_mysql41_ap2/distinfo
new file mode 100644
index 000000000000..0d2c530fa6e2
--- /dev/null
+++ b/www/mod_auth_mysql41_ap2/distinfo
@@ -0,0 +1 @@
+MD5 (mod_auth_mysql41_ap2_1.00.tar.gz) = 1bbb708dd08831e25aebc6191fd7e72c
diff --git a/www/mod_auth_mysql41_ap2/files/patch-mod_auth_mysql.c b/www/mod_auth_mysql41_ap2/files/patch-mod_auth_mysql.c
new file mode 100644
index 000000000000..ab8e7b70bcc8
--- /dev/null
+++ b/www/mod_auth_mysql41_ap2/files/patch-mod_auth_mysql.c
@@ -0,0 +1,11 @@
+--- mod_auth_mysql.c.orig Fri Jan 9 22:13:01 2004
++++ mod_auth_mysql.c Fri Jan 9 22:13:12 2004
+@@ -692,7 +692,7 @@
+ /* if AuthMySQLScrambledPassword is On, compare the scrambled password */
+ if(sec->mysqlScrambled) {
+ scrambled_sent_pw = PCALLOC(r->pool, 33);
+- make_scrambled_password(scrambled_sent_pw, sent_pw, NULL, 0);
++ make_scrambled_password(scrambled_sent_pw, sent_pw);
+ if(strcmp(real_pw, scrambled_sent_pw)) {
+ passwords_match = 0;
+ }
diff --git a/www/mod_auth_mysql41_ap2/pkg-descr b/www/mod_auth_mysql41_ap2/pkg-descr
new file mode 100644
index 000000000000..f4699abd8d9b
--- /dev/null
+++ b/www/mod_auth_mysql41_ap2/pkg-descr
@@ -0,0 +1,5 @@
+mod_auth_mysql41_ap2 is an Apache module that allows authentication using user and group data stored in MySQL databases. Originally by Vivek Khera for Apache1, now also includes a version for Apache 2. This version has been modified from the version by Sam Brauer <sbrauer@users.sourceforge.net> at http://sourceforge.net/projects/modauthmysql to support MySQL 4.1 with Apache 2. Group Authentication has not been implemented yet.
+
+Douglas A. Maske
+maske@maske.org
+http://www.maske.org
diff --git a/www/mod_auth_mysql41_ap2/pkg-message b/www/mod_auth_mysql41_ap2/pkg-message
new file mode 100644
index 000000000000..0d443aee1001
--- /dev/null
+++ b/www/mod_auth_mysql41_ap2/pkg-message
@@ -0,0 +1,27 @@
+*****************************************************************************
+
+You have installed the mod_auth_mysql41_ap2 package.
+
+Your Apache2 configuration file has been updated with the new module.
+
+Please restart Apache2 for this module to activate.
+
+You should put this to your .htaccess file:
+
+AuthType Basic
+AuthName YOURAUTHNAME
+AuthMySQLDB YOURDATABASENAME
+AuthMySQLUser YOURMYSQLUSERNAME
+AuthMySQLPassword YOURMYSQLPASSWORD
+AuthMySQLHost YOURMYSQLHOSTNAME
+AuthMySQLUserTable YOURUSERTABLENAME
+AuthMySQLNameField USERNAMEFIELD
+AuthMySQLPasswordField PASSWORDFIELD
+
+For .htaccess options, view /usr/local/share/doc/mod_auth_mysql41_ap2/README
+
+For more information visit http://www.maske.org
+
+Group authentication is not supported at this time.
+
+*****************************************************************************
diff --git a/www/mod_auth_mysql41_ap2/pkg-plist b/www/mod_auth_mysql41_ap2/pkg-plist
new file mode 100644
index 000000000000..648d6e410b13
--- /dev/null
+++ b/www/mod_auth_mysql41_ap2/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache2/mod_auth_mysql.so
+@exec %D/sbin/apxs -e -a -n mysql_auth %D/%f
+@unexec %D/sbin/apxs -e -A -n mysql_auth %D/%f