aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_mysql
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2002-11-05 12:17:51 +0000
committerJames E. Housley <jeh@FreeBSD.org>2002-11-05 12:17:51 +0000
commit81330903a5f06ce487f4a99c743439f84fd87253 (patch)
tree2e801a938297ed5488ce7ed3a00e17cd8c58613e /www/mod_auth_mysql
parentcf0bbe06e751a7c054f9ed0b421322aaa076056e (diff)
downloadports-81330903a5f06ce487f4a99c743439f84fd87253.tar.gz
ports-81330903a5f06ce487f4a99c743439f84fd87253.zip
Currently mod_auth_mysql logs authentication error in the access log, and
not in the error log. This new patch logs in both the access log and the error log, to not break existing scripts. Submitted by: Steve Ungerer <sau1@cornell.edu>
Notes
Notes: svn path=/head/; revision=69522
Diffstat (limited to 'www/mod_auth_mysql')
-rw-r--r--www/mod_auth_mysql/Makefile1
-rw-r--r--www/mod_auth_mysql/files/patch-ad32
2 files changed, 33 insertions, 0 deletions
diff --git a/www/mod_auth_mysql/Makefile b/www/mod_auth_mysql/Makefile
index 8947651546ff..955692fd925c 100644
--- a/www/mod_auth_mysql/Makefile
+++ b/www/mod_auth_mysql/Makefile
@@ -6,6 +6,7 @@
PORTNAME= mod_auth_mysql
PORTVERSION= 2.20
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mod-auth-mysql
diff --git a/www/mod_auth_mysql/files/patch-ad b/www/mod_auth_mysql/files/patch-ad
new file mode 100644
index 000000000000..77c8c469a1fe
--- /dev/null
+++ b/www/mod_auth_mysql/files/patch-ad
@@ -0,0 +1,32 @@
+--- mod_auth_mysql.c.orig Sat Oct 3 13:41:41 1998
++++ mod_auth_mysql.c Tue Nov 5 07:13:30 2002
+@@ -559,6 +559,10 @@
+
+ switch (mysql_check_user_password(r, c->user, sent_pw, sec)) {
+ case 0:
++ ap_log_rerror(APLOG_MARK, APLOG_NOERRNO|APLOG_ERR, r,
++ "user %s: authentication failure for \"%s\": %s",
++ c->user, r->uri);
++ ap_note_basic_auth_failure(r);
+ note_basic_auth_failure(r);
+ return AUTH_REQUIRED;
+ break;
+@@ -582,6 +586,7 @@
+ {
+ mysql_auth_config_rec *sec = (mysql_auth_config_rec *) get_module_config(r->per_dir_config, &auth_mysql_module);
+ char *user = r->connection->user;
++ conn_rec *c = r->connection;
+ int m = r->method_number;
+ int method_restricted = 0;
+ register int x;
+@@ -653,6 +658,10 @@
+ if (!(sec->assume_authoritative)) {
+ return DECLINED;
+ }
++ ap_log_rerror(APLOG_MARK, APLOG_NOERRNO|APLOG_ERR, r,
++ "user %s: authentication failure for \"%s\": %s",
++ c->user, r->uri);
++ ap_note_basic_auth_failure(r);
+ note_basic_auth_failure(r);
+ return AUTH_REQUIRED;
+ }