aboutsummaryrefslogtreecommitdiff
path: root/www/mod_backhand
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2006-02-21 08:50:44 +0000
committerSean Chittenden <seanc@FreeBSD.org>2006-02-21 08:50:44 +0000
commit396bd70e27937f4567c503684d049470b045dcba (patch)
treefc6a786a1b09457aabeb69a8bbeb7e8e9bb87918 /www/mod_backhand
parent6ddada094463dd205448ccb48decce02f61c38f6 (diff)
downloadports-396bd70e27937f4567c503684d049470b045dcba.tar.gz
ports-396bd70e27937f4567c503684d049470b045dcba.zip
Clear errno on library load. Fixes the symptom of mod_backhand aborting on
systems with nss. Notified upstream maintainers. Port rev bump. PR: ports/75048 Submitted by: Rachel Willmer <rachel@hobthross.com> Fix obtained from: Scott Wilson <scott.wilson@gmail.com>
Notes
Notes: svn path=/head/; revision=156565
Diffstat (limited to 'www/mod_backhand')
-rw-r--r--www/mod_backhand/Makefile1
-rw-r--r--www/mod_backhand/files/patch-mod_backhand.c10
2 files changed, 11 insertions, 0 deletions
diff --git a/www/mod_backhand/Makefile b/www/mod_backhand/Makefile
index ac630dc54189..f42e07c434c7 100644
--- a/www/mod_backhand/Makefile
+++ b/www/mod_backhand/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_backhand
PORTVERSION= 1.2.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://mirrors.omniti.com/mod_backhand/ \
http://people.FreeBSD.org/~seanc/ports/mod_backhand/
diff --git a/www/mod_backhand/files/patch-mod_backhand.c b/www/mod_backhand/files/patch-mod_backhand.c
new file mode 100644
index 000000000000..2ea0d47ecd1a
--- /dev/null
+++ b/www/mod_backhand/files/patch-mod_backhand.c
@@ -0,0 +1,10 @@
+--- mod_backhand.c.orig Tue Feb 21 00:42:40 2006
++++ mod_backhand.c Tue Feb 21 00:43:24 2006
+@@ -427,6 +427,7 @@
+ mbcfg *cfg = (mbcfg *) mconfig;
+ struct cpd *newfunc;
+ cfg->local = 1;
++ ap_os_dso_error();
+ handle = ap_os_dso_load(szFilename);
+ if(!handle)
+ return ap_os_dso_error();