aboutsummaryrefslogtreecommitdiff
path: root/www/mod_bw
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-10-06 19:13:28 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-10-06 19:13:28 +0000
commitddc01fa885ad4bdd1007f4b165be44c9e8df64ea (patch)
tree2f78f3c9fc890c6337e0bc89613d4bcabbdbed3b /www/mod_bw
parentb8cbb211ebf1fa99d1edd29a9d8cd1fd6406895f (diff)
downloadports-ddc01fa885ad4bdd1007f4b165be44c9e8df64ea.tar.gz
ports-ddc01fa885ad4bdd1007f4b165be44c9e8df64ea.zip
- Remove a patch chunk which was breaking runtime on FreeBSD 4.X
PR: ports/97883 Submitted by: Jeremy Chadwick <freebsd@jdc.parodius.com> Approved by: maintainer timeout (apache; 4 months)
Notes
Notes: svn path=/head/; revision=174662
Diffstat (limited to 'www/mod_bw')
-rw-r--r--www/mod_bw/Makefile1
-rw-r--r--www/mod_bw/files/patch-mod_bw.c15
2 files changed, 1 insertions, 15 deletions
diff --git a/www/mod_bw/Makefile b/www/mod_bw/Makefile
index cc3bc22766be..0516434bffe4 100644
--- a/www/mod_bw/Makefile
+++ b/www/mod_bw/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_bw
PORTVERSION= 0.7
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bwmod
diff --git a/www/mod_bw/files/patch-mod_bw.c b/www/mod_bw/files/patch-mod_bw.c
index 94ae7bc4954f..9a3f3d63e236 100644
--- a/www/mod_bw/files/patch-mod_bw.c
+++ b/www/mod_bw/files/patch-mod_bw.c
@@ -1,20 +1,5 @@
--- mod_bw.c.orig Mon Apr 24 03:10:44 2006
+++ mod_bw.c Tue May 16 14:01:56 2006
-@@ -51,6 +51,14 @@
- #include "http_core.h"
- #include "scoreboard.h"
-
-+#if APR_MAJOR_VERSION == 0
-+#define apr_atomic_set32(mem,val) (atomic_set_32(mem,val),mem)
-+#define apr_atomic_inc32(mem) (atomic_add_32(mem,1),mem)
-+#define apr_atomic_dec32(mem) (atomic_subtract_32(mem,1),mem)
-+#define apr_atomic_add32(mem,val) (atomic_add_32(mem,val),mem)
-+#define apr_atomic_cas32 apr_atomic_cas
-+#endif
-+
- #define MIN_BW 256 /* Minimal bandwidth 256 bytes */
- #define PACKET 8192 /* Default packet at 8192 bytes */
-
@@ -715,8 +723,10 @@
/* If we are too busy, deny connection */