aboutsummaryrefslogtreecommitdiff
path: root/www/mod_clamav
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-04-18 17:01:11 +0000
committerClement Laforet <clement@FreeBSD.org>2004-04-18 17:01:11 +0000
commit44ad29fbb815573d10dc3082aeff617a36d7f33a (patch)
tree46a1cae73e3b167d216415c5971b06d01b93715f /www/mod_clamav
parent99f2e416e6941c266acc6656d9fda5c897a4241e (diff)
downloadports-44ad29fbb815573d10dc3082aeff617a36d7f33a.tar.gz
ports-44ad29fbb815573d10dc3082aeff617a36d7f33a.zip
All mod_clamev 0.19, scans content delivered by the Apache2 proxy
module for viruses Submitted by: Tom Müller-Kortkamp <tmueko@kommunity.net>
Notes
Notes: svn path=/head/; revision=107439
Diffstat (limited to 'www/mod_clamav')
-rw-r--r--www/mod_clamav/Makefile37
-rw-r--r--www/mod_clamav/distinfo2
-rw-r--r--www/mod_clamav/pkg-descr8
-rw-r--r--www/mod_clamav/pkg-message10
-rw-r--r--www/mod_clamav/pkg-plist3
5 files changed, 60 insertions, 0 deletions
diff --git a/www/mod_clamav/Makefile b/www/mod_clamav/Makefile
new file mode 100644
index 000000000000..f27210441a91
--- /dev/null
+++ b/www/mod_clamav/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mod_clamav
+# Date created: Sun Oct 19
+# Whom: Clement Laforet <clement@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_clamav
+PORTVERSION= 0.19
+CATEGORIES= www security
+MASTER_SITES= http://software.othello.ch/mod_clamav/
+
+MAINTAINER= tmueko@kommunity.net
+COMMENT= Scans content delivered by the Apache2 proxy module for viruses
+
+LIB_DEPENDS+= clamav:${PORTSDIR}/${CLAMAV_PORT}
+
+USE_APACHE= YES
+WITH_APACHE2= YES
+USE_LIBTOOL= YES
+
+.if defined(WITH_CLAMAVDEVEL)
+CLAMAV_PORT= security/clamav-devel
+.else
+CLAMAV_PORT= security/clamav
+.endif
+
+CONFIGURE_ARGS= --with-apxs=${PREFIX}/sbin/apxs \
+ --libdir=${PREFIX}/lib/apache2
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/mod_clamav/distinfo b/www/mod_clamav/distinfo
new file mode 100644
index 000000000000..6238119982d3
--- /dev/null
+++ b/www/mod_clamav/distinfo
@@ -0,0 +1,2 @@
+MD5 (mod_clamav-0.19.tar.gz) = e06e6d4b5a3a9a3096ca0ad12263824b
+SIZE (mod_clamav-0.19.tar.gz) = 307375
diff --git a/www/mod_clamav/pkg-descr b/www/mod_clamav/pkg-descr
new file mode 100644
index 000000000000..0d9750bf60c8
--- /dev/null
+++ b/www/mod_clamav/pkg-descr
@@ -0,0 +1,8 @@
+Apache 2 introduces filters, which allow to modify content generated
+by some
+other module. mod_clamav is an Apache 2 filter which scans the content
+delivered by the proxy module (mod_proxy) for viruses using the Clamav
+virus
+scanning engine.
+
+WWW: http://software.othello.ch/mod_clamav/
diff --git a/www/mod_clamav/pkg-message b/www/mod_clamav/pkg-message
new file mode 100644
index 000000000000..99ebb1a0a487
--- /dev/null
+++ b/www/mod_clamav/pkg-message
@@ -0,0 +1,10 @@
+######################################################################
+# First you have to make sure, clamav runs in Daemon-Mode:
+# Add "ClamavMode daemon" to your httpd.conf
+# If clamd run on a local socket, it must have the same userid as the
+# webserver add something like "user www" to your clamav.conf
+# If you don't want to start clamd as the same user as the Webserver
+# you have to start clamd on an inet socket by removing LocalSocket...
+# and add the options "TCPSocket ..." and "TCPAddr..."
+# later in the clamav.conf
+#######################################################################
diff --git a/www/mod_clamav/pkg-plist b/www/mod_clamav/pkg-plist
new file mode 100644
index 000000000000..7ea86d547c7e
--- /dev/null
+++ b/www/mod_clamav/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache2/mod_clamav.so
+@exec %D/sbin/apxs -e -A -n clamav %D/%f
+@exec %D/sbin/apxs -e -A -n clamav %D/%f