aboutsummaryrefslogtreecommitdiff
path: root/www/mod_clamav
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-08-15 06:53:14 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-08-15 06:53:14 +0000
commit6bcb94a52c3df27eb0f21d7411c617737e074070 (patch)
treee716746b732e0b1596acf675dcc8825a95234f02 /www/mod_clamav
parent32686dd1978e187ea365538e941d03aa3adbeff9 (diff)
downloadports-6bcb94a52c3df27eb0f21d7411c617737e074070.tar.gz
ports-6bcb94a52c3df27eb0f21d7411c617737e074070.zip
maintainer update www/mod_clamav
Update to 0.22. Check that Apache-2.2 is NOT installed PR: ports/123594 Submitted by: Tom Müller-Kortkamp <tmueko@kommunity.net>
Notes
Notes: svn path=/head/; revision=218613
Diffstat (limited to 'www/mod_clamav')
-rw-r--r--www/mod_clamav/Makefile25
-rw-r--r--www/mod_clamav/distinfo6
-rw-r--r--www/mod_clamav/files/patch-mod_clamav.c25
3 files changed, 19 insertions, 37 deletions
diff --git a/www/mod_clamav/Makefile b/www/mod_clamav/Makefile
index c5d5313dc727..ff962b3e0cbd 100644
--- a/www/mod_clamav/Makefile
+++ b/www/mod_clamav/Makefile
@@ -6,27 +6,35 @@
#
PORTNAME= mod_clamav
-PORTVERSION= 0.21
-PORTREVISION= 3
+PORTVERSION= 0.22
+PORTREVISION= 1
CATEGORIES= www security
-MASTER_SITES= http://software.othello.ch/mod_clamav/
+MASTER_SITES= http://software.othello.ch/mod_clamav/ \
+ http://www.kommunity.net/download/mod_clamav/
MAINTAINER= tmueko@kommunity.net
-COMMENT= Scans content delivered by the Apache2 proxy module for viruses
-
-LIB_DEPENDS+= clamav.4:${PORTSDIR}/${CLAMAV_PORT}
+COMMENT= Scans content delivered by the Apache20 proxy module for viruses
USE_AUTOTOOLS= libtool:15
USE_APACHE= YES
WITH_APACHE2= YES
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/include/apache22/http_core.h) || exists(${LOCALBASE}/include/apache/http_core.h)
+IGNORE= mod_clamav only compile and run with apache-2.0.x
+.endif
+
.if defined(WITH_CLAMAVDEVEL)
-CLAMAV_PORT= security/clamav-devel
+LIB_DEPENDS+= clamav:${PORTSDIR}/security/clamav-devel
.else
CLAMAV_PORT= security/clamav
+LIB_DEPENDS+= clamav:${PORTSDIR}/security/clamav
.endif
+BUILD_DEPENDS+= apache20:${PORTSDIR}/www/apache20
+
CONFIGURE_ARGS= --with-apxs=${PREFIX}/sbin/apxs \
--libdir=${PREFIX}/lib/apache2
CFLAGS+= -I${LOCALBASE}/include
@@ -39,5 +47,4 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" \
post-install:
@${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/mod_clamav/distinfo b/www/mod_clamav/distinfo
index eae9bb00bd1b..16c864e6e155 100644
--- a/www/mod_clamav/distinfo
+++ b/www/mod_clamav/distinfo
@@ -1,3 +1,3 @@
-MD5 (mod_clamav-0.21.tar.gz) = 98bd0d8628be8ddeae21da6623e57d20
-SHA256 (mod_clamav-0.21.tar.gz) = b5e2265582cfe5a10c6fb407d3ca0be0b6f5a4bad3e3750366450b93980d1254
-SIZE (mod_clamav-0.21.tar.gz) = 308497
+MD5 (mod_clamav-0.22.tar.gz) = 63d1a1fd02418a870e483a1a642dfb92
+SHA256 (mod_clamav-0.22.tar.gz) = f13c18ccfb6e40b7315db32c26c3602e14a4c9b7bf8e2ff23df87aca2e5f4341
+SIZE (mod_clamav-0.22.tar.gz) = 308718
diff --git a/www/mod_clamav/files/patch-mod_clamav.c b/www/mod_clamav/files/patch-mod_clamav.c
deleted file mode 100644
index c31ed1ff1100..000000000000
--- a/www/mod_clamav/files/patch-mod_clamav.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- mod_clamav.c.bak Fri Oct 12 10:03:41 2007
-+++ mod_clamav.c Fri Oct 12 10:02:09 2007
-@@ -102,6 +102,22 @@
- unsigned long reloads; /* number of database reloads (local) */
- } clamav_stats;
-
-+const char *cl_perror(int clerror) /* deprecated */
-+{
-+ return cl_strerror(clerror);
-+}
-+
-+void cl_freetrie(struct cl_node *root) /* for backward compatibility */
-+{
-+ cl_free(root);
-+}
-+
-+int cl_buildtrie(struct cl_node *root) /* for backward compatibility */
-+{
-+ return cl_build(root);
-+}
-+
-+
- static void clamav_virus_record(clamav_stats *stats, const char *uri,
- const char *req, const char *virus, off_t size) {
- /* find the index of the entry we are about to create */