aboutsummaryrefslogtreecommitdiff
path: root/www/mod_extract_forwarded
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-12-06 12:16:34 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-12-06 12:16:34 +0000
commita23bb435c3eaacfae3fa53ffd9cfb5c714b420c7 (patch)
treea4bc383cecad8e91d7b8b68f0dcc878045031363 /www/mod_extract_forwarded
parent09d4c1396f857be1ccb4d9103d31858595509c4e (diff)
downloadports-a23bb435c3eaacfae3fa53ffd9cfb5c714b420c7.tar.gz
ports-a23bb435c3eaacfae3fa53ffd9cfb5c714b420c7.zip
Forced commit (forgot to add patch):
Fix build for "union <anonymous>' has no member named 'sin6'" error. PR: ports/146886 Reported by: Yurij <ilesikz@gmail.com>
Notes
Notes: svn path=/head/; revision=265756
Diffstat (limited to 'www/mod_extract_forwarded')
-rw-r--r--www/mod_extract_forwarded/Makefile2
-rw-r--r--www/mod_extract_forwarded/files/patch-mod_extract_forwarded.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/www/mod_extract_forwarded/Makefile b/www/mod_extract_forwarded/Makefile
index 56054b6571ce..4bc55a66fdc6 100644
--- a/www/mod_extract_forwarded/Makefile
+++ b/www/mod_extract_forwarded/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mod_extract_forwarded
PORTVERSION= 2.0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.openinfo.co.uk/apache/
DISTNAME= extract_forwarded-${DISTVERSION}
diff --git a/www/mod_extract_forwarded/files/patch-mod_extract_forwarded.c b/www/mod_extract_forwarded/files/patch-mod_extract_forwarded.c
new file mode 100644
index 000000000000..e5d78fc4b6d6
--- /dev/null
+++ b/www/mod_extract_forwarded/files/patch-mod_extract_forwarded.c
@@ -0,0 +1,11 @@
+--- mod_extract_forwarded.c.orig 2010-05-24 13:43:06.446992453 +0900
++++ mod_extract_forwarded.c 2010-06-12 17:46:16.673689346 +0900
+@@ -423,7 +423,7 @@
+ {
+ result = &(conn->remote_addr->sa.sin.sin_addr.s_addr);
+ }
+-#if defined(AF_INET6) && defined(IN6_IS_ADDR_V4MAPPED)
++#if defined(AF_INET6) && defined(IN6_IS_ADDR_V4MAPPED) && APR_HAVE_IPV6 == 1
+ if (conn->remote_addr->family == AF_INET6 &&
+ IN6_IS_ADDR_V4MAPPED(&conn->remote_addr->sa.sin6.sin6_addr))
+ {