aboutsummaryrefslogtreecommitdiff
path: root/www/mod_extract_forwarded_ap13
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2001-06-19 01:59:10 +0000
committerJames E. Housley <jeh@FreeBSD.org>2001-06-19 01:59:10 +0000
commitbf4b2173ef0aea76fe2eb4ee33e571203d6b4fc9 (patch)
tree51156aaecd82a0ebe838fcf37b07fe59213bb224 /www/mod_extract_forwarded_ap13
parent150a7b6b49aa315dbe56c85349dd30275e8236d9 (diff)
downloadports-bf4b2173ef0aea76fe2eb4ee33e571203d6b4fc9.tar.gz
ports-bf4b2173ef0aea76fe2eb4ee33e571203d6b4fc9.zip
New port of mod_extract_forwarded, an Apache module that can make proxied
requests appear with client IP. PR: 27998 Submitted by: Anders Nordby <anders@fix.no>
Notes
Notes: svn path=/head/; revision=44195
Diffstat (limited to 'www/mod_extract_forwarded_ap13')
-rw-r--r--www/mod_extract_forwarded_ap13/Makefile37
-rw-r--r--www/mod_extract_forwarded_ap13/distinfo1
-rw-r--r--www/mod_extract_forwarded_ap13/pkg-comment1
-rw-r--r--www/mod_extract_forwarded_ap13/pkg-descr13
-rw-r--r--www/mod_extract_forwarded_ap13/pkg-message15
-rw-r--r--www/mod_extract_forwarded_ap13/pkg-plist6
6 files changed, 73 insertions, 0 deletions
diff --git a/www/mod_extract_forwarded_ap13/Makefile b/www/mod_extract_forwarded_ap13/Makefile
new file mode 100644
index 000000000000..3081d06a2c4b
--- /dev/null
+++ b/www/mod_extract_forwarded_ap13/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mod_extract_forwarded
+# Date created: 9 June 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_extract_forwarded
+PORTVERSION= 1.2
+CATEGORIES= www
+MASTER_SITES= http://web.systhug.com/mod_extract_forwarded/ \
+ http://www.freenix.no/~anders/
+
+MAINTAINER= anders@fix.no
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+APXS?= ${LOCALBASE}/sbin/apxs
+DOCS= mod_extract_forwarded.html README
+
+do-build:
+ cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
+
+do-install:
+ cd ${WRKSRC} && ${APXS} -A -i ${PORTNAME}.so
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/share/doc/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/${PORTNAME}
+.endfor
+.endif
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/mod_extract_forwarded_ap13/distinfo b/www/mod_extract_forwarded_ap13/distinfo
new file mode 100644
index 000000000000..9a61d5278471
--- /dev/null
+++ b/www/mod_extract_forwarded_ap13/distinfo
@@ -0,0 +1 @@
+MD5 (mod_extract_forwarded-1.2.tar.gz) = 70ecf6f26f5561377b97ba8cae10e95f
diff --git a/www/mod_extract_forwarded_ap13/pkg-comment b/www/mod_extract_forwarded_ap13/pkg-comment
new file mode 100644
index 000000000000..2b25fe5ece54
--- /dev/null
+++ b/www/mod_extract_forwarded_ap13/pkg-comment
@@ -0,0 +1 @@
+An Apache module that can make proxied requests appear with client IP
diff --git a/www/mod_extract_forwarded_ap13/pkg-descr b/www/mod_extract_forwarded_ap13/pkg-descr
new file mode 100644
index 000000000000..a1f0912373d8
--- /dev/null
+++ b/www/mod_extract_forwarded_ap13/pkg-descr
@@ -0,0 +1,13 @@
+mod_extract_forwarded hooks itself into Apache's header parsing phase and looks
+for the X-Forwarded-For header which some (most?) proxies add to the proxied
+HTTP requests. It extracts the IP from the X-Forwarded-For and modifies the
+connection data so to the rest of Apache the request looks like it came from
+that IP rather than the proxy IP.
+
+mod_extract_forwarded can be dangerous for host based access control because
+X-Forwarded-For is easily spoofed. Because of this you can configure which
+proxies you trust or don't trust.
+
+WWW: http://web.systhug.com/mod_extract_forwarded/
+
+- Anders Nordby <anders@fix.no>
diff --git a/www/mod_extract_forwarded_ap13/pkg-message b/www/mod_extract_forwarded_ap13/pkg-message
new file mode 100644
index 000000000000..de71faa90343
--- /dev/null
+++ b/www/mod_extract_forwarded_ap13/pkg-message
@@ -0,0 +1,15 @@
+************************************************************
+You've installed mod_extract_forward, an Apache module that
+can make proxied requests appear with client IPs.
+
+Edit your apache.conf or httpd.conf to enable and setup this
+module. Have a look at the files in
+${PREFIX}/share/doc/mod_extract_forward for information on
+how to configure it.
+
+Then do this to make it work effective:
+
+# apachectl configtest (see if there are any config errors)
+# apachectl restart
+
+************************************************************
diff --git a/www/mod_extract_forwarded_ap13/pkg-plist b/www/mod_extract_forwarded_ap13/pkg-plist
new file mode 100644
index 000000000000..57031aa59d80
--- /dev/null
+++ b/www/mod_extract_forwarded_ap13/pkg-plist
@@ -0,0 +1,6 @@
+libexec/apache/mod_extract_forwarded.so
+@exec %D/sbin/apxs -e -A -n extract_forwarded %D/%F
+@unexec %D/sbin/apxs -e -A -n extract_forwarded %D/%F
+%%PORTDOCS%%share/doc/mod_extract_forwarded/mod_extract_forwarded.html
+%%PORTDOCS%%share/doc/mod_extract_forwarded/README
+%%PORTDOCS%%@dirrm share/doc/mod_extract_forwarded