aboutsummaryrefslogtreecommitdiff
path: root/www/mod_fcgid
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2006-04-23 02:10:22 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2006-04-23 02:10:22 +0000
commit8e86501b968dd72a122b2343cbb0027aa86ba88c (patch)
tree13d0e941e0a0f99e9891bcb923bcda0da6f459d3 /www/mod_fcgid
parent5820fe3700d16f8a1302fe1d8ed13e0f0e5537d5 (diff)
downloadports-8e86501b968dd72a122b2343cbb0027aa86ba88c.tar.gz
ports-8e86501b968dd72a122b2343cbb0027aa86ba88c.zip
Updated www/mod_fcgid to version 1.08. Updated Makefile and other files to
handle cases for both www/apache20 and www/apache22. Removed www/mod_fcgid/pkg_message. Added www/mod_fcgid/files/pkg_message.in. PR: ports/96158 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=160190
Diffstat (limited to 'www/mod_fcgid')
-rw-r--r--www/mod_fcgid/Makefile26
-rw-r--r--www/mod_fcgid/distinfo6
-rw-r--r--www/mod_fcgid/files/pkg-message.in (renamed from www/mod_fcgid/pkg-message)2
-rw-r--r--www/mod_fcgid/pkg-plist2
4 files changed, 27 insertions, 9 deletions
diff --git a/www/mod_fcgid/Makefile b/www/mod_fcgid/Makefile
index b8b7dabc0261..62aa07b4644e 100644
--- a/www/mod_fcgid/Makefile
+++ b/www/mod_fcgid/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mod_fcgid
-PORTVERSION= 1.07
+PORTVERSION= 1.08
CATEGORIES= www
MASTER_SITES= http://fastcgi.coremail.cn/ \
${MASTER_SITE_LOCAL}
@@ -16,14 +16,32 @@ DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= hemi@puresimplicity.net
COMMENT= An alternative FastCGI module for Apache2
-USE_APACHE= yes
+USE_APACHE= 2.0+
WITH_APACHE2= yes
-MAKE_ARGS= top_dir="${LOCALBASE}/share/apache2" INCLUDES="-I${LOCALBASE}/include/apache2"
+
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} >= 22
+MAKE_ARGS= top_dir="${LOCALBASE}/share/apache${APACHE_VERSION}"
+MAKE_ARGS+= INCLUDES="-I${LOCALBASE}/include/apache${APACHE_VERSION} -I${LOCALBASE}/include/apr-1"
+INSTALL_TARGET= install-modules-yes
+PLIST_SUB= APACHE_VERSION=${APACHE_VERSION}
+PLIST_FILES+= libexec/apache%%APACHE_VERSION%%/mod_fcgid.a
+PLIST_FILES+= libexec/apache%%APACHE_VERSION%%/mod_fcgid.la
+SUB_LIST= APACHE_VERSION=${APACHE_VERSION}
+.else
+MAKE_ARGS= top_dir="${LOCALBASE}/share/apache${APACHE_VERSION:S/20/2/}"
+MAKE_ARGS+= INCLUDES="-I${LOCALBASE}/include/apache${APACHE_VERSION:S/20/2/}"
INSTALL_TARGET= install-modules
+PLIST_SUB= APACHE_VERSION=${APACHE_VERSION:S/20/2/}
+SUB_LIST= APACHE_VERSION=${APACHE_VERSION:S/20/2/}
+.endif
post-install:
${MKDIR} -m 700 /var/run/fcgidsock
${CHOWN} www:www /var/run/fcgidsock
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/mod_fcgid/distinfo b/www/mod_fcgid/distinfo
index 9e3541bc4203..6b88b3de6c24 100644
--- a/www/mod_fcgid/distinfo
+++ b/www/mod_fcgid/distinfo
@@ -1,3 +1,3 @@
-MD5 (mod_fcgid.1.07.tar.gz) = ae74bcb009b044739dc22757581b09f3
-SHA256 (mod_fcgid.1.07.tar.gz) = 22b935f1c65da19e39b295a4bce935fa962094a517f6a6612c1f2b9a76eed3ef
-SIZE (mod_fcgid.1.07.tar.gz) = 48521
+MD5 (mod_fcgid.1.08.tar.gz) = 5e053b090f89ff610347e4b4fbe9a81a
+SHA256 (mod_fcgid.1.08.tar.gz) = dd8ada827e099f881bff89dd823fb5e7c05ba6e476e19995cc55211277b669f7
+SIZE (mod_fcgid.1.08.tar.gz) = 48963
diff --git a/www/mod_fcgid/pkg-message b/www/mod_fcgid/files/pkg-message.in
index 17a13263fc35..9214400920dc 100644
--- a/www/mod_fcgid/pkg-message
+++ b/www/mod_fcgid/files/pkg-message.in
@@ -2,7 +2,7 @@
To enable this module, add something like the following
lines to your server configuration file:
- LoadModule fcgid_module libexec/apache2/mod_fcgid.so
+ LoadModule fcgid_module libexec/apache%%APACHE_VERSION%%/mod_fcgid.so
<IfModule mod_fcgid.c>
AddHandler fcgid-script .fcgi
diff --git a/www/mod_fcgid/pkg-plist b/www/mod_fcgid/pkg-plist
index bc85ebc4c2fc..65e6fc018590 100644
--- a/www/mod_fcgid/pkg-plist
+++ b/www/mod_fcgid/pkg-plist
@@ -1,4 +1,4 @@
-libexec/apache2/mod_fcgid.so
+libexec/apache%%APACHE_VERSION%%/mod_fcgid.so
@exec /bin/mkdir -p -m 700 /var/run/fcgidsock
@exec /bin/chown www:www /var/run/fcgidsock
@unexec /bin/rmdir /var/run/fcgidsock 2>/dev/null || true