aboutsummaryrefslogtreecommitdiff
path: root/www/mod_geoip2
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-02 15:47:43 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-02 15:47:43 +0000
commitfafdc13474af197cc988f120ff1cc9a4cbf97d9c (patch)
treebe0a5daab4695b5f0cd34ce32f83372ed320993c /www/mod_geoip2
parent5f44713ce28850103dc634049becb5a89ea3b8cb (diff)
downloadports-fafdc13474af197cc988f120ff1cc9a4cbf97d9c.tar.gz
ports-fafdc13474af197cc988f120ff1cc9a4cbf97d9c.zip
Add mod_geoip2.
mod_geoip2 is an Apache2 module that looks up the country code for the IP address making the request without using reverse DNS. WWW: http://www.maxmind.com/app/mod_geoip PR: ports/86777 Submitted by: Jukka A. Ukkonen <jau@iki.fi>
Notes
Notes: svn path=/head/; revision=143992
Diffstat (limited to 'www/mod_geoip2')
-rw-r--r--www/mod_geoip2/Makefile39
-rw-r--r--www/mod_geoip2/distinfo2
-rw-r--r--www/mod_geoip2/files/pkg-message.in11
-rw-r--r--www/mod_geoip2/pkg-descr4
-rw-r--r--www/mod_geoip2/pkg-plist3
5 files changed, 59 insertions, 0 deletions
diff --git a/www/mod_geoip2/Makefile b/www/mod_geoip2/Makefile
new file mode 100644
index 000000000000..9d27bad49d7e
--- /dev/null
+++ b/www/mod_geoip2/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mod_geoip2
+# Date created: 26 Aug 2005
+# Whom: Jukka A. Ukkonen <jau@iki.fi>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_geoip2
+PORTVERSION= 1.1.7
+CATEGORIES= www
+MASTER_SITES= http://www.maxmind.com/download/geoip/api/mod_geoip2/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= jau@iki.fi
+COMMENT= An Apache module that provides the country code of the client's IP
+
+LIB_DEPENDS= GeoIP.4:${PORTSDIR}/net/GeoIP
+
+CONFLICTS= mod_geoip-[0-9]*
+
+USE_APACHE= yes
+WITH_APACHE2= yes
+
+SUB_FILES= pkg-message
+PORTDOCS= Changes INSTALL README README.php
+
+do-build:
+ @cd ${WRKSRC} && \
+ ${APXS} -c -L${LOCALBASE}/lib -I${LOCALBASE}/include -lGeoIP mod_geoip.c
+
+do-install:
+ ${APXS} -i -A -n geoip ${WRKSRC}/.libs/mod_geoip.so
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/mod_geoip2/distinfo b/www/mod_geoip2/distinfo
new file mode 100644
index 000000000000..d370a63aed56
--- /dev/null
+++ b/www/mod_geoip2/distinfo
@@ -0,0 +1,2 @@
+MD5 (mod_geoip2_1.1.7.tar.gz) = ca02b8b955d95d659037f8c633908ae9
+SIZE (mod_geoip2_1.1.7.tar.gz) = 6848
diff --git a/www/mod_geoip2/files/pkg-message.in b/www/mod_geoip2/files/pkg-message.in
new file mode 100644
index 000000000000..05dc4359e32a
--- /dev/null
+++ b/www/mod_geoip2/files/pkg-message.in
@@ -0,0 +1,11 @@
+*******************************************************************************
+Please edit your apache.conf or httpd.conf to enable and setup this module.
+
+You can always refer to the useful documents held in:
+%%DOCSDIR%%
+
+When it is done, do the following to apply the modifications:
+
+ apachectl configtest (and correct any errors reported)
+ apachectl restart
+*******************************************************************************
diff --git a/www/mod_geoip2/pkg-descr b/www/mod_geoip2/pkg-descr
new file mode 100644
index 000000000000..f7adbb40231d
--- /dev/null
+++ b/www/mod_geoip2/pkg-descr
@@ -0,0 +1,4 @@
+mod_geoip2 is an Apache2 module that looks up the country code for the
+IP address making the request without using reverse DNS.
+
+WWW: http://www.maxmind.com/app/mod_geoip
diff --git a/www/mod_geoip2/pkg-plist b/www/mod_geoip2/pkg-plist
new file mode 100644
index 000000000000..ac397fa53abf
--- /dev/null
+++ b/www/mod_geoip2/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache2/mod_geoip.so
+@exec %D/sbin/apxs -e -A -n geoip %D/%F
+@unexec %D/sbin/apxs -e -A -n geoip %D/%F