aboutsummaryrefslogtreecommitdiff
path: root/www/mod_log_firstbyte
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-02-15 14:38:41 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-02-15 14:38:41 +0000
commitb2aa5f515653774986bb289b836f02cdd74361d0 (patch)
treed27096d4ac215dd92a100a02015e88cc4a5c9ad6 /www/mod_log_firstbyte
parent061e814ebbe17d1539defeadc2a1db8657422cd2 (diff)
downloadports-b2aa5f515653774986bb289b836f02cdd74361d0.tar.gz
ports-b2aa5f515653774986bb289b836f02cdd74361d0.zip
- add mod_log_firstbyte-1.01
mod_log_firstbyte is a module for Apache 2.0 which allows you to log the time between each request being read and the first byte of the response served. Unlike the total serve time, this index of performance tells you how long Apache actually spent loading the file off the disk or executing your script: it's independent of client connection speed. It makes a great performance benchmark for your server! WWW: http://code.google.com/p/mod-log-firstbyte/
Notes
Notes: svn path=/head/; revision=207250
Diffstat (limited to 'www/mod_log_firstbyte')
-rw-r--r--www/mod_log_firstbyte/Makefile34
-rw-r--r--www/mod_log_firstbyte/distinfo6
-rw-r--r--www/mod_log_firstbyte/pkg-descr13
-rw-r--r--www/mod_log_firstbyte/pkg-plist3
4 files changed, 56 insertions, 0 deletions
diff --git a/www/mod_log_firstbyte/Makefile b/www/mod_log_firstbyte/Makefile
new file mode 100644
index 000000000000..ed91c01efd27
--- /dev/null
+++ b/www/mod_log_firstbyte/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: mod_log_firstbyte
+# Date created: January 29, 2008
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_log_firstbyte
+PORTVERSION= 1.01
+CATEGORIES= www
+MASTER_SITES= http://mod-log-firstbyte.googlecode.com/svn/trunk/
+DISTFILES= ${PORTNAME}.c readme.txt
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= Log the time between request and the first byte of the response served
+
+USE_APACHE= 2.0+
+MOD= mod_log_firstbyte
+PKGMESSAGE= ${WRKSRC}/readme.txt
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ cd ${DISTDIR} && ${CP} ${DISTFILES} ${WRKSRC}
+
+do-build:
+ cd ${WRKSRC} && ${APXS} -c ${MOD}.c
+
+do-install:
+ ${APXS} -i -a ${WRKSRC}/${MOD}.la
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/mod_log_firstbyte/distinfo b/www/mod_log_firstbyte/distinfo
new file mode 100644
index 000000000000..32915bb2d882
--- /dev/null
+++ b/www/mod_log_firstbyte/distinfo
@@ -0,0 +1,6 @@
+MD5 (mod_log_firstbyte.c) = 096592b5646e9915c7812debf49022ac
+SHA256 (mod_log_firstbyte.c) = f1dcdefffa4cafa1193303b1acadd8f033624d6f1a857421a20f563f9229989e
+SIZE (mod_log_firstbyte.c) = 3884
+MD5 (readme.txt) = 2404822441a0dc2bdd0830d5e2eb4829
+SHA256 (readme.txt) = 4f8c1d0352431214d86d0171fc0a5e97189340cc6383dc51461a91ad2b1e2c61
+SIZE (readme.txt) = 672
diff --git a/www/mod_log_firstbyte/pkg-descr b/www/mod_log_firstbyte/pkg-descr
new file mode 100644
index 000000000000..d28375bc388b
--- /dev/null
+++ b/www/mod_log_firstbyte/pkg-descr
@@ -0,0 +1,13 @@
+Ever tried logging Apache page serve times using '%D'? You'll have discovered
+that they aren't a good index of your server's performance, because they depend
+more on the client's connection speed, computer and browsing habits than on the
+speed of your server.
+
+mod_log_firstbyte is a module for Apache 2.0 which allows you to log the time
+between each request being read and the first byte of the response served.
+Unlike the total serve time, this index of performance tells you how long Apache
+actually spent loading the file off the disk or executing your script: it's
+independent of client connection speed. It makes a great performance benchmark
+for your server!
+
+WWW: http://code.google.com/p/mod-log-firstbyte/
diff --git a/www/mod_log_firstbyte/pkg-plist b/www/mod_log_firstbyte/pkg-plist
new file mode 100644
index 000000000000..21012beca366
--- /dev/null
+++ b/www/mod_log_firstbyte/pkg-plist
@@ -0,0 +1,3 @@
+%%APACHEMODDIR%%/mod_log_firstbyte.so
+@exec %D/sbin/apxs -e -A -n log_firstbyte %D/%F
+@unexec %D/sbin/apxs -e -A -n log_firstbyte %D/%F