aboutsummaryrefslogtreecommitdiff
path: root/www/mod_mp3
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-08 19:42:40 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-08 19:42:40 +0000
commit2a3597aa3ad8bcf98129ad5518f4bbb0c049964d (patch)
tree522e3322a2ef748b94dbd98d6cdf0b05cc89d433 /www/mod_mp3
parenta8458468050f708d82385484cd37583b0cc38b85 (diff)
downloadports-2a3597aa3ad8bcf98129ad5518f4bbb0c049964d.tar.gz
ports-2a3597aa3ad8bcf98129ad5518f4bbb0c049964d.zip
Add mod_mp3 0.6, an apache module to allow MP3 streaming.
Spotted on: Slashdot (har har)
Notes
Notes: svn path=/head/; revision=41084
Diffstat (limited to 'www/mod_mp3')
-rw-r--r--www/mod_mp3/Makefile26
-rw-r--r--www/mod_mp3/distinfo1
-rw-r--r--www/mod_mp3/pkg-comment1
-rw-r--r--www/mod_mp3/pkg-descr7
-rw-r--r--www/mod_mp3/pkg-plist3
5 files changed, 38 insertions, 0 deletions
diff --git a/www/mod_mp3/Makefile b/www/mod_mp3/Makefile
new file mode 100644
index 000000000000..357c5b183b69
--- /dev/null
+++ b/www/mod_mp3/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: mod_auth_pam
+# Date created: 7 April 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_mp3
+PORTVERSION= 0.6
+CATEGORIES= www
+MASTER_SITES= http://www.tangent.org/mod_mp3/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+do-build:
+ @cd ${WRKSRC} && ${APXS} -c mod_mp3.c
+
+do-install:
+ ${APXS} -i -A -n mp3 ${WRKSRC}/mod_mp3.so
+
+.include <bsd.port.mk>
diff --git a/www/mod_mp3/distinfo b/www/mod_mp3/distinfo
new file mode 100644
index 000000000000..3802b9b6ddb8
--- /dev/null
+++ b/www/mod_mp3/distinfo
@@ -0,0 +1 @@
+MD5 (mod_mp3-0.6.tar.gz) = b28ed0f2bee1157761680f27b294a942
diff --git a/www/mod_mp3/pkg-comment b/www/mod_mp3/pkg-comment
new file mode 100644
index 000000000000..1819207c4b8f
--- /dev/null
+++ b/www/mod_mp3/pkg-comment
@@ -0,0 +1 @@
+Apache module to allow MP3 streaming
diff --git a/www/mod_mp3/pkg-descr b/www/mod_mp3/pkg-descr
new file mode 100644
index 000000000000..b9bb0c29c04e
--- /dev/null
+++ b/www/mod_mp3/pkg-descr
@@ -0,0 +1,7 @@
+This turns apache into your basic RIAA hating, but every college
+student loving mp3 streaming server. It can play from a list of
+files, either straight through or randomly. It can also be used
+to cache mp3's into memory and have the server operate entirely
+from memory. Enjoy, groove, mp3s not included.
+
+WWW: http://www.tangent.org/mod_mp3/
diff --git a/www/mod_mp3/pkg-plist b/www/mod_mp3/pkg-plist
new file mode 100644
index 000000000000..ea7da22f779e
--- /dev/null
+++ b/www/mod_mp3/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache/mod_mp3.so
+@exec %D/sbin/apxs -e -A -n mp3 %D/%F
+@unexec %D/sbin/apxs -e -A -n mp3 %D/%F