aboutsummaryrefslogtreecommitdiff
path: root/www/mod_pcgi2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-07 09:12:58 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-07 09:12:58 +0000
commitf4d7c801f854ff4fad4642d62b23bae798962615 (patch)
treeeee60e8fb7c2a2d1bf0636dd8288df46aee9e9bb /www/mod_pcgi2
parent2e8e10b527cd18511e4bd6a598f05050d4190015 (diff)
downloadports-f4d7c801f854ff4fad4642d62b23bae798962615.tar.gz
ports-f4d7c801f854ff4fad4642d62b23bae798962615.zip
Use the new Apache bits from bsd.port.mk.
Submitted by: dinoex
Notes
Notes: svn path=/head/; revision=93294
Diffstat (limited to 'www/mod_pcgi2')
-rw-r--r--www/mod_pcgi2/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/www/mod_pcgi2/Makefile b/www/mod_pcgi2/Makefile
index 6fc295427da2..c80d72f163c8 100644
--- a/www/mod_pcgi2/Makefile
+++ b/www/mod_pcgi2/Makefile
@@ -17,18 +17,17 @@ COMMENT= Persistent CGI module for Apache and Zope
RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/z2.py:${PORTSDIR}/www/zope
.if defined(WITH_APACHE13)
-BUILD_DEPENDS= ${LOCALBASE}/include/apache/httpd.h:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${LOCALBASE}/include/apache/httpd.h:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${LOCALBASE}/include/apache/httpd.h:${PORTSDIR}/${APACHE_PORT}
+RUN_DEPENDS= ${LOCALBASE}/include/apache/httpd.h:${PORTSDIR}/${APACHE_PORT}
.else
-BUILD_DEPENDS= ${LOCALBASE}/include/apache2/httpd.h:${PORTSDIR}/www/apache2
-RUN_DEPENDS= ${LOCALBASE}/include/apache2/httpd.h:${PORTSDIR}/www/apache2
+BUILD_DEPENDS= ${LOCALBASE}/include/apache2/httpd.h:${PORTSDIR}/${APACHE_PORT}
+RUN_DEPENDS= ${LOCALBASE}/include/apache2/httpd.h:${PORTSDIR}/${APACHE_PORT}
.endif
USE_PYTHON= yes
# You can change this in the environment if you like.
SZOPEBASEDIR?= www/Zope
-APXS?= ${LOCALBASE}/sbin/apxs
# Don't change these
ZOPEBASEDIR= ${LOCALBASE}/${SZOPEBASEDIR}
@@ -43,6 +42,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.if defined(WITH_APACHE13)
APACHEVER= apache
.else
+WITH_APACHE2= yes
APACHEVER= apache2
BUILDOPT+= -DAPACHE2 -Wc,-shared
.endif