aboutsummaryrefslogtreecommitdiff
path: root/www/mod_python3
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-09-09 18:30:10 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-09-09 18:30:10 +0000
commite9bd637dd02fcd96b91fb80ba311012435435f6b (patch)
tree1462b961ad61216f85817c7e4d143262dfbae524 /www/mod_python3
parentb45c510091c3a7e41e33fdb7f7f019ef370b004d (diff)
downloadports-e9bd637dd02fcd96b91fb80ba311012435435f6b.tar.gz
ports-e9bd637dd02fcd96b91fb80ba311012435435f6b.zip
support appache13-modssl by defining APACHE_PORT in /etc/make.conf
others variants of the apache ports can be used too.
Notes
Notes: svn path=/head/; revision=65932
Diffstat (limited to 'www/mod_python3')
-rw-r--r--www/mod_python3/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/www/mod_python3/Makefile b/www/mod_python3/Makefile
index 591db4ae4e58..dd217311cd59 100644
--- a/www/mod_python3/Makefile
+++ b/www/mod_python3/Makefile
@@ -15,8 +15,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
NO_PACKAGE= "Requires Python without threads support"
USE_PYTHON= yes
@@ -24,6 +24,7 @@ USE_PYTHON= yes
.include <bsd.port.pre.mk>
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-apxs=${APXS}