aboutsummaryrefslogtreecommitdiff
path: root/www/mod_shapvh
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-11-30 20:45:55 +0000
committerClement Laforet <clement@FreeBSD.org>2004-11-30 20:45:55 +0000
commitf0b77951fe9d166c8878abdc65df6b7e842df2c5 (patch)
tree79491de4e7ec17582784e7bf3c5d1883008c081d /www/mod_shapvh
parent30905665b0b0e725aa6824458dd6765f21f2cf13 (diff)
downloadports-f0b77951fe9d166c8878abdc65df6b7e842df2c5.tar.gz
ports-f0b77951fe9d166c8878abdc65df6b7e842df2c5.zip
- Add mod_shapvh 1.0, Apache module that provides virtual hosts from a
MySQL database. http://www.crazygreek.co.uk/content/mod_shapvh PR: ports/74038 Submitted by: Steven Looman <steven@krx.nl>
Notes
Notes: svn path=/head/; revision=122836
Diffstat (limited to 'www/mod_shapvh')
-rw-r--r--www/mod_shapvh/Makefile32
-rw-r--r--www/mod_shapvh/distinfo2
-rw-r--r--www/mod_shapvh/pkg-descr6
-rw-r--r--www/mod_shapvh/pkg-plist3
4 files changed, 43 insertions, 0 deletions
diff --git a/www/mod_shapvh/Makefile b/www/mod_shapvh/Makefile
new file mode 100644
index 000000000000..04b59e69663f
--- /dev/null
+++ b/www/mod_shapvh/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: mod_shapvh
+# Date created: 17 Nov 2004
+# Whom: Steven Looman <steven@krx.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_shapvh
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= http://www.crazygreek.co.uk/downloads/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .c
+
+MAINTAINER= steven@krx.nl
+COMMENT= Apache module that provides virtual hosts from a database
+
+USE_APACHE= yes
+USE_MYSQL= yes
+NO_WRKSUBDIR= yes
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+
+do-build:
+ @cd ${WRKSRC} && ${APXS} -c -l mysqlclient -I ${PREFIX}/include -L ${PREFIX}/lib/mysql ${PORTNAME}.c
+
+do-install:
+ ${APXS} -i -A -n ${PORTNAME:S/^mod_//g} ${WRKSRC}/${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/www/mod_shapvh/distinfo b/www/mod_shapvh/distinfo
new file mode 100644
index 000000000000..8ce2c94eb303
--- /dev/null
+++ b/www/mod_shapvh/distinfo
@@ -0,0 +1,2 @@
+MD5 (mod_shapvh.c) = 6be3fa980c7710c2739dd4cdd3ff79e7
+SIZE (mod_shapvh.c) = 14712
diff --git a/www/mod_shapvh/pkg-descr b/www/mod_shapvh/pkg-descr
new file mode 100644
index 000000000000..d1fe88116cd5
--- /dev/null
+++ b/www/mod_shapvh/pkg-descr
@@ -0,0 +1,6 @@
+Shared Apache VirtualHost module.
+
+This module allows you to store your virtual hosts in a database
+and extract them on the fly.
+
+WWW: http://www.crazygreek.co.uk/content/mod_shapvh
diff --git a/www/mod_shapvh/pkg-plist b/www/mod_shapvh/pkg-plist
new file mode 100644
index 000000000000..3b8b695e3672
--- /dev/null
+++ b/www/mod_shapvh/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache/mod_shapvh.so
+@exec %D/sbin/apxs -e -A -n shapvh %D/%F
+@unexec %D/sbin/apxs -e -A -n shapvh %D/%F