aboutsummaryrefslogtreecommitdiff
path: root/www/mod_sqlinclude
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2001-11-12 02:09:15 +0000
committerAnders Nordby <anders@FreeBSD.org>2001-11-12 02:09:15 +0000
commit4417a778f41170679f5eabb971094cd5c89b7c76 (patch)
treec4c4e9b17b0e623bab337e7fbe60fb5360587590 /www/mod_sqlinclude
parente4d88f396affc7dbeecd407c50fb3d113829b849 (diff)
downloadports-4417a778f41170679f5eabb971094cd5c89b7c76.tar.gz
ports-4417a778f41170679f5eabb971094cd5c89b7c76.zip
Add mod_sqlinclude, an Apache module implementing config inclusion from MySQL
databases. PR: 31296 Submitted by: Anders Nordby <anders@fix.no> Approved by: will
Notes
Notes: svn path=/head/; revision=49952
Diffstat (limited to 'www/mod_sqlinclude')
-rw-r--r--www/mod_sqlinclude/Makefile37
-rw-r--r--www/mod_sqlinclude/distinfo1
-rw-r--r--www/mod_sqlinclude/files/patch-mod_sqlinclude.c11
-rw-r--r--www/mod_sqlinclude/pkg-comment1
-rw-r--r--www/mod_sqlinclude/pkg-descr9
-rw-r--r--www/mod_sqlinclude/pkg-message15
-rw-r--r--www/mod_sqlinclude/pkg-plist7
7 files changed, 81 insertions, 0 deletions
diff --git a/www/mod_sqlinclude/Makefile b/www/mod_sqlinclude/Makefile
new file mode 100644
index 000000000000..0c388212eed7
--- /dev/null
+++ b/www/mod_sqlinclude/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mod_sqlinclude
+# Date created: October 25 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+
+PORTNAME= mod_sqlinclude
+PORTVERSION= 1.2
+CATEGORIES= www
+MASTER_SITES= http://wfmh.org.pl/~carlos/files/ \
+ ftp://ftp.nuug.no/pub/anders/distfiles/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= anders@fix.no
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+
+APXS?= ${LOCALBASE}/sbin/apxs
+DOCS= CHANGES.txt README.txt TODO.txt
+
+do-build:
+ (cd ${WRKSRC} && ${APXS} -c -I${LOCALBASE}/include \
+ -L${LOCALBASE}/lib/mysql -lmysqlclient mod_sqlinclude.c)
+
+do-install:
+ (cd ${WRKSRC} && ${APXS} -i -A -n 'sqlinclude' mod_sqlinclude.so)
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_sqlinclude/distinfo b/www/mod_sqlinclude/distinfo
new file mode 100644
index 000000000000..7ee30694b40c
--- /dev/null
+++ b/www/mod_sqlinclude/distinfo
@@ -0,0 +1 @@
+MD5 (mod_sqlinclude_1.2.tgz) = 4db84fa282416ca098d937d18cd262d6
diff --git a/www/mod_sqlinclude/files/patch-mod_sqlinclude.c b/www/mod_sqlinclude/files/patch-mod_sqlinclude.c
new file mode 100644
index 000000000000..f48b0f8e09ad
--- /dev/null
+++ b/www/mod_sqlinclude/files/patch-mod_sqlinclude.c
@@ -0,0 +1,11 @@
+--- mod_sqlinclude.c.orig Thu Oct 25 17:09:46 2001
++++ mod_sqlinclude.c Thu Oct 25 17:10:00 2001
+@@ -376,7 +376,7 @@
+ { "SQL_SQLPassword", cmd_sqli_sqlpassword, NULL, RSRC_CONF, TAKE1,
+ "the MySQL password for SQLI_User. No default" },
+ { "SQL_SQLDB", cmd_sqli_sqldb, NULL, RSRC_CONF, TAKE1,
+- "the MySQL database the module shall use. Default 'sqlinclude' },
++ "the MySQL database the module shall use. Default 'sqlinclude'" },
+
+ { "SQL_Include", cmd_sqli_include, NULL, RSRC_CONF, TAKE1,
+ "valid SQL query. Data returned in 1st column will be passed to Apache" },
diff --git a/www/mod_sqlinclude/pkg-comment b/www/mod_sqlinclude/pkg-comment
new file mode 100644
index 000000000000..29a205e84b4a
--- /dev/null
+++ b/www/mod_sqlinclude/pkg-comment
@@ -0,0 +1 @@
+An Apache module implementing config inclusion from MySQL databases
diff --git a/www/mod_sqlinclude/pkg-descr b/www/mod_sqlinclude/pkg-descr
new file mode 100644
index 000000000000..2de27129d48c
--- /dev/null
+++ b/www/mod_sqlinclude/pkg-descr
@@ -0,0 +1,9 @@
+mod_sqlinclude is an Apache module which implements Include-alike command,
+which, as its origin, includes the external data into Apache configuration
+file, but instead of taking the real files SQLInclude fetches and includes data
+from MySQL databases.
+
+Author: Marcin Orlowski <carlos@amiga.com.pl>
+WWW: http://wfmh.org.pl/~carlos/
+
+- Anders Nordby <anders@fix.no>
diff --git a/www/mod_sqlinclude/pkg-message b/www/mod_sqlinclude/pkg-message
new file mode 100644
index 000000000000..856b295909c8
--- /dev/null
+++ b/www/mod_sqlinclude/pkg-message
@@ -0,0 +1,15 @@
+************************************************************
+You've installed mod_sqlinclude, an Apache module
+implementing config inclusion from MySQL databases.
+
+Edit your apache.conf or httpd.conf to enable and setup this
+module. Be sure to have a look at the files in
+${PREFIX}/share/doc/mod_sqlinclude for information on how to
+configure it etc.
+
+Then do this to make it work effective:
+
+# apachectl configtest (see if there are any config errors)
+# apachectl restart
+
+************************************************************
diff --git a/www/mod_sqlinclude/pkg-plist b/www/mod_sqlinclude/pkg-plist
new file mode 100644
index 000000000000..8bcd0ce0e6ab
--- /dev/null
+++ b/www/mod_sqlinclude/pkg-plist
@@ -0,0 +1,7 @@
+libexec/apache/mod_sqlinclude.so
+@exec %D/sbin/apxs -e -A -n sqlinclude %f
+@unexec %D/sbin/apxs -e -A -n sqlinclude %f
+%%PORTDOCS%%share/doc/mod_sqlinclude/CHANGES.txt
+%%PORTDOCS%%share/doc/mod_sqlinclude/README.txt
+%%PORTDOCS%%share/doc/mod_sqlinclude/TODO.txt
+%%PORTDOCS%%@dirrm share/doc/mod_sqlinclude