aboutsummaryrefslogtreecommitdiff
path: root/www/mod_tidy
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-10-15 19:48:03 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-10-15 19:48:03 +0000
commit60575e0bb90f66f96677b4e71677e60470f5cf4b (patch)
treeb396fa10ce07fc544d87f5846066804d673a5939 /www/mod_tidy
parent83037c0e8c0e7d076131e0e34d6cd460bcec33a7 (diff)
downloadports-60575e0bb90f66f96677b4e71677e60470f5cf4b.tar.gz
ports-60575e0bb90f66f96677b4e71677e60470f5cf4b.zip
Import mod_tidy 0.3.
mod_tidy validates the HTML output of your apache2 webserver. PR: 57662 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
Notes
Notes: svn path=/head/; revision=91351
Diffstat (limited to 'www/mod_tidy')
-rw-r--r--www/mod_tidy/Makefile38
-rw-r--r--www/mod_tidy/distinfo1
-rw-r--r--www/mod_tidy/pkg-descr8
-rw-r--r--www/mod_tidy/pkg-plist4
4 files changed, 51 insertions, 0 deletions
diff --git a/www/mod_tidy/Makefile b/www/mod_tidy/Makefile
new file mode 100644
index 000000000000..eacbfd09431e
--- /dev/null
+++ b/www/mod_tidy/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: mod_tidy
+# Date created: Sun Oct 5
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_tidy
+PORTVERSION= 0.3
+CATEGORIES= www
+MASTER_SITES= http://home.snafu.de/tusk/mod_tidy/
+DIST_SUBDIR= apache
+
+MAINTAINER= sheepkiller@cultdeadsheep.org
+COMMENT= Validates the HTML output of your apache2 webserver
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= tidy:${PORTSDIR}/www/tidy-lib
+
+RESTRICTED= "no license"
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+TIDY_INC= ${LOCALBASE}/include/tidy
+TIDY_LIBS= ${LOCALBASE}/lib
+
+post-extract:
+ @${ECHO_MSG} "===> Removing distributed tidy libs to avoid conflicts"
+ @${RM} -fr ${WRKSRC}/tidy
+
+do-build:
+ @(cd ${WRKSRC}/src && ${APXS} -I ${TIDY_INC} -L ${TIDY_LIBS} -c ${PORTNAME}.c)
+
+do-install:
+ @(cd ${WRKSRC}/src && ${APXS} -A -i ${PORTNAME}.la)
+
+.include <bsd.port.mk>
diff --git a/www/mod_tidy/distinfo b/www/mod_tidy/distinfo
new file mode 100644
index 000000000000..0aa200c26bf7
--- /dev/null
+++ b/www/mod_tidy/distinfo
@@ -0,0 +1 @@
+MD5 (apache/mod_tidy-0.3.tar.gz) = f4af3e8e1ba21483e0483e114bd66838
diff --git a/www/mod_tidy/pkg-descr b/www/mod_tidy/pkg-descr
new file mode 100644
index 000000000000..c5e3e438045d
--- /dev/null
+++ b/www/mod_tidy/pkg-descr
@@ -0,0 +1,8 @@
+mod_tidy validates the HTML output of your apache2 webserver. So you don't need
+a separate application to check your HTML.
+It works as a filter that hooks up to HTML output. mod_tidy feeds the HTML
+output to TidyLib which validates the HTML output. If TidyLib finds
+an error the client receives a HTML page with a list of all found errors. If
+TidyLib doesn't complain you will get your HTML data as without mod_tidy.
+
+WWW: http://home.snafu.de/tusk/mod_tidy/
diff --git a/www/mod_tidy/pkg-plist b/www/mod_tidy/pkg-plist
new file mode 100644
index 000000000000..9eb85be71af3
--- /dev/null
+++ b/www/mod_tidy/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+libexec/apache2/mod_tidy.so
+@exec %D/sbin/apxs -e -A -n tidy %D/%f
+@unexec echo "===> If you do not plan on reinstalling mod_tidy, you must manually remove"; echo "===> references to it in httpd.conf."