aboutsummaryrefslogtreecommitdiff
path: root/www/mod_tsa/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-07 21:24:30 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-07 21:24:30 +0000
commit5c181c521caf826dd791951d6e311f8f3d730d5b (patch)
treebb7e7eb753af8e62b8c35c4a1c376fee4b1f1e41 /www/mod_tsa/Makefile
parent8428501784fd5589fcbaecdee44d639a10d5a26d (diff)
downloadports-5c181c521caf826dd791951d6e311f8f3d730d5b.tar.gz
ports-5c181c521caf826dd791951d6e311f8f3d730d5b.zip
- with AP_FAST_BUILD / AP_GENPLIST, SRC_FILE is required if there is >1 .c file
that needs to be linked in. PR: ports/152746 Reported by: Dmitry Banschikov <ubique@peterhost.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=265820
Diffstat (limited to 'www/mod_tsa/Makefile')
-rw-r--r--www/mod_tsa/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/www/mod_tsa/Makefile b/www/mod_tsa/Makefile
index 7feed3f6c743..a9ffe98b81e0 100644
--- a/www/mod_tsa/Makefile
+++ b/www/mod_tsa/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_tsa
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://am.nesiac.org/static/ \
http://ubique.spb.ru/src/
@@ -34,6 +35,7 @@ USE_APACHE= 20+
AP_EXTRAS+= -DMOD_TSA_VERSION=\\\"mod_tsa/${PORTVERSION}\\\"
AP_FAST_BUILD= yes
AP_GENPLIST= yes
+SRC_FILE= mod_tsa.c tsa_util.c
PORTEXAMPLES= *.sql tsa.conf
@@ -42,16 +44,19 @@ PORTEXAMPLES= *.sql tsa.conf
.if defined(WITH_MYSQL)
USE_MYSQL= yes
CONFIGURE_ARGS+= --enable-mysql=yes
+SRC_FILE+= db_mysql.c
.endif
.if defined(WITH_PGSQL)
USE_PGSQL= yes
CONFIGURE_ARGS+= --enable-pgsql=yes
+SRC_FILE+= db_postgresql.c
.endif
.if defined(WITH_FIREBIRD)
USE_FIREBIRD= yes
CONFIGURE_ARGS+= --enable-firebird=yes
+SRC_FILE+= db_firebird.c
.endif
.if defined(WITH_DEBUG)