aboutsummaryrefslogtreecommitdiff
path: root/www/mod_uid
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-01-05 17:19:08 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-01-05 17:19:08 +0000
commitbc5d34ab38ea8c3a3b3535db266f88f10affad22 (patch)
tree64533f508847c0e506c18c46f4d2b45a298a543d /www/mod_uid
parent587486b6b49956ae7615fcb590682ade418bd35c (diff)
downloadports-bc5d34ab38ea8c3a3b3535db266f88f10affad22.tar.gz
ports-bc5d34ab38ea8c3a3b3535db266f88f10affad22.zip
add mod_uid-1.1.0
The standard distribution of Apache does not provide adequate means for user tracking, and this module provides them. What it actually does: + if the user has provided the cookie header with the correct cookie-name, the module writes this cookie in notes with the name uid_got (accordingly, then it may be written to the log); + if the user has arrived without the required cookie, the module issues the SetCookie header for him/her and writes the cookie thus issued in notes with the name uid_set (and this may also be written to the log); + if built-in P3P support is included, the P3P header is also issued as the Set-Cookie header is issued. WWW: http://www.lexa.ru/programs/mod-uid-eng.html
Notes
Notes: svn path=/head/; revision=97376
Diffstat (limited to 'www/mod_uid')
-rw-r--r--www/mod_uid/Makefile37
-rw-r--r--www/mod_uid/distinfo1
-rw-r--r--www/mod_uid/pkg-descr15
-rw-r--r--www/mod_uid/pkg-plist4
4 files changed, 57 insertions, 0 deletions
diff --git a/www/mod_uid/Makefile b/www/mod_uid/Makefile
new file mode 100644
index 000000000000..db640966620b
--- /dev/null
+++ b/www/mod_uid/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mod_uid
+# Date created: 02 December 2003
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_uid
+PORTVERSION= 1.1.0
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.lexa.ru/pub/apache-rus/contrib/
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= A module issuing the "correct" cookies for counting the site visitors
+
+USE_APACHE= yes
+DOCS= README.html
+
+.if defined(WITH_APACHE2)
+MOD= mod_uid2
+.else
+MOD= mod_uid
+.endif
+
+do-build:
+ @cd ${WRKSRC} && ${APXS} -c ${MOD}.c
+
+do-install:
+ ${APXS} -i -A -n uid ${WRKSRC}/${MOD}.so
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_uid/distinfo b/www/mod_uid/distinfo
new file mode 100644
index 000000000000..a37dae2bcd94
--- /dev/null
+++ b/www/mod_uid/distinfo
@@ -0,0 +1 @@
+MD5 (mod_uid-1.1.0.tar.gz) = 50abf184879a6928f76b5975f6074aff
diff --git a/www/mod_uid/pkg-descr b/www/mod_uid/pkg-descr
new file mode 100644
index 000000000000..7a290050dc7a
--- /dev/null
+++ b/www/mod_uid/pkg-descr
@@ -0,0 +1,15 @@
+The standard distribution of Apache does not provide adequate means for user
+tracking, and this module provides them. What it actually does:
+
++ if the user has provided the cookie header with the correct cookie-name,
+ the module writes this cookie in notes with the name uid_got (accordingly,
+ then it may be written to the log);
+
++ if the user has arrived without the required cookie, the module issues the
+ SetCookie header for him/her and writes the cookie thus issued in notes
+ with the name uid_set (and this may also be written to the log);
+
++ if built-in P3P support is included, the P3P header is also issued as the
+ Set-Cookie header is issued.
+
+WWW: http://www.lexa.ru/programs/mod-uid-eng.html
diff --git a/www/mod_uid/pkg-plist b/www/mod_uid/pkg-plist
new file mode 100644
index 000000000000..1724bb3fd3f6
--- /dev/null
+++ b/www/mod_uid/pkg-plist
@@ -0,0 +1,4 @@
+libexec/apache/mod_uid.so
+%%PORTDOCS%%%%DOCSDIR%%/README.html
+@exec %D/sbin/apxs -e -A -n uid %D/%F
+@unexec %D/sbin/apxs -e -A -n uid %D/%F