aboutsummaryrefslogtreecommitdiff
path: root/www/mod_wsgi
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-20 23:12:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-20 23:12:20 +0000
commit84198308e29c18b2524934dfcbf2ff5a1e66ac0f (patch)
treeba0ddb742d693c969176a05b52499b51914f09d4 /www/mod_wsgi
parent41968842195fe94992676bfe0b7118225bf41627 (diff)
downloadports-84198308e29c18b2524934dfcbf2ff5a1e66ac0f.tar.gz
ports-84198308e29c18b2524934dfcbf2ff5a1e66ac0f.zip
The mod_wsgi adapter is an Apache module that provides a WSGI compliant
interface for hosting Python based web applications within Apache. The adapter is written completely in C code against the Apache C runtime and for hosting WSGI applications within Apache has a lower overhead than using existing WSGI adapters for mod_python or CGI. WWW: http://www.modwsgi.org/ PR: ports/122612 Submitted by: Douglas Thrift
Notes
Notes: svn path=/head/; revision=215421
Diffstat (limited to 'www/mod_wsgi')
-rw-r--r--www/mod_wsgi/Makefile28
-rw-r--r--www/mod_wsgi/distinfo3
-rw-r--r--www/mod_wsgi/pkg-descr7
-rw-r--r--www/mod_wsgi/pkg-message5
-rw-r--r--www/mod_wsgi/pkg-plist5
5 files changed, 48 insertions, 0 deletions
diff --git a/www/mod_wsgi/Makefile b/www/mod_wsgi/Makefile
new file mode 100644
index 000000000000..c14edd658bfc
--- /dev/null
+++ b/www/mod_wsgi/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: mod_wsgi
+# Date created: 07 April 2008
+# Whom: Douglas Thrift
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_wsgi
+PORTVERSION= 2.0
+CATEGORIES= www python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= douglas@douglasthrift.net
+COMMENT= Python WSGI adapter module for Apache
+
+PROJECTHOST= modwsgi
+
+USE_APACHE= 1.3+
+USE_PYTHON= 2.3+
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-apxs="${APXS}" --with-python="${PYTHON_CMD}"
+
+post-install:
+ @${APXS} -e -a -n "${SHORTMODNAME}" "${APACHEMODDIR}/${MODULENAME}.so"
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/mod_wsgi/distinfo b/www/mod_wsgi/distinfo
new file mode 100644
index 000000000000..1a8a9876cb1e
--- /dev/null
+++ b/www/mod_wsgi/distinfo
@@ -0,0 +1,3 @@
+MD5 (mod_wsgi-2.0.tar.gz) = 72e871d4fda1da33829ae3c7f3f2aeb6
+SHA256 (mod_wsgi-2.0.tar.gz) = 6ccf94e88ecce945fe1c7bf1dd77abc725c8623b96b93a0cd9e3d0692b30500b
+SIZE (mod_wsgi-2.0.tar.gz) = 96622
diff --git a/www/mod_wsgi/pkg-descr b/www/mod_wsgi/pkg-descr
new file mode 100644
index 000000000000..626edd10ab45
--- /dev/null
+++ b/www/mod_wsgi/pkg-descr
@@ -0,0 +1,7 @@
+The mod_wsgi adapter is an Apache module that provides a WSGI compliant
+interface for hosting Python based web applications within Apache. The
+adapter is written completely in C code against the Apache C runtime and
+for hosting WSGI applications within Apache has a lower overhead than using
+existing WSGI adapters for mod_python or CGI.
+
+WWW: http://www.modwsgi.org/
diff --git a/www/mod_wsgi/pkg-message b/www/mod_wsgi/pkg-message
new file mode 100644
index 000000000000..dea5054f301f
--- /dev/null
+++ b/www/mod_wsgi/pkg-message
@@ -0,0 +1,5 @@
+================================================================================
+
+For more information, see http://www.modwsgi.org/.
+
+================================================================================
diff --git a/www/mod_wsgi/pkg-plist b/www/mod_wsgi/pkg-plist
new file mode 100644
index 000000000000..45d83308c5b6
--- /dev/null
+++ b/www/mod_wsgi/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+@unexec /usr/bin/sed -i '' '/LoadModule %%AP_NAME%%_module/d' %D/%%APACHEETCDIR%%/httpd.conf
+%%APACHEMODDIR%%/%%AP_MODULE%%
+@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %D/%F
+@unexec echo "Don't forget to remove all mod_wsgi-related directives in your httpd.conf"