aboutsummaryrefslogtreecommitdiff
path: root/www/moodle31
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2016-05-24 08:33:27 +0000
committerWen Heping <wen@FreeBSD.org>2016-05-24 08:33:27 +0000
commit925df5a505b064c2ce9a4636c654e554d3fbf141 (patch)
treedc9d110b63b7514517fc7040dc6039e2d75ed585 /www/moodle31
parent977e5f90162ebb8f7d6c94d1ab99278278da149a (diff)
downloadports-925df5a505b064c2ce9a4636c654e554d3fbf141.tar.gz
ports-925df5a505b064c2ce9a4636c654e554d3fbf141.zip
- Repocopy moodle30 --> moodle31 and update to 3.1
Notes
Notes: svn path=/head/; revision=415772
Diffstat (limited to 'www/moodle31')
-rw-r--r--www/moodle31/Makefile66
-rw-r--r--www/moodle31/distinfo3
-rw-r--r--www/moodle31/files/pkg-message.in65
-rw-r--r--www/moodle31/pkg-descr7
4 files changed, 141 insertions, 0 deletions
diff --git a/www/moodle31/Makefile b/www/moodle31/Makefile
new file mode 100644
index 000000000000..befe9087d9fa
--- /dev/null
+++ b/www/moodle31/Makefile
@@ -0,0 +1,66 @@
+# Created by: Javier Martin Rueda <jmrueda@diatel.upm.es>
+# $FreeBSD$
+
+PORTNAME= moodle
+PORTVERSION= 3.1
+CATEGORIES= www
+MASTER_SITES= SF/moodle/Moodle/stable31/
+PKGNAMESUFFIX= ${PKGORIGIN:T:S/moodle//}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Course management system based on social constructionism
+
+LICENSE= GPLv3
+
+CONFLICTS= moodle28-2.8.[0-9]* moodle29-2.9.[0-9]* moodle30-3.0.[0-9]*
+
+USES= cpe tar:tgz
+USE_PHP= ctype curl dom gd hash iconv intl json mbstring opcache \
+ openssl pcre session simplexml soap spl tokenizer xml \
+ xmlreader xmlrpc zip zlib
+WRKSRC= ${WRKDIR}/moodle
+
+OPTIONS_SINGLE= BACKEND
+OPTIONS_SINGLE_BACKEND= MYSQL PGSQL MSSQL
+OPTIONS_DEFINE= LDAP MIMETEX
+OPTIONS_DEFAULT= MYSQL
+MIMETEX_DESC= mimeTeX filter functionality support
+
+MYSQL_USE= mysql=client php=mysqli
+PGSQL_USE= php=pgsql
+MSSQL_USE= php=mssql
+LDAP_USE= php=ldap
+MIMETEX_RUN_DEPENDS= ${LOCALBASE}/www/mimetex/cgi-bin/mimetex.cgi:www/mimetex
+
+NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
+SUB_FILES= pkg-message
+SUB_LIST= MOODLEDIR=${MOODLEDIR} \
+ MOODLEDATADIR=${MOODLEDATADIR}
+
+MOODLEDIR?= www/moodle
+MOODLEDATADIR?= moodledata
+
+pre-install:
+ @${ECHO_CMD} "@owner ${WWWOWN}" >> ${PLIST}
+ @${ECHO_CMD} "@group ${WWWGRP}" >> ${PLIST}
+ @${ECHO_CMD} "@mode 755" >> ${PLIST}
+ @${ECHO} @dir ${MOODLEDATADIR} >> ${PLIST}
+ @${ECHO_CMD} "@mode" >> ${PLIST}
+ @${ECHO_CMD} "@group" >> ${PLIST}
+ @${ECHO_CMD} "@owner" >> ${PLIST}
+
+# Here for safety I do not set moodle diretory 0755 permission
+# It require user write config.php manually then.
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >>${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dir ${MOODLEDIR}?g" >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${MOODLEDIR}
+ @${INSTALL} -d ${STAGEDIR}${PREFIX}/${MOODLEDATADIR}
+
+do-install-MIMETEX-on:
+ ${LN} -sf ${PREFIX}/www/mimetex/cgi-bin/mimetex.cgi \
+ ${STAGEDIR}${PREFIX}/${MOODLEDIR}/filter/tex/mimetex.freebsd
+
+.include <bsd.port.mk>
diff --git a/www/moodle31/distinfo b/www/moodle31/distinfo
new file mode 100644
index 000000000000..e2e6c4876a60
--- /dev/null
+++ b/www/moodle31/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1464077765
+SHA256 (moodle-3.1.tgz) = 5debb77fe2a82f28b25505f1244cc9e641b1c0b20dfefe831917c605da74151c
+SIZE (moodle-3.1.tgz) = 37440572
diff --git a/www/moodle31/files/pkg-message.in b/www/moodle31/files/pkg-message.in
new file mode 100644
index 000000000000..f23faec17d77
--- /dev/null
+++ b/www/moodle31/files/pkg-message.in
@@ -0,0 +1,65 @@
+POST-INSTALL CONFIGURATION FOR MOODLE
+=====================================
+
+1) Create a user and a database for Moodle to store all
+ its tables in (or choose an existing database).
+ It doesn't matter what the database or user names are,
+ as this will be configured in a later step.
+ NOTE: this package assumes that either the phpX-pgsql,
+ phpX-mysql, or phpX-mssql packages are installed.
+
+2) Add the following to your Apache configuration file
+ httpd.conf, and restart the server:
+
+ For Apache versions earlier than 2.4:
+
+ Alias /moodle %%PREFIX%%/%%MOODLEDIR%%/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/%%MOODLEDIR%%>
+ AllowOverride None
+ Order Allow,Deny
+ Allow from all
+ </Directory>
+
+ For Apache version 2.4.x or above:
+
+ Alias /moodle %%PREFIX%%/%%MOODLEDIR%%/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/%%MOODLEDIR%%/>
+ AllowOverride None
+ Require all granted
+ </Directory>
+
+3) Visit your Moodle site with a browser (i.e.,
+ http://your.server.com/moodle/), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up Moodle, creating an admin account, etc.
+
+ At one step, you will get a message saying that the
+ installer script was not able to automatically create
+ the config.php file. Just download it and copy it to
+ %%PREFIX%%/%%MOODLEDIR%%/config.php. Beware that it
+ will contain the database password in cleartext, so
+ set up whatever file permissions you deem more adequate.
+ For instance, user=root, group=www, mask=640.
+
+4) Set up a cron task to invoke the file admin/cron.php
+ every five minutes or so. For instance:
+ */5 * * * * fetch http://your.server.com/moodle/admin/cron.php
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://docs.moodle.org/en/Installing_Moodle
+
+It may be worth reading the installation docs even if Moodle seems
+to be working at first, to ensure your PHP settings and database
+configuration will allow Moodle to operate properly.
+
+If you are upgrading from an earlier version of Moodle, check out
+possible additional steps at:
+
+ https://docs.moodle.org/30/en/Upgrading
+
+If you have real trouble, please visit the Moodle course
+"Using Moodle" on moodle.org.
diff --git a/www/moodle31/pkg-descr b/www/moodle31/pkg-descr
new file mode 100644
index 000000000000..fe30e0d25bab
--- /dev/null
+++ b/www/moodle31/pkg-descr
@@ -0,0 +1,7 @@
+Moodle is a course management system (CMS) - a free, Open Source software
+package designed using sound pedagogical principles, to help educators
+create effective online learning communities. You can use it on any
+computer you have handy (including webhosts), yet it can scale from a
+single-teacher site to a 40,000-student University.
+
+WWW: http://www.moodle.org/