aboutsummaryrefslogtreecommitdiff
path: root/www/mozilla/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-06 18:34:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-06 18:34:37 +0000
commit23dad2b5554e624ff2f98d189b1e0c29485bf586 (patch)
tree0bc5df01870d95b2cbb4c6d93ba3c603823a1aff /www/mozilla/Makefile
parentc35077fee69a444f37aef105506c7a04e403edad (diff)
downloadports-23dad2b5554e624ff2f98d189b1e0c29485bf586.tar.gz
ports-23dad2b5554e624ff2f98d189b1e0c29485bf586.zip
Use ${PTHREAD_LIBS} instead of hardcoded -pthread and -lc_r in a few places.
This should help the KSE and libthr people use these applications (plus it lets them build on -CURRENT).
Notes
Notes: svn path=/head/; revision=88641
Diffstat (limited to 'www/mozilla/Makefile')
-rw-r--r--www/mozilla/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 8c76783a4632..be20bbbe9414 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -196,6 +196,13 @@ post-patch:
${WRKSRC}/config/autoconf.mk.in
@${FIND} ${WRKSRC}/other-licenses/libical -name "*.c" | ${XARGS} \
${REINPLACE_CMD} 's|<malloc.h>|<stdlib.h>|g'
+ @${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/nsprpub/config/FreeBSD.mk \
+ ${WRKSRC}/security/coreconf/FreeBSD.mk \
+ ${WRKSRC}/directory/c-sdk/config/FreeBSD.mk \
+ ${WRKSRC}/js/src/Makefile.in
post-build:
${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%MOZILLA%%|${MOZILLA}|g" \