aboutsummaryrefslogtreecommitdiff
path: root/www/mozplugger
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-29 12:20:56 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-29 12:20:56 +0000
commit48f601df41eb19ae004a83d496bd5c190d9958d9 (patch)
tree255a32e23e18ddcb71939adcae98782ab8a69ee2 /www/mozplugger
parent4fd0fd121ecf0b892fde9f77848e3adbd2c60152 (diff)
downloadports-48f601df41eb19ae004a83d496bd5c190d9958d9.tar.gz
ports-48f601df41eb19ae004a83d496bd5c190d9958d9.zip
- Update to 1.7.3
PR: ports/92442 Submitted by: Loren M. Lang <lorenl@alzatex.com> (maintainer)
Notes
Notes: svn path=/head/; revision=154719
Diffstat (limited to 'www/mozplugger')
-rw-r--r--www/mozplugger/Makefile2
-rw-r--r--www/mozplugger/distinfo6
-rw-r--r--www/mozplugger/files/patch-Makefile8
-rw-r--r--www/mozplugger/files/patch-mozplugger.c23
4 files changed, 11 insertions, 28 deletions
diff --git a/www/mozplugger/Makefile b/www/mozplugger/Makefile
index 9cd7f4767a97..2277d5515193 100644
--- a/www/mozplugger/Makefile
+++ b/www/mozplugger/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mozplugger
-PORTVERSION= 1.7.2
+PORTVERSION= 1.7.3
CATEGORIES= www
MASTER_SITES= http://download.mozdev.org/mozplugger/
diff --git a/www/mozplugger/distinfo b/www/mozplugger/distinfo
index e6bb96afbf95..5fa6b760e85b 100644
--- a/www/mozplugger/distinfo
+++ b/www/mozplugger/distinfo
@@ -1,3 +1,3 @@
-MD5 (mozplugger-1.7.2.tar.gz) = d9a4919caf36dbf1fb66b3a034d64cd2
-SHA256 (mozplugger-1.7.2.tar.gz) = 3db40fcd991df2bd95227426e1a398b47caaa16f1854afea18b7a4d2e15743e9
-SIZE (mozplugger-1.7.2.tar.gz) = 54990
+MD5 (mozplugger-1.7.3.tar.gz) = 5b56c7c598e9609d9dca3d7c3a88e124
+SHA256 (mozplugger-1.7.3.tar.gz) = 5dcac24b34db58d17dbf2f9dac720f4172fdec7d72aa56e6f3a38a97fb30c524
+SIZE (mozplugger-1.7.3.tar.gz) = 54718
diff --git a/www/mozplugger/files/patch-Makefile b/www/mozplugger/files/patch-Makefile
index 18f4db5a1d8b..bfa0473e811e 100644
--- a/www/mozplugger/files/patch-Makefile
+++ b/www/mozplugger/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sat Apr 16 12:24:24 2005
-+++ Makefile Tue Jun 7 04:33:19 2005
+--- Makefile.orig Mon Aug 29 14:09:55 2005
++++ Makefile Fri Jan 27 16:37:23 2006
@@ -1,5 +1,5 @@
# Where is your Xwindows located?
-X11=/usr/X11R6
@@ -37,8 +37,8 @@
mozplugger-common.c mozplugger.h README.in
BIN_FILES=mozplugger.so mozplugger-helper
--DEFINES=$(STREAM) -DVERSION=\"$(VERSION)\" -Wall #-DDEBUG #-D__amd64__
-+DEFINES=$(STREAM) -DVERSION=\"$(VERSION)\" -DPREFIX=\"$(prefix)\" -Wall #-DDEBUG #-D__amd64__
+-DEFINES=$(STREAM) -DVERSION=\"$(VERSION)\" #-Wall -DDEBUG #-D__amd64__
++DEFINES=$(STREAM) -DVERSION=\"$(VERSION)\" -DPREFIX=\"$(prefix)\" #-Wall -DDEBUG #-D__amd64__
RPM_OPT_FLAGS=-O2
COMMON_CFLAGS=$(RPM_OPT_FLAGS) -Inpapi/include -I$(X11)/include -DXP_UNIX $(DEFINES)
COMMON_LDFLAGS=
diff --git a/www/mozplugger/files/patch-mozplugger.c b/www/mozplugger/files/patch-mozplugger.c
index bbf0cb982e77..26db7994dd1a 100644
--- a/www/mozplugger/files/patch-mozplugger.c
+++ b/www/mozplugger/files/patch-mozplugger.c
@@ -1,6 +1,6 @@
---- mozplugger.c.orig Sun Apr 17 05:19:59 2005
-+++ mozplugger.c Fri Jun 3 20:55:32 2005
-@@ -568,6 +568,9 @@
+--- mozplugger.c.orig Mon Aug 29 14:08:04 2005
++++ mozplugger.c Fri Jan 27 17:04:36 2006
+@@ -572,6 +572,9 @@
if (cb(fname, data)) return 1;
}
@@ -10,20 +10,3 @@
snprintf(fname, sizeof(fname), "/etc/%s", basename);
if (cb(fname, data)) return 1;
-@@ -1208,6 +1211,8 @@
- *****************************************************************************/
- NPError NPP_SetWindow(NPP instance, NPWindow* window)
- {
-+ XSetWindowAttributes attrib;
-+
- D("SetWindow\n");
-
- if (!instance)
-@@ -1239,7 +1244,6 @@
- D("Writing WIN 0x%x to fd %d\n", window->window, THIS->fd);
- write(THIS->fd, (char *)window, sizeof(*window));
-
-- XSetWindowAttributes attrib;
- attrib.override_redirect = True;
- XChangeWindowAttributes(THIS->display, (Window)THIS->windata.window,
- CWOverrideRedirect, &attrib);