aboutsummaryrefslogtreecommitdiff
path: root/www/neon26
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2007-03-16 10:03:11 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2007-03-16 10:03:11 +0000
commitde7020af32b8546e31c7891c14f28c898ffc74f8 (patch)
tree8bae992377f9c4bda81f1e6be3740ad7e48dc20c /www/neon26
parent248aeb3a1dbbc217a941b4a4f72cca85c19c401b (diff)
downloadports-de7020af32b8546e31c7891c14f28c898ffc74f8.tar.gz
ports-de7020af32b8546e31c7891c14f28c898ffc74f8.zip
(1) Update `www/neon' to 0.26.3
(2) Bump port revisions (and dependencies) on all ports, using libneon (3) Mark `devel/bazaar' broken, it doesn't support new neon version. Approved by maintainer. (4) Mark `www/neonpp' broken, it doesn't support new neon version. Maintainer timeout.
Notes
Notes: svn path=/head/; revision=187477
Diffstat (limited to 'www/neon26')
-rw-r--r--www/neon26/Makefile40
-rw-r--r--www/neon26/distinfo6
-rw-r--r--www/neon26/files/patch-Makefile.in12
-rw-r--r--www/neon26/files/patch-ltmain.sh25
-rw-r--r--www/neon26/pkg-plist27
5 files changed, 46 insertions, 64 deletions
diff --git a/www/neon26/Makefile b/www/neon26/Makefile
index 544a9044dbc9..dda338f2ec24 100644
--- a/www/neon26/Makefile
+++ b/www/neon26/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= neon
-PORTVERSION= 0.25.5
+PORTVERSION= 0.26.3
PORTREVISION= 0
CATEGORIES= www
MASTER_SITES= http://www.webdav.org/neon/ \
@@ -19,6 +19,7 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
+USE_GETTEXT= yes
.ifndef WITHOUT_OPENSSL
USE_OPENSSL= yes
@@ -40,25 +41,26 @@ MAN3= ne_add_request_header.3 ne_addr_destroy.3 ne_addr_error.3 \
ne_buffer_finish.3 ne_buffer_grow.3 ne_buffer_ncreate.3 \
ne_buffer_zappend.3 ne_calloc.3 ne_close_connection.3 ne_forget_auth.3 \
ne_get_error.3 ne_get_response_header.3 ne_get_scheme.3 \
- ne_get_server_hostport.3 ne_get_status.3 ne_iaddr_cmp.3 \
- ne_iaddr_free.3 ne_iaddr_make.3 ne_iaddr_print.3 ne_iaddr_typeof.3 \
- ne_malloc.3 ne_oom_callback.3 ne_print_request_header.3 ne_qtoken.3 \
- ne_realloc.3 ne_request_create.3 ne_request_destroy.3 \
- ne_request_dispatch.3 ne_response_header_iterate.3 ne_session_create.3 \
- ne_session_destroy.3 ne_session_proxy.3 ne_set_error.3 \
- ne_set_persist.3 ne_set_proxy_auth.3 ne_set_read_timeout.3 \
- ne_set_request_body_buffer.3 ne_set_request_body_fd.3 \
+ ne_get_server_hostport.3 ne_get_status.3 ne_has_support.3 \
+ ne_i18n_init.3 ne_iaddr_cmp.3 ne_iaddr_free.3 ne_iaddr_make.3 \
+ ne_iaddr_print.3 ne_iaddr_typeof.3 ne_malloc.3 ne_oom_callback.3 \
+ ne_print_request_header.3 ne_qtoken.3 ne_realloc.3 ne_request_create.3 \
+ ne_request_destroy.3 ne_request_dispatch.3 ne_response_header_iterate.3 \
+ ne_session_create.3 ne_session_destroy.3 ne_session_proxy.3 \
+ ne_set_error.3 ne_set_persist.3 ne_set_proxy_auth.3 \
+ ne_set_read_timeout.3 ne_set_request_body_buffer.3 \
+ ne_set_request_body_fd.3 ne_set_request_body_fd64.3\
ne_set_request_expect100.3 ne_set_server_auth.3 ne_set_useragent.3 \
- ne_shave.3 ne_sock_init.3 ne_ssl_cert_cmp.3 ne_ssl_cert_export.3 \
- ne_ssl_cert_free.3 ne_ssl_cert_identity.3 ne_ssl_cert_import.3 \
- ne_ssl_cert_issuer.3 ne_ssl_cert_read.3 ne_ssl_cert_signedby.3 \
- ne_ssl_cert_subject.3 ne_ssl_cert_write.3 ne_ssl_clicert_decrypt.3 \
- ne_ssl_clicert_encrypted.3 ne_ssl_clicert_free.3 ne_ssl_clicert_name.3 \
- ne_ssl_clicert_owner.3 ne_ssl_clicert_read.3 ne_ssl_dname_cmp.3 \
- ne_ssl_readable_dname.3 ne_ssl_set_verify.3 ne_ssl_trust_cert.3 \
- ne_ssl_trust_default_ca.3 ne_status.3 ne_strdup.3 ne_strndup.3 \
- ne_token.3 ne_version_match.3 ne_version_string.3 ne_xml_create.3 \
- ne_xml_destroy.3 neon.3
+ ne_shave.3 ne_sock_init.3 ne_sock_exit.3 ne_ssl_cert_cmp.3 \
+ ne_ssl_cert_export.3 ne_ssl_cert_free.3 ne_ssl_cert_identity.3 \
+ ne_ssl_cert_import.3 ne_ssl_cert_issuer.3 ne_ssl_cert_read.3 \
+ ne_ssl_cert_signedby.3 ne_ssl_cert_subject.3 ne_ssl_cert_write.3 \
+ ne_ssl_clicert_decrypt.3 ne_ssl_clicert_encrypted.3 ne_ssl_clicert_free.3 \
+ ne_ssl_clicert_name.3 ne_ssl_clicert_owner.3 ne_ssl_clicert_read.3 \
+ ne_ssl_dname_cmp.3 ne_ssl_readable_dname.3 ne_ssl_set_verify.3 \
+ ne_ssl_trust_cert.3 ne_ssl_trust_default_ca.3 ne_status.3 \
+ ne_strdup.3 ne_strndup.3 ne_token.3 ne_version_match.3 \
+ ne_version_string.3 ne_xml_create.3 ne_xml_destroy.3 neon.3
PLIST_SUB+= PORTVERSION=${PORTVERSION}
diff --git a/www/neon26/distinfo b/www/neon26/distinfo
index 3f594bcd0319..2a3674364e1a 100644
--- a/www/neon26/distinfo
+++ b/www/neon26/distinfo
@@ -1,3 +1,3 @@
-MD5 (neon-0.25.5.tar.gz) = b5fdb71dd407f0a3de0f267d27c9ab17
-SHA256 (neon-0.25.5.tar.gz) = b5513f88cb54c5f11e4c8348ee6c7ace9767b45c263c3a3ba8a5ce4e2b40a07a
-SIZE (neon-0.25.5.tar.gz) = 736201
+MD5 (neon-0.26.3.tar.gz) = 6e52cd9c03e372026d6eccbfb80f09ef
+SHA256 (neon-0.26.3.tar.gz) = b6897fb8354424dbd0fb120ee003ad5482f1c3fa61e1f27783ae3af08b2a7b3f
+SIZE (neon-0.26.3.tar.gz) = 789289
diff --git a/www/neon26/files/patch-Makefile.in b/www/neon26/files/patch-Makefile.in
index 15a86d18070d..b0ea71eb41a3 100644
--- a/www/neon26/files/patch-Makefile.in
+++ b/www/neon26/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Mon Sep 22 23:57:02 2003
-+++ Makefile.in Thu Oct 9 13:41:35 2003
+--- Makefile.in.orig Wed Feb 7 15:53:29 2007
++++ Makefile.in Wed Feb 7 16:34:12 2007
@@ -21,7 +21,7 @@
man1dir = $(mandir)/man1
man3dir = $(mandir)/man3
@@ -8,13 +8,13 @@
+docdir = $(datadir)/doc/neon
includedir = @includedir@
neonincludes = $(includedir)/neon
- pkgconfigdir = $(libdir)/pkgconfig
-@@ -132,7 +132,7 @@
+ pkgconfigdir = $(prefix)/libdata/pkgconfig
+@@ -147,7 +147,7 @@
@echo "ERROR: purposes only; this copy of neon must not be installed."
@false
--install-yes: install-lib install-headers install-config install-docs
-+install-yes: install-lib install-headers install-config
+-install-yes: install-lib install-headers install-config install-docs install-nls
++install-yes: install-lib install-headers install-config install-nls
# libtool does all the necessary magic here
install-lib: subdirs
diff --git a/www/neon26/files/patch-ltmain.sh b/www/neon26/files/patch-ltmain.sh
index 003c40b7a007..f44f68cc1521 100644
--- a/www/neon26/files/patch-ltmain.sh
+++ b/www/neon26/files/patch-ltmain.sh
@@ -1,27 +1,10 @@
---- ltmain.sh.orig Wed Jan 23 11:38:40 2002
-+++ ltmain.sh Sun Feb 3 01:44:17 2002
-@@ -1037,8 +1037,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -4179,10 +4190,12 @@
+--- ltmain.sh.orig Wed Feb 7 15:52:17 2007
++++ ltmain.sh Wed Feb 7 15:52:58 2007
+@@ -6038,10 +6038,12 @@
fi
# Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
++ if /usr/bin/false ; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
diff --git a/www/neon26/pkg-plist b/www/neon26/pkg-plist
index 6a45340fb85e..ce13cac81aa6 100644
--- a/www/neon26/pkg-plist
+++ b/www/neon26/pkg-plist
@@ -21,28 +21,23 @@ include/neon/ne_uri.h
include/neon/ne_utils.h
include/neon/ne_xml.h
include/neon/ne_xmlreq.h
-lib/libneon.so.25
+lib/libneon.so.26
lib/libneon.so
lib/libneon.la
lib/libneon.a
libdata/pkgconfig/neon.pc
-%%PORTDOCS%%%%DOCSDIR%%/html/apas01.html
-%%PORTDOCS%%%%DOCSDIR%%/html/apas02.html
-%%PORTDOCS%%%%DOCSDIR%%/html/apas03.html
-%%PORTDOCS%%%%DOCSDIR%%/html/apas04.html
-%%PORTDOCS%%%%DOCSDIR%%/html/apas05.html
-%%PORTDOCS%%%%DOCSDIR%%/html/apas06.html
-%%PORTDOCS%%%%DOCSDIR%%/html/apas07.html
-%%PORTDOCS%%%%DOCSDIR%%/html/apas08.html
-%%PORTDOCS%%%%DOCSDIR%%/html/apas09.html
-%%PORTDOCS%%%%DOCSDIR%%/html/apas10.html
-%%PORTDOCS%%%%DOCSDIR%%/html/apas11.html
-%%PORTDOCS%%%%DOCSDIR%%/html/apas12.html
+share/locale/cs/LC_MESSAGES/neon.mo
+share/locale/de/LC_MESSAGES/neon.mo
+share/locale/fr/LC_MESSAGES/neon.mo
+share/locale/ja/LC_MESSAGES/neon.mo
+share/locale/nn/LC_MESSAGES/neon.mo
+share/locale/ru/LC_MESSAGES/neon.mo
+share/locale/tr/LC_MESSAGES/neon.mo
+share/locale/zh/LC_MESSAGES/neon.mo
%%PORTDOCS%%%%DOCSDIR%%/html/api.html
%%PORTDOCS%%%%DOCSDIR%%/html/biblio.html
%%PORTDOCS%%%%DOCSDIR%%/html/compliance.html
%%PORTDOCS%%%%DOCSDIR%%/html/features.html
-%%PORTDOCS%%%%DOCSDIR%%/html/gfdl.html
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/intro.html
%%PORTDOCS%%%%DOCSDIR%%/html/ref.html
@@ -57,14 +52,16 @@ libdata/pkgconfig/neon.pc
%%PORTDOCS%%%%DOCSDIR%%/html/refclicert.html
%%PORTDOCS%%%%DOCSDIR%%/html/refconfig.html
%%PORTDOCS%%%%DOCSDIR%%/html/referr.html
+%%PORTDOCS%%%%DOCSDIR%%/html/reffeat.html
%%PORTDOCS%%%%DOCSDIR%%/html/refgetst.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refi18n.html
%%PORTDOCS%%%%DOCSDIR%%/html/refiaddr.html
%%PORTDOCS%%%%DOCSDIR%%/html/refneon.html
%%PORTDOCS%%%%DOCSDIR%%/html/refopts.html
%%PORTDOCS%%%%DOCSDIR%%/html/refreq.html
-%%PORTDOCS%%%%DOCSDIR%%/html/refreqopts.html
%%PORTDOCS%%%%DOCSDIR%%/html/refreqbody.html
%%PORTDOCS%%%%DOCSDIR%%/html/refreqhdr.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refreqopts.html
%%PORTDOCS%%%%DOCSDIR%%/html/refresolve.html
%%PORTDOCS%%%%DOCSDIR%%/html/refresphdr.html
%%PORTDOCS%%%%DOCSDIR%%/html/refsess.html