aboutsummaryrefslogtreecommitdiff
path: root/www/neowebscript/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-10-28 08:37:27 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-10-28 08:37:27 +0000
commit40df45352156d24ae7ab2105eaf4b894900455f0 (patch)
tree5f9afb850e66875f994e795c1cb436bef20eb4b3 /www/neowebscript/Makefile
parenta0a9045009a8816019357b0b8b0b8bef31cd46c2 (diff)
downloadports-40df45352156d24ae7ab2105eaf4b894900455f0.tar.gz
ports-40df45352156d24ae7ab2105eaf4b894900455f0.zip
NeoWebScript[tm] is a module for the Apache webserver that allows you to
embed the Tcl/Tk programming language in your webpages as a scripting tool. It was invented by Karl Lehenbauer, NeoSoft's Chief Technical Officer, and documented, enhanced and extended by NeoSoft's programmers and technical writers. WWW: http://www.sourceforge.net/projects/nws/ The changes: . don't build the Apache, TclX, gd, db, neo-tcl bundled in the tarball, but use those that are installed by their ports . don't generate GIFs -- use PNGs . look in /var/log for Apache's log file . use /var/db/neowebscript for caches and per-user databases . expose some configuration knobs into the neowebscript.conf -- there should be no need to edit init.tcl itself anymore All of the bundled demos work, except for the gd-based banner generator. The demo code uses Gdtclft commands that don't exist in the modern Gdtclft.
Notes
Notes: svn path=/head/; revision=49283
Diffstat (limited to 'www/neowebscript/Makefile')
-rw-r--r--www/neowebscript/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/www/neowebscript/Makefile b/www/neowebscript/Makefile
new file mode 100644
index 000000000000..5166d03b03e1
--- /dev/null
+++ b/www/neowebscript/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: neowebscript
+# Date created: October 28, 2001
+# Whom: Mikhail Teterin <mi@aldan.algebra.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= neowebscript
+PORTVERSION= 3.3
+CATEGORIES= www tcl83
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=nws
+
+MAINTAINER= mi@aldan.algebra.com
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+LIB_DEPENDS= neo82:${PORTSDIR}/devel/tcl-neo
+
+MAKEFILE= ${FILESDIR}/Makefile.bsd
+WRKSRC= ${WRKDIR}/${DISTNAME}/modules
+MAKE_ENV+= FILESDIR="${FILESDIR}" INSTALL_DATA="${INSTALL_DATA}"
+
+SUBDIRS= modules neowebscript htdocs # tools
+
+# Only extract what we care for -- the tarball also includes antiquated
+# versions of Apache, TCL, TclX, ITCL, gd...
+EXTRACT_AFTER_ARGS:=| ${TAR} -xf - ${SUBDIRS:%=${PORTNAME}-${PORTVERSION}/%}
+
+post-patch:
+ # Replacing writePNG with writePNG
+ ${PERL} -pi -e 's/writeGIF/writePNG/g' \
+ `find ${WRKSRC}/.. -type f | xargs fgrep -l --mmap writeGIF`
+
+pre-install:
+ # Removing *.orig files and empty directories:
+ find ${WRKSRC}/../neowebscript ${WRKSRC}/../htdocs \
+ \( -type f -name \*.orig -o -type d -empty \) -delete
+
+CONFSCRIPT= ${LOCALBASE}/etc/apache/neowebscript.conf
+PREFIX_CMD= 's^/usr/local^${PREFIX}^g'
+
+post-install:
+ test -e ${CONFSCRIPT} || ${SED} ${PREFIX_CMD} < \
+ ${FILESDIR}/neowebscript.conf > ${CONFSCRIPT}
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CP} -Rp ${WRKSRC}/../htdocs/* ${DOCSDIR}
+.endif
+ @${SED} ${PREFIX_CMD} < ${PKGMESSAGE}
+
+.include <bsd.port.mk>