aboutsummaryrefslogtreecommitdiff
path: root/www/netscape-remote
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-01 02:35:57 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-01 02:35:57 +0000
commitea9fb84528e88cb46e5c541b1dbb2921cf780c7e (patch)
tree0401a86e8482f5a847c2f4d48650d7594797152e /www/netscape-remote
parent9bf909df77772d6780fee3b8f018854bee4e6408 (diff)
downloadports-ea9fb84528e88cb46e5c541b1dbb2921cf780c7e.tar.gz
ports-ea9fb84528e88cb46e5c541b1dbb2921cf780c7e.zip
Initnial import of netscape-remote version 1.0.
A utility to pass commands to a running netscape process. PR: 13727 Submitted by: Kelly Yancey <kbyanc@posi.net>
Notes
Notes: svn path=/head/; revision=22797
Diffstat (limited to 'www/netscape-remote')
-rw-r--r--www/netscape-remote/Makefile28
-rw-r--r--www/netscape-remote/distinfo2
-rw-r--r--www/netscape-remote/files/Makefile22
-rw-r--r--www/netscape-remote/files/patch-aa37
-rw-r--r--www/netscape-remote/pkg-comment1
-rw-r--r--www/netscape-remote/pkg-descr10
-rw-r--r--www/netscape-remote/pkg-plist1
7 files changed, 101 insertions, 0 deletions
diff --git a/www/netscape-remote/Makefile b/www/netscape-remote/Makefile
new file mode 100644
index 000000000000..b4ba2573bc08
--- /dev/null
+++ b/www/netscape-remote/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: netscape-remote
+# Version required: 1.0
+# Date created: 09/13/1999
+# Whom: Kelly Yancey <kbyanc@posi.net>
+#
+# $FreeBSD$
+#
+
+DISTNAME= netscape-remote
+PKGNAME= netscape-remote-1.0
+CATEGORIES= www
+MASTER_SITES= http://home.netscape.com/newsref/std/
+DISTFILES= remote.c vroot.h
+
+MAINTAINER= kbyanc@posi.net
+
+FETCH_BEFORE_ARGS= -b
+
+DIST_SUBDIR= netscape-remote
+NO_WRKSUBDIR= yes
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @cp ${FILESDIR}/Makefile ${WRKDIR}
+ @for i in $(DISTFILES); do ${CP} ${DISTDIR}/${DIST_SUBDIR}/$$i \
+ ${WRKDIR}; done
+
+.include <bsd.port.mk>
diff --git a/www/netscape-remote/distinfo b/www/netscape-remote/distinfo
new file mode 100644
index 000000000000..4fd845721784
--- /dev/null
+++ b/www/netscape-remote/distinfo
@@ -0,0 +1,2 @@
+MD5 (netscape-remote/remote.c) = 1dfd396d83169cd1f286675698899feb
+MD5 (netscape-remote/vroot.h) = cc8e398b414b212c684d774ab87fdf2a
diff --git a/www/netscape-remote/files/Makefile b/www/netscape-remote/files/Makefile
new file mode 100644
index 000000000000..f6b116fdbb42
--- /dev/null
+++ b/www/netscape-remote/files/Makefile
@@ -0,0 +1,22 @@
+X11BASE ?= /usr/X11R6
+INCDIR = -I$(X11BASE)/include
+LIBDIR = -L$(X11BASE)/lib
+LIBS = -lX11 -lXmu
+OBJS = remote.o
+CFLAGS += -DSTANDALONE -g $(INCDIR)
+PREFIX ?= /usr/local
+BSD_INSTALL_PROGRAM ?= /usr/bin/install -c -s
+
+BINARY = netscape-remote
+
+all: remote
+
+remote: $(OBJS)
+ $(CC) $(CFLAGS) $(LIBDIR) $(LIBS) -o $(BINARY) $(OBJS)
+
+install: all
+ $(BSD_INSTALL_PROGRAM) $(BINARY) $(PREFIX)/bin
+
+clean:
+ for i in $(OBJS); do rm -f $$i; done
+ rm -f $(BINARY)
diff --git a/www/netscape-remote/files/patch-aa b/www/netscape-remote/files/patch-aa
new file mode 100644
index 000000000000..cf0b3347e5d8
--- /dev/null
+++ b/www/netscape-remote/files/patch-aa
@@ -0,0 +1,37 @@
+--- remote.c.orig Sun Oct 31 13:45:51 1999
++++ remote.c Sun Oct 31 13:46:28 1999
+@@ -146,11 +146,16 @@
+ }
+ else if (tenative)
+ {
++#ifndef STANDALONE
++ /* no point in harassing the user when run standalone; everyone has
++ * at least netscape 1.1 by now!
++ */
+ fprintf (stderr,
+ "%s: warning: expected version %s but found version\n"
+ "\t%s (0x%x) instead.\n",
+ progname, expected_mozilla_version,
+ tenative_version, (unsigned int) tenative);
++#endif
+ XFree (tenative_version);
+ return tenative;
+ }
+@@ -507,6 +512,8 @@
+ int status = 0;
+ mozilla_remote_init_atoms (dpy);
+
++ if(commands == NULL) return;
++
+ if (window == 0)
+ window = mozilla_remote_find_window (dpy);
+ else
+@@ -566,7 +573,7 @@
+ }
+
+
+-void
++int
+ main (int argc, char **argv)
+ {
+ Display *dpy;
diff --git a/www/netscape-remote/pkg-comment b/www/netscape-remote/pkg-comment
new file mode 100644
index 000000000000..a150d405eda6
--- /dev/null
+++ b/www/netscape-remote/pkg-comment
@@ -0,0 +1 @@
+Utility to pass commands to running netscape process
diff --git a/www/netscape-remote/pkg-descr b/www/netscape-remote/pkg-descr
new file mode 100644
index 000000000000..7e6bf61ca7e3
--- /dev/null
+++ b/www/netscape-remote/pkg-descr
@@ -0,0 +1,10 @@
+This is a sort of "remote control" for netscape navigator, allowing you to
+send commands to a running netscape process. A complete list of commands is
+at:
+
+ WWW: http://home.netscape.com/newsref/std/x-remote.html
+
+Requires netscape navigator 1.1 or higher to do anything useful.
+
+ -Kelly
+ kbyanc@posi.net
diff --git a/www/netscape-remote/pkg-plist b/www/netscape-remote/pkg-plist
new file mode 100644
index 000000000000..206cfe5d7117
--- /dev/null
+++ b/www/netscape-remote/pkg-plist
@@ -0,0 +1 @@
+bin/netscape-remote