aboutsummaryrefslogtreecommitdiff
path: root/www/netscape47-communicator/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1998-11-24 22:05:18 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1998-11-24 22:05:18 +0000
commit47e3bade4518ab26234434e2cbe1f37f6046a1b9 (patch)
treea5718846c7b695d0f5cccfbf19831ac795b7a17a /www/netscape47-communicator/Makefile
parent8e23c00a32fddd84b417d261966eda1a6e99d579 (diff)
downloadports-47e3bade4518ab26234434e2cbe1f37f6046a1b9.tar.gz
ports-47e3bade4518ab26234434e2cbe1f37f6046a1b9.zip
I don't want to see 2.2.8 go out w/o Comunicator 4.5 and this has been
broken for quite some time, so... PR: 8724 Submitted by: Adrian Penisoara <ady@warpnet.ro> Going to get yelled at by: thepish
Notes
Notes: svn path=/head/; revision=14875
Diffstat (limited to 'www/netscape47-communicator/Makefile')
-rw-r--r--www/netscape47-communicator/Makefile31
1 files changed, 18 insertions, 13 deletions
diff --git a/www/netscape47-communicator/Makefile b/www/netscape47-communicator/Makefile
index 3dda042a4140..f148c043cd7e 100644
--- a/www/netscape47-communicator/Makefile
+++ b/www/netscape47-communicator/Makefile
@@ -1,32 +1,33 @@
-# New ports collection makefile for: netscape (full communicator beta)
+# New ports collection makefile for: netscape (communicator suite)
# Version required: 4.5
# Date created: 24 Feb 1997
# Whom: thepish
#
-# $Id: Makefile,v 1.27 1998/10/20 06:45:18 asami Exp $
+# $Id: Makefile,v 1.28 1998/11/24 20:39:55 obrien Exp $
#
DISTNAME= communicator-v45-export.x86-unknown-freebsd
PKGNAME= netscape-communicator-4.5
CATEGORIES= www
-MASTER_SITES= ftp://ftp.netscape.com/pub/communicator/4.5/english/unix/unsupported/freebsd/complete_install/
+MASTER_SITES= ftp://ftp.netscape.com/pub/communicator/4.5/english/unix/unsupported/freebsd/complete_install/
-MAINTAINER= thepish@FreeBSD.ORG
-
-BROKEN= PLIST
+MAINTAINER= thepish@FreeBSD.ORG
NO_LATEST_LINK= yes
-WRKSRC= ${WRKDIR}/communicator-v45.x86-unknown-freebsd
-NO_BUILD= Yes
+WRKSRC= ${WRKDIR}/communicator-v45.x86-unknown-freebsd
+NO_BUILD= Yes
+PLIST_SUB= NDIRBASE=${NDIRBASE}
+NO_FILTER_SHLIBS=yes
-NDIR= ${PREFIX}/lib/netscape.45
+NDIRBASE= netscape-4.5
+NDIR= ${PREFIX}/${NDIRBASE}
BINDIR= ${PREFIX}/bin
.if defined(USE_128BIT)
MASTER_SITES+= ftp://ftp.fortify.net/pub/Fortify/ \
ftp://ftp.za.freebsd.org/pub/Fortify/
DISTFILES+= Fortify-1.3.0-unix-x86.tar.gz
-RESTRICTED= "Contains strong cryptography"
+RESTRICTED= "Contains strong cryptography"
.else
pre-extract:
@${ECHO} "You can make Netscape use 128-bit encryption by defining USE_128BIT"
@@ -39,15 +40,19 @@ pre-extract:
@${ECHO} "concurrently."
.endif
+post-configure:
+ ${SED} -e "s;@X11BASE@;${X11BASE};g" \
+ -e "s;@PREFIX@;${PREFIX};g" \
+ -e "s;@NDIR@;${NDIR};g" \
+ ${FILESDIR}/netscape.sh >${WRKSRC}/netscape
do-install:
cd ${WRKSRC} && \
yes "" | LC_TIME=C MOZILLA_HOME="${NDIR}" ./ns-install
${MV} -f ${NDIR}/netscape ${NDIR}/communicator-4.5.bin
-.if defined(MULTIVERSION)
${INSTALL_SCRIPT} ${WRKSRC}/netscape ${BINDIR}/communicator-4.5
-.else
- ${INSTALL_SCRIPT} ${WRKSRC}/netscape ${BINDIR}
+.if !defined(MULTIVERSION)
+ ${LN} -sf ${BINDIR}/communicator-4.5 ${BINDIR}/netscape
.endif
if [ ! -f ${NDIR}/mailcap ] ; then \
${INSTALL_DATA} ${FILESDIR}/mailcap ${NDIR}; \