aboutsummaryrefslogtreecommitdiff
path: root/www/netscape7
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-01-26 11:53:00 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2002-01-26 11:53:00 +0000
commit91176d081316eb67884b90497cd298200313a1f9 (patch)
tree1ec8dab93aab495c1f056fd46f2ce87c4a90cca1 /www/netscape7
parent4da9d97a784561c707f758f5e2da6dca69e93410 (diff)
downloadports-91176d081316eb67884b90497cd298200313a1f9.tar.gz
ports-91176d081316eb67884b90497cd298200313a1f9.zip
Add dialog(1) technology, cribbed from the ghostscript-gnu and
mod_php4 ports.
Notes
Notes: svn path=/head/; revision=53783
Diffstat (limited to 'www/netscape7')
-rw-r--r--www/netscape7/Makefile28
-rw-r--r--www/netscape7/scripts/configure62
2 files changed, 72 insertions, 18 deletions
diff --git a/www/netscape7/Makefile b/www/netscape7/Makefile
index 3e207bf8c18f..a78251159895 100644
--- a/www/netscape7/Makefile
+++ b/www/netscape7/Makefile
@@ -42,21 +42,6 @@ MASTER_SITES= ftp://ftp.netscape.com/pub/netscape6/english/${PORTVERSION}/unix/l
ftp://sunsite.sut.ac.jp/pub/archives/WWW/netscape/netscape6/english/${PORTVERSION}/unix/linux22/xpi/ \
ftp://ftp.mirror.ac.uk/sites/ftp.netscape.com/pub/netscape6/english/${PORTVERSION}/unix/linux22/xpi/ \
ftp://ftp.ntua.gr/pub/www/Netscape/netscape6/english/${PORTVERSION}/unix/linux22/xpi/
-DISTFILES= browser.xpi \
- deflenus.xpi \
- langenus.xpi \
- flash.xpi \
- jre.xpi \
- langenus.xpi \
- mail.xpi \
- psm.xpi \
- regca.xpi \
- reges.xpi \
- reggb.xpi \
- regus.xpi \
- spellchecker.xpi \
- talkback.xpi \
- xpcom.xpi
DIST_SUBDIR= netscape6/english/${PORTVERSION}
PATCH_SITES= ${MASTER_SITE_LOCAL}
@@ -83,12 +68,19 @@ INSTALL_DIR= ${PREFIX}/lib/linux-netscape6
PLIST= ${WRKDIR}/pkg-plist
STARTUP_CMD= netscape6
+.include <bsd.port.pre.mk>
+
+pre-everything::
+ ${MKDIR} ${WRKSRC}/bin/plugins/java2 ${WRKSRC}/bin/chrome \
+ ${WRKSRC}/plugins
+ ${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure
+DISTFILES!=${CAT} ${.CURDIR}/work/${WRKSRC}/components.conf; ${TRUE}
+
do-extract:
- ${MKDIR} ${WRKSRC}
.for i in ${DISTFILES}
unzip -qo ${DISTDIR}/${DIST_SUBDIR}/${i} -d ${WRKSRC}
.endfor
- ${MV} ${WRKSRC}/jre-image-i386 ${WRKSRC}/bin/plugins/java2
+ - ${MV} ${WRKSRC}/jre-image-i386 ${WRKSRC}/bin/plugins/java2
cd ${WRKSRC}/bin/plugins && ${LN} -s java2/plugin/i386/ns600/libjavaplugin_oji.so;
do-patch:
@@ -125,4 +117,4 @@ do-install:
post-install:
${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/netscape7/scripts/configure b/www/netscape7/scripts/configure
new file mode 100644
index 000000000000..d700ef81994b
--- /dev/null
+++ b/www/netscape7/scripts/configure
@@ -0,0 +1,62 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+echo ${WRKSRC}/components.conf
+if [ -f ${WRKSRC}/components.conf ]; then
+ exit
+fi
+
+tempfile=`/usr/bin/mktemp -t checklist`
+
+if [ "${BATCH}" ]; then
+ if [ "${NETSCAPE6_OPTIONS}" ]; then
+ set ${NETSCAPE6_OPTIONS}
+ else
+ set \"zlib\" \"MySQL\"
+ fi
+else
+
+/usr/bin/dialog --title "Netscape 6 component selection" --clear \
+ --checklist "\n\
+Choose components of Netscape 6 to download and install. \n\
+Press the space bar to toggle selections." -1 -1 16 \
+"browser" "browser (6576 kB)" ON \
+"deflenus" "American English profile defaults (26 kB)" ON \
+"flash" "Flash plugin (576 kB)" ON \
+"jre" "Java plugin (13808 kB)" ON \
+"langenus" "American English language pack (608 kB)" ON \
+"mail" "e-mail and news (1824 kB)" ON \
+"psm" "Personal Security Manager (592 kB)" ON \
+"regca" "regional settings for Canada (56 kB)" ON \
+"reges" "regional settings for Latin America (54 kB)" ON \
+"reggb" "regional settings for the UK (58 kB)" ON \
+"regus" "regional settings for the USA (56 kB)" ON \
+"spellchecker" "spell-checker (544 kB)" ON \
+"talkback" "talkback (832 kB)" ON \
+"xpcom" "xpcom (720 kB)" ON \
+2> /tmp/checklist.tmp.$$
+
+retval=$?
+
+choice=`cat /tmp/checklist.tmp.$$`
+rm -f /tmp/checklist.tmp.$$
+
+case $retval in
+ 0) if [ -z "$choice" ]; then
+ echo "Nothing selected"
+ exit 1;
+ fi
+ ;;
+ 1) echo "Cancel pressed."
+ exit 1
+ ;;
+esac
+
+echo "$choice" \
+ | sed -e "s/\"//g" \
+ | sed -e "s/ /.xpi /g" \
+ | sed -e "s/$/.xpi/g" \
+ | perl -pi -e "s/ /\n/g" \
+ > ${WRKSRC}/components.conf
+fi