aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2010-01-14 18:55:41 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2010-01-14 18:55:41 +0000
commit1d924da9fe462c8ed5dc4d90d01a9ced86fdf81b (patch)
treec8bea09566f700db62dee77a0e88ba11df86c41f /www/nginx
parentf01179356bdf760c65c3a15b3a687fb1653560c9 (diff)
downloadports-1d924da9fe462c8ed5dc4d90d01a9ced86fdf81b.tar.gz
ports-1d924da9fe462c8ed5dc4d90d01a9ced86fdf81b.zip
Use USE_OPENSSL instead of bsd.openssl.mk.
Do not remove default DISTFILES due to port building failure when third-party module (i.e. additional DISTFILES) selected. Do not bump PORTREVISIONs. PRs: 142831, 142833
Notes
Notes: svn path=/head/; revision=247875
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 1ecfa934d73f..3dbb8cf6647f 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -75,8 +75,6 @@ USE_RUBY= yes
USE_RAKE= yes
.endif
-.include <bsd.port.pre.mk>
-
NGINX_VARDIR?= /var
NGINX_LOGDIR?= ${NGINX_VARDIR}/log
NGINX_RUNDIR?= ${NGINX_VARDIR}/run
@@ -390,11 +388,13 @@ CONFIGURE_ARGS+=--with-mail_ssl_module
.endif # WITH_MAIL_MODULE
.if defined(NGINX_OPENSSL)
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+USE_OPENSSL= yes
.endif
PLIST_SUB+= NGINX_TMPDIR=${NGINX_TMPDIR} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
+.include <bsd.port.pre.mk>
+
pre-everything::
@${ECHO_MSG}
.if defined(WITH_HTTP_UPSTREAM_FAIR)