aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2010-01-11 07:43:39 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2010-01-11 07:43:39 +0000
commit46138ea4730c9d9efb13f3c4d879d0a1917e81f3 (patch)
treefc26071ce817679ef924b1ad33b2698b73adbb15 /www/nginx
parent17200acc4f4a0d3c6ca50eea670887ddecb0b507 (diff)
downloadports-46138ea4730c9d9efb13f3c4d879d0a1917e81f3.tar.gz
ports-46138ea4730c9d9efb13f3c4d879d0a1917e81f3.zip
Accordingly add ngx_cache_purge-1.0, the module adding ability
to purge content from nginx's FastCGI and proxy caches. Do not bump PORTREVISIONs.
Notes
Notes: svn path=/head/; revision=247596
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile8
-rw-r--r--www/nginx/distinfo3
2 files changed, 11 insertions, 0 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 3fdeadeefff0..1ecfa934d73f 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -42,6 +42,7 @@ OPTIONS= DEBUG "Build with debug" off \
MAIL_SMTP_MODULE "Enable SMTP proxy module" off \
MAIL_SSL_MODULE "Enable mail_ssl module" off \
WWW "Enable html sample files" on \
+ CACHE_PURGE_MODULE "3rd party cache_purge module" off \
HTTP_ACCESSKEY_MODULE "3rd party http_accesskey module" off \
HTTP_AUTH_PAM_MODULE "3rd party http_auth_pam module" off \
HTTP_EVAL_MODULE "3rd party eval module" off \
@@ -152,6 +153,13 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_auth_pam_module-${NGINX_AUTH_PAM
CONFIGURE_ARGS+=--without-http-cache
.endif
+.if defined(WITH_CACHE_PURGE_MODULE)
+NGINX_CACHE_PURGE_MODULE_VERSION= 1.0
+MASTER_SITES+= http://labs.frickle.com/files/:cache_purge
+DISTFILES+= ngx_cache_purge-${NGINX_CACHE_PURGE_MODULE_VERSION}.tar.gz:cache_purge
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_cache_purge-${NGINX_CACHE_PURGE_MODULE_VERSION}
+.endif
+
.if defined(WITH_HTTP_DAV_MODULE)
CONFIGURE_ARGS+=--with-http_dav_module
.endif
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index b8a4e9c3f1d1..b77f7beaa871 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -7,6 +7,9 @@ SIZE (nginx-accesskey-2.0.3.tar.gz) = 2632
MD5 (ngx_http_auth_pam_module-1.1.tar.gz) = 4e30d7481f6cb90bbf6c43c50b5c8502
SHA256 (ngx_http_auth_pam_module-1.1.tar.gz) = ea9da5f106b952729398248cddabbe25f7a5752993e91c9b8252dbc2b03b8ecd
SIZE (ngx_http_auth_pam_module-1.1.tar.gz) = 5193
+MD5 (ngx_cache_purge-1.0.tar.gz) = ec1dabaa8321530c100f9baf65370294
+SHA256 (ngx_cache_purge-1.0.tar.gz) = 6f4229a4edc0e8b914dc89c0a3c5b6a746469a3f9e5942b3d025dbe6a5ab2d13
+SIZE (ngx_cache_purge-1.0.tar.gz) = 4569
MD5 (nginx_eval_module-1.0.1.tar.gz) = 570b6f7e40e489c5846ffca725226edb
SHA256 (nginx_eval_module-1.0.1.tar.gz) = f11ba0bf445f0eafd999d52817e298b1f1b09817f74b6120ed491e611d53c798
SIZE (nginx_eval_module-1.0.1.tar.gz) = 4974