aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2010-06-30 17:35:58 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2010-06-30 17:35:58 +0000
commit9b4375aa3eab5f3b79ee438ce03db70f48ebabdb (patch)
treeee0f9937fcac744d3593a97f409b47ba7b18dc65 /www/nginx
parent672d75d729b9c47a295c5c664b038e52f01ca8b9 (diff)
downloadports-9b4375aa3eab5f3b79ee438ce03db70f48ebabdb.tar.gz
ports-9b4375aa3eab5f3b79ee438ce03db70f48ebabdb.zip
Accordingly update passenger from 2.2.14 to 2.2.15 for:
o) www/nginx and www/nginx-devel [1] o) www/rubygem-passenger [2] Remove needless patch. [1] Do not bump PORTREVISION. [2] Approved by: Jacob Atzen aka jatzen at gmail dot com (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=257218
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile4
-rw-r--r--www/nginx/distinfo6
-rw-r--r--www/nginx/files/extra-patch-StaticContentHandler.c15
3 files changed, 4 insertions, 21 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 199d5ecde86c..aa3004aeb760 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -381,7 +381,7 @@ CONFIGURE_ARGS+=--with-pcre
.endif
.if defined(WITH_PASSENGER_MODULE)
-PASSENGER_VERSION= 2.2.14
+PASSENGER_VERSION= 2.2.15
MASTER_SITES+= RF/passenger/:passenger
DISTFILES+= passenger-${PASSENGER_VERSION}.tar.gz:passenger
CONFIGURE_ARGS+=--add-module=${WRKDIR}/passenger-${PASSENGER_VERSION}/ext/nginx
@@ -481,8 +481,6 @@ post-patch:
@${REINPLACE_CMD} '377s!-g!${CXXFLAGS}!; \
s!-lpthread!${PTHREAD_LIBS}!g' \
${WRKDIR}/passenger-${PASSENGER_VERSION}/lib/phusion_passenger/platform_info.rb
- @${PATCH} ${PATCH_ARGS} < \
- ${PATCHDIR}/extra-patch-StaticContentHandler.c
.endif
.if defined(WITH_HTTP_UPSTREAM_HASH)
@${PATCH} ${PATCH_ARGS} < \
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 0d5d127f0017..3f3d7ab448db 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -70,9 +70,9 @@ SIZE (mod_zip-1.1.5.tar.gz) = 19126
MD5 (ngx_http_memc_module-0.08.tar.gz) = b18562b966fc2ae116762612da704407
SHA256 (ngx_http_memc_module-0.08.tar.gz) = 1d786ba382d3fa5f0036d1831c8a21e1c787f5aa64ebec50820510bf72f2ccce
SIZE (ngx_http_memc_module-0.08.tar.gz) = 92182
-MD5 (passenger-2.2.14.tar.gz) = 296205978dffe1de3c35bf844c2bc3c7
-SHA256 (passenger-2.2.14.tar.gz) = 9d23b509324a0d00c3e1aac1402a36ffa2470edf8dd13ab999bf260287481d2b
-SIZE (passenger-2.2.14.tar.gz) = 2207394
+MD5 (passenger-2.2.15.tar.gz) = a156bb47e79b00d063d08fc5715dec0c
+SHA256 (passenger-2.2.15.tar.gz) = 95a9f61070d268ecaa311539d8e28b348765ca0e1528665ef928fc4b4bcc1436
+SIZE (passenger-2.2.15.tar.gz) = 2128473
MD5 (ngx_slowfs_cache-1.5.tar.gz) = 165c93b1adc6b5cebc2b2aa28f881682
SHA256 (ngx_slowfs_cache-1.5.tar.gz) = 8f3d1afd6bcaaeba89bc4f9d5e5ba3e2b334bf8e7e5b56bd37f25b5cbac8d828
SIZE (ngx_slowfs_cache-1.5.tar.gz) = 9785
diff --git a/www/nginx/files/extra-patch-StaticContentHandler.c b/www/nginx/files/extra-patch-StaticContentHandler.c
deleted file mode 100644
index 60a108f77186..000000000000
--- a/www/nginx/files/extra-patch-StaticContentHandler.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- ../passenger-2.2.14/ext/nginx/StaticContentHandler.c.orig 2010-06-04 14:37:15.000000000 +0400
-+++ ../passenger-2.2.14/ext/nginx/StaticContentHandler.c 2010-06-07 16:59:47.000000000 +0400
-@@ -67,12 +67,6 @@
- return NGX_DECLINED;
- }
-
-- #if NGINX_VERSION_NUM < 8038
-- if (r->zero_in_uri) {
-- return NGX_DECLINED;
-- }
-- #endif
--
- log = r->connection->log;
-
- ngx_log_debug1(NGX_LOG_DEBUG_HTTP, log, 0,