aboutsummaryrefslogtreecommitdiff
path: root/www/npm
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-02-01 02:24:32 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-02-01 02:24:32 +0000
commit1c8e74a752a6bdde5efed2778067e96a10cde426 (patch)
tree82a4a5262615a4802dd9ebe8876c4078336a2caf /www/npm
parent4e8c5ab888f507352331d08b0372cce971107861 (diff)
downloadports-1c8e74a752a6bdde5efed2778067e96a10cde426.tar.gz
ports-1c8e74a752a6bdde5efed2778067e96a10cde426.zip
- Update to 1.2.4
Notes
Notes: svn path=/head/; revision=311347
Diffstat (limited to 'www/npm')
-rw-r--r--www/npm/Makefile10
-rw-r--r--www/npm/distinfo4
-rw-r--r--www/npm/pkg-plist20
3 files changed, 22 insertions, 12 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index ddff99f38017..49fbf1690cb3 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= npm
-PORTVERSION= 1.2.0
+PORTVERSION= 1.2.4
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
@@ -21,10 +21,10 @@ USE_XZ= yes
MAN1= README.1 adduser.1 bin.1 bugs.1 build.1 bundle.1 cache.1 \
changelog.1 coding-style.1 completion.1 config.1 dedupe.1 \
deprecate.1 developers.1 disputes.1 docs.1 edit.1 explore.1 \
- faq.1 folders.1 help-search.1 help.1 index.1 init.1 install.1 \
- json.1 link.1 ls.1 npm.1 outdated.1 owner.1 pack.1 prefix.1 \
- prune.1 publish.1 rebuild.1 registry.1 removing-npm.1 \
- restart.1 root.1 run-script.1 scripts.1 search.1 semver.1 \
+ faq.1 folders.1 global.1 help-search.1 help.1 index.1 init.1 \
+ install.1 json.1 link.1 ls.1 npm.1 outdated.1 owner.1 pack.1 \
+ prefix.1 prune.1 publish.1 rebuild.1 registry.1 removing-npm.1 \
+ restart.1 rm.1 root.1 run-script.1 scripts.1 search.1 semver.1 \
shrinkwrap.1 star.1 start.1 stop.1 submodule.1 tag.1 test.1 \
uninstall.1 unpublish.1 update.1 version.1 view.1 whoami.1
MAN3= bin.3 bugs.3 commands.3 config.3 deprecate.3 docs.3 edit.3 \
diff --git a/www/npm/distinfo b/www/npm/distinfo
index 04e1b98faa37..1cab333a5c55 100644
--- a/www/npm/distinfo
+++ b/www/npm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (npm-1.2.0.tar.xz) = f5c8af4eaec9ae0f43cbd7fec32dafd99de3945c97a0ed6e477afa43d4379920
-SIZE (npm-1.2.0.tar.xz) = 1603892
+SHA256 (npm-1.2.4.tar.xz) = bbb3f54867d17b5548d4bcb27c9210a7d8c7b92294d88ed89fe556424eb3d605
+SIZE (npm-1.2.4.tar.xz) = 1610112
diff --git a/www/npm/pkg-plist b/www/npm/pkg-plist
index 4fede40f027f..2ed5ff113b0c 100644
--- a/www/npm/pkg-plist
+++ b/www/npm/pkg-plist
@@ -69,6 +69,7 @@ lib/node_modules/npm/doc/cli/edit.md
lib/node_modules/npm/doc/cli/explore.md
lib/node_modules/npm/doc/cli/faq.md
lib/node_modules/npm/doc/cli/folders.md
+lib/node_modules/npm/doc/cli/global.md
lib/node_modules/npm/doc/cli/help-search.md
lib/node_modules/npm/doc/cli/help.md
lib/node_modules/npm/doc/cli/index.md
@@ -88,6 +89,7 @@ lib/node_modules/npm/doc/cli/rebuild.md
lib/node_modules/npm/doc/cli/registry.md
lib/node_modules/npm/doc/cli/removing-npm.md
lib/node_modules/npm/doc/cli/restart.md
+lib/node_modules/npm/doc/cli/rm.md
lib/node_modules/npm/doc/cli/root.md
lib/node_modules/npm/doc/cli/run-script.md
lib/node_modules/npm/doc/cli/scripts.md
@@ -164,6 +166,7 @@ lib/node_modules/npm/html/doc/edit.html
lib/node_modules/npm/html/doc/explore.html
lib/node_modules/npm/html/doc/faq.html
lib/node_modules/npm/html/doc/folders.html
+lib/node_modules/npm/html/doc/global.html
lib/node_modules/npm/html/doc/help-search.html
lib/node_modules/npm/html/doc/help.html
lib/node_modules/npm/html/doc/index.html
@@ -183,6 +186,7 @@ lib/node_modules/npm/html/doc/rebuild.html
lib/node_modules/npm/html/doc/registry.html
lib/node_modules/npm/html/doc/removing-npm.html
lib/node_modules/npm/html/doc/restart.html
+lib/node_modules/npm/html/doc/rm.html
lib/node_modules/npm/html/doc/root.html
lib/node_modules/npm/html/doc/run-script.html
lib/node_modules/npm/html/doc/scripts.html
@@ -331,6 +335,7 @@ lib/node_modules/npm/node_modules/fstream-npm/example/ig-tar.js
lib/node_modules/npm/node_modules/fstream-npm/example/tar.js
lib/node_modules/npm/node_modules/fstream-npm/fstream-npm.js
lib/node_modules/npm/node_modules/fstream-npm/node_modules/fstream-ignore/.npmignore
+lib/node_modules/npm/node_modules/fstream-npm/node_modules/fstream-ignore/LICENSE
lib/node_modules/npm/node_modules/fstream-npm/node_modules/fstream-ignore/README.md
lib/node_modules/npm/node_modules/fstream-npm/node_modules/fstream-ignore/example/basic.js
lib/node_modules/npm/node_modules/fstream-npm/node_modules/fstream-ignore/ignore.js
@@ -379,6 +384,7 @@ lib/node_modules/npm/node_modules/glob/glob.js
lib/node_modules/npm/node_modules/glob/package.json
lib/node_modules/npm/node_modules/glob/test/00-setup.js
lib/node_modules/npm/node_modules/glob/test/bash-comparison.js
+lib/node_modules/npm/node_modules/glob/test/bash-results.json
lib/node_modules/npm/node_modules/glob/test/cwd-test.js
lib/node_modules/npm/node_modules/glob/test/mark.js
lib/node_modules/npm/node_modules/glob/test/pause-resume.js
@@ -1592,6 +1598,7 @@ lib/node_modules/npm/node_modules/npmconf/test/fixtures/builtin
lib/node_modules/npm/node_modules/npmconf/test/fixtures/globalconfig
lib/node_modules/npm/node_modules/npmconf/test/fixtures/userconfig
lib/node_modules/npm/node_modules/npmconf/test/save.js
+lib/node_modules/npm/node_modules/npmconf/x.diff
lib/node_modules/npm/node_modules/npmlog/LICENSE
lib/node_modules/npm/node_modules/npmlog/README.md
lib/node_modules/npm/node_modules/npmlog/example.js
@@ -1837,10 +1844,6 @@ lib/node_modules/npm/test/packages/npm-test-missing-bindir/test.js
lib/node_modules/npm/test/packages/npm-test-optional-deps/README
lib/node_modules/npm/test/packages/npm-test-optional-deps/package.json
lib/node_modules/npm/test/packages/npm-test-optional-deps/test.js
-lib/node_modules/npm/test/packages/npm-test-peer-deps-invalid/README
-lib/node_modules/npm/test/packages/npm-test-peer-deps-invalid/npm-ls.json
-lib/node_modules/npm/test/packages/npm-test-peer-deps-invalid/package.json
-lib/node_modules/npm/test/packages/npm-test-peer-deps-invalid/test.js
lib/node_modules/npm/test/packages/npm-test-peer-deps/README
lib/node_modules/npm/test/packages/npm-test-peer-deps/npm-ls.json
lib/node_modules/npm/test/packages/npm-test-peer-deps/package.json
@@ -1863,8 +1866,16 @@ lib/node_modules/npm/test/run.js
lib/node_modules/npm/test/tap/false_name.js
lib/node_modules/npm/test/tap/false_name/index.js
lib/node_modules/npm/test/tap/false_name/package.json
+lib/node_modules/npm/test/tap/package-with-peer-dep/package.json
+lib/node_modules/npm/test/tap/peer-deps-invalid.js
+lib/node_modules/npm/test/tap/peer-deps-invalid/package.json
+lib/node_modules/npm/test/tap/peer-deps-without-package-json.js
+lib/node_modules/npm/test/tap/peer-deps-without-package-json/.gitkeep
lib/node_modules/npm/test/tap/publish-config.js
lib/node_modules/npm/test/update-test.sh
+@dirrm lib/node_modules/npm/test/tap/peer-deps-without-package-json
+@dirrm lib/node_modules/npm/test/tap/peer-deps-invalid
+@dirrm lib/node_modules/npm/test/tap/package-with-peer-dep
@dirrm lib/node_modules/npm/test/tap/false_name
@dirrm lib/node_modules/npm/test/tap
@dirrm lib/node_modules/npm/test/packages/npm-test-url-dep
@@ -1873,7 +1884,6 @@ lib/node_modules/npm/test/update-test.sh
@dirrm lib/node_modules/npm/test/packages/npm-test-private
@dirrm lib/node_modules/npm/test/packages/npm-test-platform-all
@dirrm lib/node_modules/npm/test/packages/npm-test-platform
-@dirrm lib/node_modules/npm/test/packages/npm-test-peer-deps-invalid
@dirrm lib/node_modules/npm/test/packages/npm-test-peer-deps
@dirrm lib/node_modules/npm/test/packages/npm-test-optional-deps
@dirrm lib/node_modules/npm/test/packages/npm-test-missing-bindir