aboutsummaryrefslogtreecommitdiff
path: root/www/npm
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-05-14 18:52:39 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-05-14 18:52:39 +0000
commit5502f121de9b1b814e90e8305151668daab46cbe (patch)
treea378a59e3239633142a34e668ed6d08334908d1d /www/npm
parentbc24ff0b726af4c8196954c09705638689ae2783 (diff)
downloadports-5502f121de9b1b814e90e8305151668daab46cbe.tar.gz
ports-5502f121de9b1b814e90e8305151668daab46cbe.zip
- Allow node-devel users to install npm
Notes
Notes: svn path=/head/; revision=296601
Diffstat (limited to 'www/npm')
-rw-r--r--www/npm/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index efe8617e4443..3d6b58264a6b 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Node package manager
-RUN_DEPENDS= node>=0.6:${PORTSDIR}/www/node
+OPTIONS= NODE_DEVEL "Use www/node-devel instead of www/node" off
NO_BUILD= yes
USE_XZ= yes
@@ -42,4 +42,12 @@ MAN3= npm.3 npm-bin.3 npm-bugs.3 npm-commands.3 npm-config.3 \
npm-tag.3 npm-test.3 npm-uninstall.3 npm-unpublish.3 \
npm-update.3 npm-version.3 npm-view.3 npm-whoami.3
+.include <bsd.port.options.mk>
+
+.if !defined(WITH_NODE_DEVEL)
+RUN_DEPENDS= ${LOCALBASE}/bin/node:${PORTSDIR}/www/node
+.else
+RUN_DEPENDS= ${LOCALBASE}/bin/node:${PORTSDIR}/www/node-devel
+.endif
+
.include <bsd.port.mk>