aboutsummaryrefslogtreecommitdiff
path: root/www/nspluginwrapper-devel
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-06-06 02:04:00 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-06-06 02:04:00 +0000
commit86c73fa3ae0f80ea5281e2d25a989c194c9e9321 (patch)
treee7a4550ced5d205f7f3778e07d6ddb564dd20404 /www/nspluginwrapper-devel
parent66168bdde5afaecf16892cf3fcdbe87c39558972 (diff)
downloadports-86c73fa3ae0f80ea5281e2d25a989c194c9e9321.tar.gz
ports-86c73fa3ae0f80ea5281e2d25a989c194c9e9321.zip
- This port requires linux-gtk2 instead of the native one
- This port needs both native and linux version of libX11. Since there is no good way to specify the native one, repeat the logic in bsd.port.mk here. Reported by: Henrik Brix Andersen, TooMany Secrets <toomany at toomany.net> - Respect X11BASE in configure script PR: ports/112274 Approved by: Dave Grochowski (maintainer)
Notes
Notes: svn path=/head/; revision=192866
Diffstat (limited to 'www/nspluginwrapper-devel')
-rw-r--r--www/nspluginwrapper-devel/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/www/nspluginwrapper-devel/Makefile b/www/nspluginwrapper-devel/Makefile
index 3197d7620fa4..1b601a14259d 100644
--- a/www/nspluginwrapper-devel/Makefile
+++ b/www/nspluginwrapper-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nspluginwrapper
PORTVERSION= 0.9.91.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www linux emulators
MASTER_SITES= http://gwenole.beauchesne.info/projects/nspluginwrapper/files/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${RPMFILE}
@@ -17,6 +17,7 @@ MAINTAINER= malus.x@gmail.com
COMMENT= A compatibility plugin for Netscape 4 (NPAPI) plugins
EXTRACT_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2
RPMFILE= ${PORTNAME}-i386-${PORTVERSION}-1.x86_64.rpm
@@ -25,7 +26,7 @@ ONLY_FOR_ARCHS= i386 amd64
USE_BZIP2= yes
USE_LINUX= yes
USE_XLIB= yes
-USE_GNOME= glib20 gtk20 pkgconfig
+USE_GNOME= glib20 pkgconfig
CFLAGS+= -std=c99
@@ -49,6 +50,7 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's,x86_64,amd64,g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' ${WRKSRC}/configure
post-install:
${MKDIR} ${LIBDIR}/i386/linux
@@ -56,4 +58,14 @@ post-install:
${LIBDIR}/i386/linux/
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# XXX switch to USE_XORG once XFree86-4 is removed
+.if ${X_WINDOW_SYSTEM:L} == xorg
+BUILD_DEPENDS+= ${X11BASE}/libdata/xorg/libraries:${X_LIBRARIES_PORT}
+RUN_DEPENDS+= ${X11BASE}/libdata/xorg/libraries:${X_LIBRARIES_PORT}
+.else
+LIB_DEPENDS+= X11.6:${X_LIBRARIES_PORT}
+.endif
+
+.include <bsd.port.post.mk>