aboutsummaryrefslogtreecommitdiff
path: root/www/ompload
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2010-01-17 20:00:33 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2010-01-17 20:00:33 +0000
commit00a2190eda14e679182b03c24b80c5e42b4977bc (patch)
tree2496cc9c15ac7f94e3c22f57e118fb95ca044c6c /www/ompload
parente70ef6e4d46de420a6ec489fb7a00bd626efb6f0 (diff)
downloadports-00a2190eda14e679182b03c24b80c5e42b4977bc.tar.gz
ports-00a2190eda14e679182b03c24b80c5e42b4977bc.zip
Ruby script to upload files on http://omploader.org.
WWW: http://omploader.org PR: ports/141127 Submitted by: Philippe Pepiot <phil@philpep.org>
Notes
Notes: svn path=/head/; revision=248028
Diffstat (limited to 'www/ompload')
-rw-r--r--www/ompload/Makefile32
-rw-r--r--www/ompload/distinfo3
-rw-r--r--www/ompload/pkg-descr2
3 files changed, 37 insertions, 0 deletions
diff --git a/www/ompload/Makefile b/www/ompload/Makefile
new file mode 100644
index 000000000000..bdeebbf2f034
--- /dev/null
+++ b/www/ompload/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: ompload
+# Date created: 3 December 2009
+# Whom: Philippe Pepiot
+#
+# $FreeBSD$
+#
+
+PORTNAME= ompload
+PORTVERSION= 1
+CATEGORIES= www
+MASTER_SITES= http://omploader.org/
+DISTNAME= ompload
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= phil@philpep.org
+COMMENT= Upload files to omploader.org
+
+RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl
+
+USE_RUBY= yes
+
+NO_MAN= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/ompload
+
+do-install:
+ ${INSTALL_SCRIPT} ${DISTDIR}/ompload ${PREFIX}/bin/ompload
+
+.include <bsd.port.mk>
diff --git a/www/ompload/distinfo b/www/ompload/distinfo
new file mode 100644
index 000000000000..482e6f4ec383
--- /dev/null
+++ b/www/ompload/distinfo
@@ -0,0 +1,3 @@
+MD5 (ompload) = 2098a2c1b44396de3e0ae42801f626b1
+SHA256 (ompload) = f2a1459ac465265fb42c82de4280196a573144f4d9b5544ff1fa1e7e9e548944
+SIZE (ompload) = 3742
diff --git a/www/ompload/pkg-descr b/www/ompload/pkg-descr
new file mode 100644
index 000000000000..58aa03f22834
--- /dev/null
+++ b/www/ompload/pkg-descr
@@ -0,0 +1,2 @@
+Ruby script for upload files on omploader.org
+WWW: http://omploader.org/ompload