aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-ASP
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-29 18:06:16 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-29 18:06:16 +0000
commit3cb0da9c632cc05ba677c99662626ef7da5c0208 (patch)
tree6667ac14ae606aab4a0c3f0c553ed3489784f2ea /www/p5-Apache-ASP
parent3d460b347bdd89bdce919c88c96ed2e94da4ca5d (diff)
downloadports-3cb0da9c632cc05ba677c99662626ef7da5c0208.tar.gz
ports-3cb0da9c632cc05ba677c99662626ef7da5c0208.zip
upgrade to 2.33
take maintainership PR: 38691 Submitted by: Erwin Lansing <erwin@lansing.dk>
Notes
Notes: svn path=/head/; revision=60254
Diffstat (limited to 'www/p5-Apache-ASP')
-rw-r--r--www/p5-Apache-ASP/Makefile11
-rw-r--r--www/p5-Apache-ASP/distinfo2
-rw-r--r--www/p5-Apache-ASP/pkg-plist29
3 files changed, 37 insertions, 5 deletions
diff --git a/www/p5-Apache-ASP/Makefile b/www/p5-Apache-ASP/Makefile
index 3bc8cee40bf1..77f42e2e8fd5 100644
--- a/www/p5-Apache-ASP/Makefile
+++ b/www/p5-Apache-ASP/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= Apache-ASP
-PORTVERSION= 2.17
+PORTVERSION= 2.33
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Apache
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= erwin@lansing.dk
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Apache/Filter.pm:${PORTSDIR}/www/p5-Apache-Filter \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Apache/SSI.pm:${PORTSDIR}/www/p5-Apache-SSI \
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Apache/Filter.pm:${P
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/Clean.pm:${PORTSDIR}/www/p5-HTML-Clean \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/FillInForm.pm:${PORTSDIR}/www/p5-HTML-FillInForm \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTTP/Date.pm:${PORTSDIR}/www/p5-libwww \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MLDBM.pm:${PORTSDIR}/databases/p5-MLDBM \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MLDBM/Sync.pm:${PORTSDIR}/databases/p5-MLDBM-Sync \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Tie/Cache.pm:${PORTSDIR}/devel/p5-Tie-Cache \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/XSLT.pm:${PORTSDIR}/textproc/p5-XML-XSLT \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
@@ -28,11 +28,14 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Apache/Filter.pm:${P
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Sablotron.pm:${PORTSDIR}/textproc/p5-XML-Sablotron
+RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
+MAN1= asp-perl.1
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Apache::ASP.3 \
- Bundle::Apache::ASP.3
+ Bundle::Apache::ASP.3 \
+ Bundle::Apache::ASP::Extra.3
.include <bsd.port.mk>
diff --git a/www/p5-Apache-ASP/distinfo b/www/p5-Apache-ASP/distinfo
index 26b048c2869c..2ad2cd7eb213 100644
--- a/www/p5-Apache-ASP/distinfo
+++ b/www/p5-Apache-ASP/distinfo
@@ -1 +1 @@
-MD5 (Apache-ASP-2.17.tar.gz) = 9770f9741a936e9c5414544d3df713a3
+MD5 (Apache-ASP-2.33.tar.gz) = 3ab8cb7eb6ed05a70396b91360f8f494
diff --git a/www/p5-Apache-ASP/pkg-plist b/www/p5-Apache-ASP/pkg-plist
index 6fb6361f5ed9..6156d76dc07e 100644
--- a/www/p5-Apache-ASP/pkg-plist
+++ b/www/p5-Apache-ASP/pkg-plist
@@ -1,8 +1,37 @@
+bin/asp-perl
lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Application.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/CGI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/CGI/Test.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Collection.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/CollectionItem.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Date.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Error.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/GlobalASA.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Lang/PerlScript.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Load.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Request.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Response.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/STDERR.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Server.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Session.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Share/CORE.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Share/CORE/MailErrors.inc
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Share/CORE/MailErrorsHTML.inc
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/StatINC.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/State.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/StateManager.pm
lib/perl5/site_perl/%%PERL_VER%%/Bundle/Apache/ASP.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bundle/Apache/ASP/Extra.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/ASP/.packlist
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/ASP
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/CGI
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Lang
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Share/CORE
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP/Share
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bundle/Apache/ASP
@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bundle/Apache
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Bundle/Apache 2>/dev/null || true
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Apache 2>/dev/null || true