aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-NNTPGateway
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-05-27 02:15:02 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-05-27 02:15:02 +0000
commitd01082dac50f71caa3abf42f35e0bd967a3ae381 (patch)
treedb635209166005905b6135eb4e1cba0fc57f196f /www/p5-Apache-NNTPGateway
parentdc17d3ead2235a6561394e9dabff4accdedb9be0 (diff)
downloadports-d01082dac50f71caa3abf42f35e0bd967a3ae381.tar.gz
ports-d01082dac50f71caa3abf42f35e0bd967a3ae381.zip
A NNTP interface for mod_perl enabled Apache web server
PR: ports/24347 Submitted by: Sergey Skvortsov <skv@protey.ru>
Notes
Notes: svn path=/head/; revision=43099
Diffstat (limited to 'www/p5-Apache-NNTPGateway')
-rw-r--r--www/p5-Apache-NNTPGateway/Makefile29
-rw-r--r--www/p5-Apache-NNTPGateway/distinfo1
-rw-r--r--www/p5-Apache-NNTPGateway/files/patch-NNTPGateway.pm19
-rw-r--r--www/p5-Apache-NNTPGateway/pkg-comment1
-rw-r--r--www/p5-Apache-NNTPGateway/pkg-descr1
-rw-r--r--www/p5-Apache-NNTPGateway/pkg-plist5
6 files changed, 56 insertions, 0 deletions
diff --git a/www/p5-Apache-NNTPGateway/Makefile b/www/p5-Apache-NNTPGateway/Makefile
new file mode 100644
index 000000000000..cd434062272b
--- /dev/null
+++ b/www/p5-Apache-NNTPGateway/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Apache::NNTPGateway
+# Date created: 15 Jan 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-NNTPGateway
+PORTVERSION= 0.8
+CATEGORIES= www news perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/NNTPGateway-${PORTVERSION}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Apache::NNTPGateway.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-NNTPGateway/distinfo b/www/p5-Apache-NNTPGateway/distinfo
new file mode 100644
index 000000000000..9550b2aac3d1
--- /dev/null
+++ b/www/p5-Apache-NNTPGateway/distinfo
@@ -0,0 +1 @@
+MD5 (Apache-NNTPGateway-0.8.tar.gz) = ed210853017145dbb3376f09ba677813
diff --git a/www/p5-Apache-NNTPGateway/files/patch-NNTPGateway.pm b/www/p5-Apache-NNTPGateway/files/patch-NNTPGateway.pm
new file mode 100644
index 000000000000..bc6f56656340
--- /dev/null
+++ b/www/p5-Apache-NNTPGateway/files/patch-NNTPGateway.pm
@@ -0,0 +1,19 @@
+*** NNTPGateway.pm.orig Mon Jan 15 18:13:44 2001
+--- NNTPGateway.pm Mon Jan 15 18:14:10 2001
+***************
+*** 99,105 ****
+ # MESSAGES, stuff that is printed on the users's screen...
+ # The current default language: Should be an entry in Messages_Map &
+ # LANGS_OK
+! my $USR_LANG = 'fr';
+ # Allowed languages choice.
+ my %LANGS_OK = ( 'fr' => 1, 'en' => 1 );
+ # All messages that could be printed.
+--- 99,105 ----
+ # MESSAGES, stuff that is printed on the users's screen...
+ # The current default language: Should be an entry in Messages_Map &
+ # LANGS_OK
+! my $USR_LANG = 'en';
+ # Allowed languages choice.
+ my %LANGS_OK = ( 'fr' => 1, 'en' => 1 );
+ # All messages that could be printed.
diff --git a/www/p5-Apache-NNTPGateway/pkg-comment b/www/p5-Apache-NNTPGateway/pkg-comment
new file mode 100644
index 000000000000..63504cce915e
--- /dev/null
+++ b/www/p5-Apache-NNTPGateway/pkg-comment
@@ -0,0 +1 @@
+A NNTP interface for mod_perl enabled Apache web server
diff --git a/www/p5-Apache-NNTPGateway/pkg-descr b/www/p5-Apache-NNTPGateway/pkg-descr
new file mode 100644
index 000000000000..8df1046d3ed8
--- /dev/null
+++ b/www/p5-Apache-NNTPGateway/pkg-descr
@@ -0,0 +1 @@
+Apache::NNTPGateway - A NNTP interface for mod_perl enabled Apache web server
diff --git a/www/p5-Apache-NNTPGateway/pkg-plist b/www/p5-Apache-NNTPGateway/pkg-plist
new file mode 100644
index 000000000000..f82cde879818
--- /dev/null
+++ b/www/p5-Apache-NNTPGateway/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/NNTPGateway/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Apache/NNTPGateway.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/NNTPGateway
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Apache 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache 2>/dev/null || true