aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-ParseFormData/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-10-12 10:52:12 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-10-12 10:52:12 +0000
commit95683ec9125669c2bc05b9382e1d03508d2b4511 (patch)
tree7276e3ad6b422dcd0fead773de8689f8fc40ca89 /www/p5-Apache-ParseFormData/Makefile
parent7c9b9c3c4960b3387646e974a41c71639d79d7fe (diff)
downloadports-95683ec9125669c2bc05b9382e1d03508d2b4511.tar.gz
ports-95683ec9125669c2bc05b9382e1d03508d2b4511.zip
Add p5-Apache-ParseFormData 0.09, module allows you to easily
decode/parse form and query data. PR: ports/68993 Submitted by: Jon Nistor <nistor@snickers.org>
Notes
Notes: svn path=/head/; revision=118929
Diffstat (limited to 'www/p5-Apache-ParseFormData/Makefile')
-rw-r--r--www/p5-Apache-ParseFormData/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/p5-Apache-ParseFormData/Makefile b/www/p5-Apache-ParseFormData/Makefile
new file mode 100644
index 000000000000..da2426e42bf3
--- /dev/null
+++ b/www/p5-Apache-ParseFormData/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Apache-ParseFormData
+# Date created: 13-Jul-2004
+# Whom: Jon Nistor <nistor@snickers.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-ParseFormData
+PORTVERSION= 0.09
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nistor@snickers.org
+COMMENT= Module allows you to easily decode/parse form and query data
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2/mod_perl.pm:${PORTSDIR}/www/mod_perl2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Apache::ParseFormData.3
+
+.include <bsd.port.pre.mk>
+
+# mod_perl 2 requires it
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>