aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-Session-PHP/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-18 06:33:13 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-18 06:33:13 +0000
commit8a905ff3204fe00d7006820db88ef645fb3d21d3 (patch)
treeb53209c94e56cff31ced3144f273a688d99edf2d /www/p5-Apache-Session-PHP/Makefile
parent588f799d6e2c90087f3daed549460fd8bb9888b5 (diff)
downloadports-8a905ff3204fe00d7006820db88ef645fb3d21d3.tar.gz
ports-8a905ff3204fe00d7006820db88ef645fb3d21d3.zip
New port www/p5-Apache-Session-PHP
Glue Apache::Session with PHP::Session PR: ports/51034 Submitted by: Mathieu Arnold <m@absolight.net>
Notes
Notes: svn path=/head/; revision=79208
Diffstat (limited to 'www/p5-Apache-Session-PHP/Makefile')
-rw-r--r--www/p5-Apache-Session-PHP/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/www/p5-Apache-Session-PHP/Makefile b/www/p5-Apache-Session-PHP/Makefile
new file mode 100644
index 000000000000..e29ef120788a
--- /dev/null
+++ b/www/p5-Apache-Session-PHP/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Apache-Session-PHP
+# Date created: 16 April 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Session-PHP
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Glue Apache::Session with PHP::Session
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/PHP/Session.pm:${PORTSDIR}/www/p5-PHP-Session \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Apache/Session.pm:${PORTSDIR}/www/p5-Apache-Session \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Apache::Session::PHP.3 Apache::Session::Serialize::PHP.3 Apache::Session::Store::PHP.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>