aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-Singleton
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-03-12 12:09:31 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-03-12 12:09:31 +0000
commit9f7101ca5e222efdd8e81dbe443b249a7868991e (patch)
tree1e4f5a8c175fee01eb6eee28b1dfc4cb24bf1a5c /www/p5-Apache-Singleton
parentba0757c84fb919622877e706db02483ce8a7f688 (diff)
downloadports-9f7101ca5e222efdd8e81dbe443b249a7868991e.tar.gz
ports-9f7101ca5e222efdd8e81dbe443b249a7868991e.zip
Apache::Singleton is adapted Class::Singleton for apache
PR: ports/78211 Submitted by: ports@c0decafe.net
Notes
Notes: svn path=/head/; revision=131014
Diffstat (limited to 'www/p5-Apache-Singleton')
-rw-r--r--www/p5-Apache-Singleton/Makefile26
-rw-r--r--www/p5-Apache-Singleton/distinfo2
-rw-r--r--www/p5-Apache-Singleton/pkg-descr5
-rw-r--r--www/p5-Apache-Singleton/pkg-plist9
4 files changed, 42 insertions, 0 deletions
diff --git a/www/p5-Apache-Singleton/Makefile b/www/p5-Apache-Singleton/Makefile
new file mode 100644
index 000000000000..386e7cb19576
--- /dev/null
+++ b/www/p5-Apache-Singleton/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Apache-Singleton
+# Date created: 2005-02-28
+# Whom: ports@c0decafe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Singleton
+PORTVERSION= 0.07
+CATEGORIES= www devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= Singleton class for mod_perl
+
+RUN_DEPENDS=${SITE_PERL}/Class/Singleton.pm:${PORTSDIR}/devel/p5-Class-Singleton
+
+PERL_CONFIGURE= yes
+
+MAN3= Apache::Singleton.3 \
+ Apache::Singleton::Process.3 \
+ Apache::Singleton::Request.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-Singleton/distinfo b/www/p5-Apache-Singleton/distinfo
new file mode 100644
index 000000000000..330c6df9175e
--- /dev/null
+++ b/www/p5-Apache-Singleton/distinfo
@@ -0,0 +1,2 @@
+MD5 (Apache-Singleton-0.07.tar.gz) = 5a260c20dc8d4f73c3e050d56a39fd36
+SIZE (Apache-Singleton-0.07.tar.gz) = 3275
diff --git a/www/p5-Apache-Singleton/pkg-descr b/www/p5-Apache-Singleton/pkg-descr
new file mode 100644
index 000000000000..092c7afc3c65
--- /dev/null
+++ b/www/p5-Apache-Singleton/pkg-descr
@@ -0,0 +1,5 @@
+Apache::Singleton works the same as Class::Singleton, but with
+various object lifetime adapted for use under Apache.
+
+Author: Tatsuhiko Miyagawa <miyagawa@bulknews.net>
+WWW: http://search.cpan.org/~miyagawa/Apache-Singleton/
diff --git a/www/p5-Apache-Singleton/pkg-plist b/www/p5-Apache-Singleton/pkg-plist
new file mode 100644
index 000000000000..d553ab236f05
--- /dev/null
+++ b/www/p5-Apache-Singleton/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Singleton/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Singleton
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache 2>/dev/null || true
+%%SITE_PERL%%/Apache/Singleton.pm
+%%SITE_PERL%%/Apache/Singleton/Process.pm
+%%SITE_PERL%%/Apache/Singleton/Request.pm
+@dirrm %%SITE_PERL%%/Apache/Singleton
+@unexec rmdir %D/%%SITE_PERL%%/Apache 2>/dev/null || true