aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Application-Plugin-Stream
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-12-07 10:18:15 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-12-07 10:18:15 +0000
commitdad55a4d439cda5cdb0e2b0b55a7fa522e3959f1 (patch)
tree2f42f896248edc447db564319d0376d280e09b9e /www/p5-CGI-Application-Plugin-Stream
parentb7e78ef9b88574c24e114f9a3ec5cca1e8ffadd5 (diff)
downloadports-dad55a4d439cda5cdb0e2b0b55a7fa522e3959f1.tar.gz
ports-dad55a4d439cda5cdb0e2b0b55a7fa522e3959f1.zip
Add p5-CGI-Application-Plugin-Stream 2.05, plugin that adds file
streaming support to CGI::Application. PR: ports/103387 Submitted by: George Hartzell <hartzell at alerce.com>
Notes
Notes: svn path=/head/; revision=179103
Diffstat (limited to 'www/p5-CGI-Application-Plugin-Stream')
-rw-r--r--www/p5-CGI-Application-Plugin-Stream/Makefile31
-rw-r--r--www/p5-CGI-Application-Plugin-Stream/distinfo3
-rw-r--r--www/p5-CGI-Application-Plugin-Stream/pkg-descr17
-rw-r--r--www/p5-CGI-Application-Plugin-Stream/pkg-plist4
4 files changed, 55 insertions, 0 deletions
diff --git a/www/p5-CGI-Application-Plugin-Stream/Makefile b/www/p5-CGI-Application-Plugin-Stream/Makefile
new file mode 100644
index 000000000000..ea85a8226efe
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-Stream/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: www/p5-CGI-Application-Plugin-Stream
+# Date created: 14 September 2005
+# Whom: George Hartzell <hartzell@alerce.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Application-Plugin-Stream
+PORTVERSION= 2.05
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hartzell@alerce.com
+COMMENT= Plugin that adds file streaming support to CGI::Application
+
+BUILD_DEPENDS= ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application \
+ ${SITE_PERL}/CGI/Application/Plugin/AutoRunmode.pm:${PORTSDIR}/www/p5-CGI-Application-Plugin-AutoRunmode \
+ ${SITE_PERL}/File/MMagic.pm:${PORTSDIR}/devel/p5-File-MMagic
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= CGI::Application::Plugin::Stream.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or newer. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-CGI-Application-Plugin-Stream/distinfo b/www/p5-CGI-Application-Plugin-Stream/distinfo
new file mode 100644
index 000000000000..3efc31cab876
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-Stream/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Application-Plugin-Stream-2.05.tar.gz) = 687a6be94eada6f499b3842596935231
+SHA256 (CGI-Application-Plugin-Stream-2.05.tar.gz) = 9c3554ea4df4d78bb28c263ef35fb1213a3cb33181c025e9f481eb9a7fc661a1
+SIZE (CGI-Application-Plugin-Stream-2.05.tar.gz) = 5523
diff --git a/www/p5-CGI-Application-Plugin-Stream/pkg-descr b/www/p5-CGI-Application-Plugin-Stream/pkg-descr
new file mode 100644
index 000000000000..428d61a958dd
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-Stream/pkg-descr
@@ -0,0 +1,17 @@
+This plugin provides a way to stream a file back to the user.
+
+This is useful if you are creating a PDF or Spreadsheet document
+dynamically to deliver to the user.
+
+The file is read and printed in small chunks to keep memory
+consumption down.
+
+This plugin is a consumer, as in your runmode shouldn't try to do any
+output or anything afterwards. This plugin affects the HTTP response
+headers, so anything you do afterwards will probably not work. If you
+pass along a filehandle, we'll make sure to close it for you.
+
+It's recommended that you increment $| (or set it to 1), which will
+autoflush the buffer as your application is streaming out the file.
+
+WWW: http://search.cpan.org/dist/CGI-Application-Plugin-Stream/
diff --git a/www/p5-CGI-Application-Plugin-Stream/pkg-plist b/www/p5-CGI-Application-Plugin-Stream/pkg-plist
new file mode 100644
index 000000000000..ecae73f21e3d
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-Stream/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/CGI/Application/Plugin/Stream.pm
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin
+@dirrmtry %%SITE_PERL%%/CGI/Application
+@dirrmtry %%SITE_PERL%%/CGI