aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI.pm
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-07-12 21:05:08 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-07-12 21:05:08 +0000
commit6969400487102b7200ec771cdf201458f721c5ab (patch)
tree96deaf00e06091df93881550c710f262b60fbbe5 /www/p5-CGI.pm
parent03b00b389d0521c9d54309a790ece2ce35b195e3 (diff)
downloadports-6969400487102b7200ec771cdf201458f721c5ab.tar.gz
ports-6969400487102b7200ec771cdf201458f721c5ab.zip
Add p5-CGI.pm - the updated version of the CGI.pm from the base system.
Requested by: many OK'ed by: markm
Notes
Notes: svn path=/head/; revision=45082
Diffstat (limited to 'www/p5-CGI.pm')
-rw-r--r--www/p5-CGI.pm/Makefile26
-rw-r--r--www/p5-CGI.pm/distinfo1
-rw-r--r--www/p5-CGI.pm/pkg-comment1
-rw-r--r--www/p5-CGI.pm/pkg-descr9
-rw-r--r--www/p5-CGI.pm/pkg-plist12
5 files changed, 49 insertions, 0 deletions
diff --git a/www/p5-CGI.pm/Makefile b/www/p5-CGI.pm/Makefile
new file mode 100644
index 000000000000..b3356d72feaf
--- /dev/null
+++ b/www/p5-CGI.pm/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: www/p5-CGI.pm
+# Date created: 12 July 2001
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI.pm
+PORTVERSION= 2.753
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI.3 CGI::Apache.3 CGI::Carp.3 CGI::Cookie.3 CGI::Fast.3 \
+ CGI::Pretty.3 CGI::Push.3 CGI::Switch.3 CGI::Util.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+pre-patch:
+ @${PERL} -pi -e '$$_ = "" if /INSTALLDIRS/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI.pm/distinfo b/www/p5-CGI.pm/distinfo
new file mode 100644
index 000000000000..d219fba87624
--- /dev/null
+++ b/www/p5-CGI.pm/distinfo
@@ -0,0 +1 @@
+MD5 (CGI.pm-2.753.tar.gz) = ea1241dc3fda30b56a353b24b151ab28
diff --git a/www/p5-CGI.pm/pkg-comment b/www/p5-CGI.pm/pkg-comment
new file mode 100644
index 000000000000..52666efe941f
--- /dev/null
+++ b/www/p5-CGI.pm/pkg-comment
@@ -0,0 +1 @@
+CGI.pm - Simple Common Gateway Interface Class
diff --git a/www/p5-CGI.pm/pkg-descr b/www/p5-CGI.pm/pkg-descr
new file mode 100644
index 000000000000..ca36d69b5cbe
--- /dev/null
+++ b/www/p5-CGI.pm/pkg-descr
@@ -0,0 +1,9 @@
+There are two styles of programming with CGI.pm, an object-oriented
+style and a function-oriented style. In the object-oriented style you
+create one or more CGI objects and then use object methods to create the
+various elements of the page. Each CGI object starts out with the list
+of named parameters that were passed to your CGI script by the server.
+You can modify the objects, save them to a file or database and recreate
+them. Because each object corresponds to the "state" of the CGI script,
+and because each object's parameter list is independent of the others,
+this allows you to save the state of the script and restore it later.
diff --git a/www/p5-CGI.pm/pkg-plist b/www/p5-CGI.pm/pkg-plist
new file mode 100644
index 000000000000..2a00e0eb0488
--- /dev/null
+++ b/www/p5-CGI.pm/pkg-plist
@@ -0,0 +1,12 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CGI/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/CGI.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Push.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Pretty.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Fast.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Switch.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Carp.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Apache.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Util.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Cookie.pm
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CGI 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/CGI 2>/dev/null || true