aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI.pm
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2002-09-17 20:35:02 +0000
committerAnton Berezin <tobez@FreeBSD.org>2002-09-17 20:35:02 +0000
commit865be3a81c5f39063c2c03c740c6446957fde778 (patch)
treeddb257c9ea6f7026e20007903e321ac03f9f28fb /www/p5-CGI.pm
parentffda1d7db2d95b54a468520e4021647f893dc49d (diff)
downloadports-865be3a81c5f39063c2c03c740c6446957fde778.tar.gz
ports-865be3a81c5f39063c2c03c740c6446957fde778.zip
Long overdue update of CGI.pm:
- update to 2.86; - bump portepoch (previous version 2.753 > 2.86); - remove the requirement for 5.6.0, since it is only true for `use integer' CGI scripts; - add WWW.
Notes
Notes: svn path=/head/; revision=66534
Diffstat (limited to 'www/p5-CGI.pm')
-rw-r--r--www/p5-CGI.pm/Makefile8
-rw-r--r--www/p5-CGI.pm/distinfo2
-rw-r--r--www/p5-CGI.pm/pkg-descr2
3 files changed, 9 insertions, 3 deletions
diff --git a/www/p5-CGI.pm/Makefile b/www/p5-CGI.pm/Makefile
index b3356d72feaf..a05f44645425 100644
--- a/www/p5-CGI.pm/Makefile
+++ b/www/p5-CGI.pm/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= CGI.pm
-PORTVERSION= 2.753
+PORTVERSION= 2.86
+PORTEPOCH= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= CGI
@@ -14,6 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
MAN3= CGI.3 CGI::Apache.3 CGI::Carp.3 CGI::Cookie.3 CGI::Fast.3 \
@@ -21,6 +25,6 @@ MAN3= CGI.3 CGI::Apache.3 CGI::Carp.3 CGI::Cookie.3 CGI::Fast.3 \
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
pre-patch:
- @${PERL} -pi -e '$$_ = "" if /INSTALLDIRS/' ${WRKSRC}/Makefile.PL
+ @${PERL} -pi -e '$$_ = "" if /INSTALLDIRS|5\.6\.0/' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/www/p5-CGI.pm/distinfo b/www/p5-CGI.pm/distinfo
index d219fba87624..4846ef5a78c6 100644
--- a/www/p5-CGI.pm/distinfo
+++ b/www/p5-CGI.pm/distinfo
@@ -1 +1 @@
-MD5 (CGI.pm-2.753.tar.gz) = ea1241dc3fda30b56a353b24b151ab28
+MD5 (CGI.pm-2.86.tar.gz) = fd85467f10648115d8ea203915a6ef5d
diff --git a/www/p5-CGI.pm/pkg-descr b/www/p5-CGI.pm/pkg-descr
index ca36d69b5cbe..384b0297f978 100644
--- a/www/p5-CGI.pm/pkg-descr
+++ b/www/p5-CGI.pm/pkg-descr
@@ -7,3 +7,5 @@ You can modify the objects, save them to a file or database and recreate
them. Because each object corresponds to the "state" of the CGI script,
and because each object's parameter list is independent of the others,
this allows you to save the state of the script and restore it later.
+
+WWW: http://search.cpan.org/search?dist=CGI.pm